1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

ps2 keyboard problem, only on boot

By smithcferg ยท 4 replies
Oct 13, 2005
  1. Hi.

    I have a IBM Netvista 6794-xx3 minitower computer that has a strange boot up problem. I have no keyboard functionality in the bios, though it works perfectly in win2k.

    I am using a ps2 keyboard. There is startup menu during post that gives the user an opportunity to access the bios or IBM recovery software. Sometimes the keys (F1 or F11) for these functions work, sometimes they don't.

    When I can get into the bios, I see the first bios page (System info), but none of the keys work there. Same for when I enter the Application Recovery Menu - I can see the menu but can't use the keyboard here. Also, when I boot into win2k, the F8 option key that leads to the safeboot menu never works. However, in Win2k the keyboard works perfectly. This functionality was confirmed with PC Doctor for Windows - every key works right.

    Possible additional circumstances:
    Just before this problem was observed I discovered my computer had been compromised with a trojan (at least one) and several viruses. I ran a trojan scanner called Tauscan, and have been using Norton Antivirus corporate edition, and adaware software. In addition, around the time this problem started I had installed a new network card.

    I have tried 2 other keyboards (both Ps2) and have had exactly the same results with these keyboards also - two of the three keyboards are known to work on other computers, the third was a new one. I don't have a usb keyboard to try. The ps2 keyboard is plugged into the ps2 port closest to the side of the computer, which is the proper ps2 port for keyboards on this computer.

    I have also tried removing all usb devices and the networking card that I had installed. I have reflashed the bios two times using a windows bios flashing program designed for this computer. I tried using both the current bios and a backlevel bios just to see if either would cure the problem.

    The ps2 mouse works fine.

    Has anyone heard of a problem like this before? Can this problem be the result of a virus or an altered boot record, etc.? Has anyone heard of a ps2 port that fails in such a way on boot up, but always perfectly in win2k? What would be a good {hopefully free: )} diagnostic for testing ps2 ports - pc doctor focused on keyboard functionality only.

    Any and all ideas are welcome! Thanks in advance.

  2. smithcferg

    smithcferg TS Rookie Topic Starter

    p.s. Sorry about the strange formatting - I copied the text in from Notepad. Formatting is now repaired.
  3. smithcferg

    smithcferg TS Rookie Topic Starter

    additional info


    No keyboard error messages are reported on bootup. No post errors of any kind, and no beep errors. In all other respects, boot is normal.

    During boot, the three leds flash at the same time twice, the way they would normally do on boot.

    Thanks again for the help,

  4. smithcferg

    smithcferg TS Rookie Topic Starter

    found answer in another forum

    It turns out that not only my keyboard had been disabled, but also my a: floppy diskette!

    When I have cleared the bios I regained access to the floppy drive, and when I reflashed it from a boot disk, rather than from the operating system, I regained use of the ps/2 keyboard on boot.

    It seems these are functions that can be removed in the bios, and there is also a feature in the bios which allows for remote bios configuration/flashing without password. So who knows how it got to the state it was in!

    I am still finding trojans popping up on the computer.

    Got this useful tip to clear bios and reflash from someone in another tech forum.

    Have a good day all.


  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...