Radeon 9600 + Direct X 9.1 + Any Game = Extreme Lag!

Status
Not open for further replies.

Afrokid

Posts: 10   +0
I have a Radeon 9600, and i just installed Direct X v9.1 from the microsoft website. When eve i run a game [ex: Halo, Warcraft, Guild Wars] i get massive lag even when im in one player! I can start up / setup the game perfectly but when i get into the game i have massive lag! Multiplayer is out of the question! Doesa anyone know whats wrong? I recently installed Direct X so could this be it?
 

shadow_29

Posts: 208   +0
ok the lad might be because of anything.what resolution are you running the game on?explain lag -slow fps or slow response when you do something.you might wanna check for any background program eating up your resources and your keyboard/mouse.
 

tbrunt3

Posts: 308   +0
Welcome To Techspot Afrokid

Please provide us with more computer specs.. We already know what video card you have. Help us help you.
 

olefarte

Posts: 1,314   +13
As Shadow said, define lag, is it stuttering, as in, does your image jump accross the screen, instead of being smooth? Is this a new install for the video card? What are your computer specs?

Try turning down, or off, AA and AF, in the video card Control Panel. Turn off Vsync. if enabled. Check any setting and lower them. In the game itself, do the same thing, in the settings. And as Shadow said, use a lower reoslution. If any of this works, then try raising your settings a little at a time to where it starts lagging again, then back off some. And as he also said, check for any background programs running. Turn off your virus scanner while you are playing, just to see if that makes a difference.
 

Afrokid

Posts: 10   +0
Sorry, it just says direct x 9 . BTW my comp is a VPR Matrix with 1.8 ghz and 512 mb ram. Its kinda hard to explain. When ever i move its very sluggish, and not up to par with my old standards. When ever i click on something, it starts to freeze, but after like a second or two it goes back to normal. I tried fixing the resolutions but that didn't work at all.
 

olefarte

Posts: 1,314   +13
A couple more ideas, as I have had the same thing in the past. Have you defragged lately. Have you got the latest vidio drivers. How much virtual memory do you have. As a VERY general rule of thumb, set it to one and a half times you ram, set minimum and maximum to the same value. Maybe try setting it to twice you ram it that doesn't work, probably no more than that needed. Unless somebody disagrees with me, there's some debate on how much VM you need..
 

Afrokid

Posts: 10   +0
i just defragged it, but that didn't work. I ran just about every virus / adware program i have but that didn't work either. How do i access video memory? Can u give me a simple step by step guide?

I also downloaded every recent update, and driver for the ati system >.< , but that didn't work either.
 

ProtoProtoss

Posts: 10   +0
How long have you been experiencing the lag?

If you have SP2, windows has a restriction on the amount of connetions it will allow, which is defaulted at 10. There is a fix to raise it to unlimited or 50 or whatever you set it to.
 

tbrunt3

Posts: 308   +0
Update your motherboard drivers some people update there video card all the time but forget to update there motherboard chipset driver wich is very important too...Make sure you AGP apagure size did not get changed.
 

Afrokid

Posts: 10   +0
i had the 9600 for quite some time, and i didn't download anything else besides Direct X. Everything ran perfectly, until the day after i downloaded Direct X, then it all got screwed up.
 

ProtoProtoss

Posts: 10   +0
I honestly have no clue for this one, but DirectX obviously is interfering with something. If you don't absolutely NEED the newest DirectX, try reverting back to the older one you had and see if it fixes anything. Maybe the installation somehow had an error and corrupted a driver, I dunno...
 

tbrunt3

Posts: 308   +0
go to start run

In box type dxdiag let this run on the bottom you will see the version of dx you are running also here make sure full graphics is set right...basically see if anything has changed here.Have you tried to disable the GPU recovery in the ATI control panel.
 

Afrokid

Posts: 10   +0
wow, i cant get my computer to work. I tried everything you guys suggested. I think i might bring it back to best buy for them to check on it. >.<
 
Status
Not open for further replies.