RAID 0 Failure

By Overmind1984 ยท 11 replies
Jul 8, 2004
  1. I have(had) a raid 0 setup with two WD 200GB SE's. I boot up the other day to find out one of them is faulty. Please keep the back up flames down to a dull roar. :) I know I may have lost everything, but I don't feel like giving in so easily. Is there anything I could do to try to recover the data, how would you guys go about trying to salvage the unsalvagable? You suggestions are greatly appreciated.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You have a stripe over 2 disks, and now you have lost 1 disk, and you have no backup?

    I don't fancy your chances.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Do you know why your controller is reporting a bad container / array?

    Are one of the drives faulty? Perhaps one became unplugged or a cable is loose?

    First, determine why the container / array is bad

    DO NOT RUN ANY SORT OF FILE SYSTEM CHECKER ON A SINGLE DRIVE FROM AN ARRAY. This includes scandisk, chkdsk etc... Use only manufacturer's disk diagnostics or known file system independant utilities. I've never done it before, but I'm assuming it will probably wipe out your data quicker than you can cancel. ;)

    Disconnect the drives from your controller and run drive diagnostics independantly on each drive using the IDE channel (if possible). If you are using SATA or SCSI, run the drives in non-RAID mode. For utilities, please check out this thread:

    If one drive fails the test...
    Try running a program like HDD Regnerator (also see above thread)

    If one drive is not detected or is making funny noises...
    This is a very serious problem which may be the result of bad electronics or mechanics. Sometimes this is repairable by the end user, but not often.

    If both drives pass the diagnostics
    Reconnect your array and double check your cables. There may have been a loose cable somewhere in the mix. You may also have an intermittent drive which the diagnostic utilities may not be able to detect reliably.

    Recreate your array
    Once you determine your drives are good, or repair your drive(s) individually, you can move on to the next step. The data on both drives independantly is nearly useless, but you may be able to ressurect your RAID 0 deleting and recreating the array. Please be sure that your controller does not initialize/format the array by default. All RAID controllers I've worked with will prompt you first before initalizing the array. Initialization is a nice way of saying "quick format".

    Basically, each drive has half of your data. If things get out of sync, your data is still there, but the controller can't sort it out.

    You can safely delete an array (how your data looks to the controller) without deleting the data on the drives (Your data on the physical drives). Once you create a new array using the drives and the same parameters as the original array, the controller should use your existing data as the array. Everythign should be back to normal now.

    Please be very careful! I care about your data, but I am not going to take responsibility for any misinformation or misintpretation regarding this post. Just trying to help you out. :)


    If your data is remotely important to you, you should always back it up. While it is unfortunate, I hope you have learned a lesson from this.
  4. Overmind1984

    Overmind1984 TS Rookie Topic Starter

    Thanks for the help, it was really appreciated. I know I should have backed up my data, but never got around to it. Thanks again.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You should certainly back up anything on a RAID 0 array.

    Its 2 times more likely to fail, now.

    As you see, only one disk went bad, but you lost the contents of both.
  6. Glowplug

    Glowplug TS Rookie

    ABIT TH7II-Raid 0 HD hang

    I recently have had problems with my computer hanging for no apparent reason. It appears related to the hard drive. I hear a series of access noises: 1-2-3-4 short pause 1-2-3-4 then a longer pause and the process repeats for about a dozen times (sometimes hangs for 10s of minutes and requires a hard restart). Looking at the task manager, I can't see any program in particular soaking up CPU time (system idle and explore at a 97/3% ratio). When this happens you can't select anything but the mouse still moves.

    This machine is about 2.5 years old and has been very reliable. The only set point of when this started appears sometime after the SP-2 package was installed. I don't recall any install problems. I do disk defrag/clean-up regularly and I use VCOM Fix-it to clean up the registry (which given the cold/warm restarts tends to get trashed - lots of lost file connections). The problem seems progressive in its frequency.

    I have a TH7II-Raid mobo recently upgraded to -EH bios from -38 bios, onboard Highpoint RAID controller, 1 GB of Rambus memory, Asylum NVidia 5700 video card, P4 2.0a CPU, two 30 GB matched IBM (60 GXP series) drives in RAID 0 format, 400w power supply, and the CPU temp from the BIOS is 40C and I recently pulled the CPU and heat sink, cleaned and reconnected with Artic Silver. I'm running WinXP with NTFS format.

    I've used the IBM/Hitachi Drive Fitness Test diagnostic in the ATA mode which means it looked at each drive (there were not disconnected but tested from the bootable floppy drive with the DFT SW). One drive reported a "failure code: 0x70 defective device" with a Tech result code: 70009596. Basically there were one or more corrupted sectors. The DFT tool said it could either rewrite (I assume format and map out the bad sectors) or try a sector fix with "some data" loss. The other drive (same type) did not report any problems. I'd much rather some tool that could look at the "RAID 0" drive from WinXP and do this sort of fix since then I would have a better chance of not losing the the whole array.

    Question to the forum: should it try the sector fix? Will it destroy the array? What are the odds I'll still end up with an workable system even if the array is intact? Is the drive on a death spiral and should be replaced? Is there a better way to confirm this problem or tool do it from within WinXP?

    BTW, I do have my data back-up and will do a more recent one before I try this stunt. If I have to dump the drive, I"ll just get new larger ATA IDE drive and forget the RAID use. I believe I can plug it in a bay, ghost over the current system then dump the bad drive and use the old good drive as a mirror back-up drive.

  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The DFT will happily wipe the drive and since you have a RAID0 setup, you will lose your array contents. Your best bet would be to run chkdsk from within Windows and let it scan for bad sectors.
  8. rushhh

    rushhh TS Rookie

    Thanks Risk you save my ***, I had the same thing happen I thought I lost everthing, I'v had no time to do backups but now I'm going to do it for sure...
  9. Glowplug

    Glowplug TS Rookie

    I have run chkdsk /f and it does it prior to loading windows (it asks if you want to do that way since within the cmd window it can't run /f). It only found a few lost files which it corrected. That did not solve the problem. I believe you are right about DFT so I'm not going to go that route unless I have hard evidence it will not.

    I did find a utility on the Highpoint website to "rebuild" a RAID drive from within windows. I'm going to at least run that in the diagnostic mode and see if it can do anything.

    My number one plan is still to get a third new drive and mirror my c: drive to it then dump the one RAID 0 drive that is failing. I think that is the safest approach.

    Thanks for the comment.
  10. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You have to add /r to chkdsk to make it scan for bad sectors. e.g. "chkdsk /f /r"
  11. Glowplug

    Glowplug TS Rookie

    Nodsu, thanks for the tip I'll file that for the future. Note the IBM DFT test SW did a very good job of finding the problem too.

    Here is a summary of how I replaced the failing drive:

    I hooked the new drive on one of the IDE ports as a slave and use the Seagate provided utility to do a low level format. I then used CasperXP to make a complete copy of the RAID 0 failing array to that drive. Only two (minor I believe) files did not get copied. Took 2.75 hours. I removed the dying drive. Since I decided not to create another RAID array I used one of the IDE ports to load the new drive as the master and one of the old array dirves as a slave (for backup). The new drive with the copied array info booted up just fine, but WinXP insisted on "re-registration" since the hardware had changed. That was totally automated and painless.

    On boot the old array drive as the slave was not found. I again used the Seagate disk utility and it immediately found old RAID array drive and did a low level format. On reboot it was found by the system and WinXP and was accessible.

    Thank you all for your comments. I highly recommend the CasperXP copy software. Hope this summary of the final solution helps the next person with failing hard drive.

  12. Richard Lamont

    Richard Lamont TS Rookie

    I recently booted WinXP to find it complaining that the last disk in my RAID 0 had failed. The array held many folders, each with 9000 148kb bitmap files in it.
    When I mounted the array in Linux there were no complaints and I managed to retrieve 1400 of the bitmaps from one of the folders (that I did not have backed up). I never thought that this would work since I believed that individual files were split among the four hard drives.
    Anyway, I left the system off for a while to cool down and managed to extract all 9000 files! Once my data was safe I tried WinXP again but it still complained about the last disk and stopped me from any access to the array.
    I am using an Adaptec 1200A RAID controller.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...