RAID and ASUS HDD not recognised in Win XP, but is on bios. please help

By darkspider
Aug 27, 2006
  1. hello,

    Can anyone help?

    I just bought a WD SATA 320 gb HDD and am trying to install it as an extra storage space - not a boot disk. the problem is that my mobo (ASUS K8V SE Deluxe) has two raid controllers. One is a VIA that i have two HDD's plugged in and not set up as raid - the boot disk (maxtor) is attatched to the primary and the other (storage) is connected to the secondary, and everything works fine. the second Raid controller is the promise 378 fAST TRACK controller and this is the one that i am trying to attatch the new 320gb HDD. I have updated VIA drivers, mobo bios, fastrack driver (fine in system). But Windows does not trecognise the drive.

    If i put the promise controller as an 'ide connected device' in bios i can set the boot order and use my normal drive (VIA primary contoller - maxtor) which works fine but windows doesn't recognise the new WD drive plugged into the promise controller. But if i set the promise controller to 'RAID' in the bios and use the little prog to arrange the array, so it is recognised, the boot order changes and i cant access windows!! The bios recognises that there is a drive attatched to the promise fastrack controller and attempts to boot from that - but when i go into bios and attempt to change it back to the maxtor (VIA controller) there is no option to boot from the VIA Raid Controller - only the promise.

    This is doing my head in! Has anyone any ideas as to why this is happening or any reccomendations on how to install this new drive.

    Thanks for any help.

  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Boot up windows and go to Control Panel -> Administrative Tools -> Computer Management and find the Disk management tab on the lower left. Click it and the HDD should be there. The reason it hasn't been recognised by windows is that it hasn't been formatted. Use this tab to format the drive (might take awhile).
  3. darkspider

    darkspider TS Rookie Topic Starter

    it ried that

    Hello and thanks for the response.

    I tried that but it doesn't appear in disk management or in the device manager. I tried using FDISK to create a partition - didnt recognise it. I tried formatting it using western digitals life guard tools - didnt recoginise it. I tried a miriad of things and it doesn't know its there when the bios is setup as an IDE device.

    ASUS told me to do a list of things which included how to set up the bios - this is what i had already done (set up a a raid, single drive). The trouble is that when i do it the ASUS way i cannot boot from my VIA controller as it defaults to the promise controller - there is NO option in boot priority to select the VIA controller from bios! The via controller disappears from the list - very weird.

    I checked out the promise controller last night and loaded windows onto the new drive with only the new hdd connected - it worked fine - so the controler is functioning properly, it must be the bios. But i have tried 2 different bios versions and still no joy. Its not like i haven't added a new drive before - but this has no logic to it!!

    But thanks for the help - any more suggestions?
  4. darkspider

    darkspider TS Rookie Topic Starter


    Thank you for contacting ASUS Customer Service.

    My name is ZYC, and I would be assisting you today.

    Sir, please connect that disk to the Promise ports( should be in RED),

    then Please enter bios-advanced-onboard device configuartion-onboard Promise controller,

    make sure it is set to Enabled,

    then set Operate mode to RAID mode. when you see the Promise controller detects your harddisk,

    please press CTRL+F to enter raid bios setting,

    choose option 1 auto setup to create a 1+0 stripe set for your single disk,

    save setting, boot up to windows, if you have install the Promise 387 raid driver,

    enter Windows-control panel-administrative tools-computer managment-disk management, you will find the disk here.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...