1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

RAID Unformatted Error - Please Help If Possible

By lonerayven
Jun 1, 2007

    I know I haven't posted much in the forums but I've been lurking around techspot for ages and I know how great it is but now I need help!

    Okay so I have this computer, 3 harddrives, NForce4 DFI-Lanparty motherboard, really good gpu, and an Opteron 148 processor. Just a bit of hardware info to get an idea. Aside from that, 2 of those harddrives, I believe of Hitachi brand, were set up in RAID. I didn't build this computer, but it was a built by someone and I got it for an amazing deal from that guy so I didn't get to build my own like I was planning and learn how everything works quite. Well ever since my problem occured I've researched like crazy and I know more but unfortunately I haven't found a solution to my problem.

    The Cause:
    I bought 2 gigs of OCZ ram to match my current gig, it installed fine at first but then in order to work I had to reset the CMOS, BIOS, and all other setup functions to make it reallocate the new RAM. Well stupidly, since I bought the computer ages ago, forgot about the RAID setup and forgot to reconfigure it and so, windows started, everything worked, then all of a sudden; my computer found two new drives! I looked, 2 unformatted drives and I knew what happened.

    The Problem:
    I tried to reconfigure RAID and repartition it but it wouldn't let me make it accessible because it was now "unformatted" or FAT16.
    BIG PROBLEM because I was installing the ram so I could speed up the transfer process of ALL my important files from that drive to my brand new external drive. There is about 2 years of important photos on there, I am a designer and lost about 3 years of important work, all my website data, portfolio, 2 films I was working on, and my entire game that I was designing. At first I wanted the photos off and I have a free program called PhotoRec.exe that works pretty well, minus the fact that I keep a database of templates that is about 2000 templates strong with about 200 images to each template. That's ALOT of pictures and the program has only found a few thousand of those and hasn't even reached my photos. But it is living proof that I CAN get data off.

    So far that photo program may work but it will take weeks at this rate, and that doesn't solve my gargantuan problem of everything else on that drive. I know it might not all be salvageable but I gotta try. The RAID is gonna remain unformatted until I figure it out. Some say that using a Live CD of linux helped them and so I tried "Damn Small Linux" which one forum suggested but when I tried to back out of the CD and find the HD, HDA, and HDB, directories it wouldn't leave what seemed to be the cd's directory, if there is another Live CD I should try, like Ubuntu, and someone could please guide me through it. Another thing though, I don't have the cash to buy one of these lame recovery programs that work like 5% of the time and spend 3 weeks just scanning the drives.

    Is there any one out there that knows what I can do? Please do help!
    Thank you so much! If I need to shorten this just tell me.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    there are several file recovery programs out there. Some are better than others. But a large hard drive with thousands of files can take a long time no matter what. Using linux/unix will not work with windows unless you have some sort of unix program that can access windows directories.

    In te future always back up important files offline to a secondary storage device, especially when doing drastic changes. Adding ram should not require changes to BIOS. Read the updating ram guide in the guides forum.

    When you tried to reconfigure the raid, you wiped out the boot and directory sectors. your data is still there, provided you didn't format or overwrite it.
  3. lonerayven

    lonerayven TS Rookie Topic Starter

    Yeah I didn't format it or overwrite it so it is still there, as I said I have run a few programs like Photorec.exe and it's recovered alot of stuff. I have tried using other applications like BartPE like some suggested, no luck because it gives me the same errors as windows, TestDisk but it doesn't make sense to me so if there's anyone that can instruct me for this please do, and FileViewer, and Nucleus Kernel. It's rather simple, I know there is an application that would work as well as this photo one, it's just buried under all these money grubbing companies that want me to buy their halfbroken utilities for insane prices.
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

    IF you had a Raid 0 setup and somehow reset your Bios (I did this with a static spark to my front USB) the Raid still applies - just set the Bios up for your same Raid operation and reboot.

    In an extreme case, you could maybe (MAYBE) try a repair install and do the F6 thing again etc to get back to basics - still have your data though.


    edit: Raid 0 was what I had - don't know if this would work with others
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...