1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Really strange USB Flash drive issue. Really.

By Hunter_Thompson ยท 17 replies
Aug 9, 2007
  1. Hi all, got some very strange symptoms, that get very puzzled looks from my IT mates. I have read all the other threads on USB storage and nothing is as weird as my deal.

    Recently started a job, given a Pentium 4 to fresh install XP as my work machine. All installed fine, connected to domain, all configured great.

    Lots of stuff I need to transfer to my laptop, or other machines. I have several flash thumb drives for this, and the work PC has 6 USB 2.0 ports.

    Been using the USB ports and drives successfully for weeks.

    Left a drive in the front USB port of my machine the other day, and someone (possibly even myself but I would remember) has stepped on the thumb drive, killing it. I open up the casing of the thumbie and can see 4 solder contacts that have broken. Damn.

    So I unplug the thumbie, luckily there is no critical data on it. I go to plug in another USB flash drive, in fact the same model and size. It does not appear in Explorer, and the following message appears in a pop up bubble near my clock:

    "One of the USB devices attached to this computer has malfuntioned, and Windows does not recognise it."

    I assumed I had killed the USB port. Try next port. Same deal. Hmmmm.

    There are 2 ports on the front, and four on the rear. One of the rear ports currently has my USB Microsoft keyboard plugged in, and it is still working 100%. As a test, I plugged the keyboard into one of the front USB ports. Gets recognised, loads drivers and works within 10 seconds. Hmmm.

    Plugged another known working USB thumb into rear & front ports. Not recognised. Plug this thumbie into my laptop and other computers in the office that are the same machine as mine - works 100% Hmmmm.

    Now here is the real strange bit. I have a nokia 6280 with a 1 gig memory stick in it. I have the nokia USB cable. When you plug in the 6280 to a USB port, it asks you to choose one of three modes: Default Mode {requires specific Nokia drivers and allows message and contact syncronising} / Printing Mode {allows you to print straight to a usb printer - I think it has some generic printer drivers it loads} / Data Storage Mode {makes the phone act as a generic flash drive - this is the mode I usually use for transerring files}

    Plugging in the Nokia to any USB port in Data Storage Mode (haven't tried the other modes) on the problematic PC works 100%. No issues, no drivers needed, fast transfers. Any other thumbie I try is not recognised.

    What the hell Why won't normal thumbie work anymore?

    Thanks for any advice. Tried updating USB drivers by the way - no change.

    I always get the computer issues that get the reply "I have never seen that before" or "That doesn't make sense"!

  2. Nostradamus

    Nostradamus TS Rookie Posts: 18

    I've never seen that before. That doesn't make sense. :p

    The only thing I can possibly fathom is that something from the old smashed-to-bits flash USB drive thing is locking up the whatever the computer uses to read the USB drive.

    Hm...that sounds nebulous. How about, "There may be a data cycle locked in the system memory which impedes the opening of a new port." I can only assume that you tried restarting the computer, but try shutting it down all the way and giving the system time to completely clear the cache--what's that, probably ten seconds? Then turn the machine back on. (Lame advice, I know. I'll go back to tech support for Dogbert.)

    Yeah, I probably botched all the lingo, but the thought is what counts, hey?

    If I knew more about USB, I might be able to comment about whether or not a particular connecter may have gone bad in the jack which is only used by flash memory and not other things. Somehow, I doubt that.
  3. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    USB connections are +5v, -5v, + data and - data. If in damaging the USB drive it also shorted a +5v feed to the data circuit you can damage the main board.
    Sorry - you probably didn't want to hear that.
  4. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter

    Thanks for the posts. However, I believe the nature of my situation rules out a physical problem, like bad ports or fried mainboards or "bits" broken off in the PC. If this was the case, why does my Nokia USB cable work? Why does my USB keyboard work?

    I believe it has something to do with drivers.... I am going to try to replace the entirety of my C:\Windows\inf and c:\windows\system32\drivers folder from a good, working PC running the same version of XP.

    Sounds drastic but I have been noticing the following:
    Open Device Manager, find the icon for the device (lists as Unknown device) and right-click, select Uninstall the device, plug back in.

    It recognised it. Installs driver. Your hardware is installed and now ready to use.

    Not appearing in Explorer.

    After 5 seconds, the malfunctioned/unrecognized device error ballon appears again. Lists as unknown device in dev manager.

    Hmmm... more tests will be conducted!
  5. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter


    Opened device manager. Uninstalled every item under Universal Serial Bus controllers. Rebooted.

    All drivers automatically re-installed. Sees the thumbie. Thumbie appears in explorer and I can see files. This is great!

    However, I get a notice that this device can run faster, I seem to be running USB v1.0.

    So open device manager, right click Universal Serial Bus controllers, Scan for Hardware changes. It updates some more drivers. Then my thumbie gets the unrecognised malfunction error balloon, and is no longer in Explorer.

  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    You may have damaged something on the motherboard still. You may not be getting enough power to it to run the USB sticks, the keyboard maybe can get by without much power. Your Nokia would then work because it supplies its own power (maybe). Is there a amperage difference in the USB 1 vs USB 2.0 standards, there probably is.

    If it isn't a branded computer, then you may have a motherboard with about 400billion USB ports on the inside when you only need about half that. So you may consider opening it up and seeing if you can switch the wires to different USB pins on the board. (for example moving it from USB 4-5 to USB 6-7.
  7. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter

    Far out, that is some serious troubleshooting. Different amp level on USB 1 vs USB 2 - this would make sense, as yes my Nokia powers itself. My hat goes off to you!

    Which means it IS hardware, which means I need a new case...but is it the port or the mainboard? Arrgh.

    Guess I should just be gratefull I have the Nokia.
  8. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    It may not be right, it is just the only thing I could think of that would fit your problem. I'm not sure a short would have damaged it in that way.

    I would take a look at the port the best you can, with a flashlight, and see if anything is cracked or potentially still shorting out somehow (probably can't be if you can plug stuff in). Then take the case off and see if you can take a look at the wires going into the plug. After that take a look and see if there are any free USB headers on the motherboard you could plug into.

    If it was either the motherboard or the port, my money would be on the motherboard, unless the wires internally on the port aren't connecting properly.
  9. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter

    I guess I like your theory so much because it actually fits my symptoms and make logical sense, whereas every other suggestion seems to have a hole punched in it by my circumstances.

    Had a look at the port in the lab with some other techies - we cannot seem to find any problem physically. Besides, all front (x2) and rear (x4) ports exhibit the symptoms. But we did find some free USB headers - changing to these provided no change.

    I am thinking that the only way to get me back my USB functionality on this machine is to buy a PCI card that has USB ports. Apparently these arfe pretty cheap.
  10. k.jacko

    k.jacko TS Rookie Posts: 493

    From memory the min. voltage required for ALL usb devices is 4.4v and 4.75v for Hi-Speed usb (v2). So maybe SNGX1275 has a good point about voltages shorting or dropping somewhere. Maybe your keyboard which will operate at usb1.1 is fine, because the voltage is at least 4.4v. But maybe its not quite reaching 4.75 thus not recognising the thumbie as a hi-speed usb device.

    Or something along those lines. Either way, i'm not sure how you'd fix it, sorry.
  11. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    If the voltage theory is correct, you could try connecting the thumby thingy through a powered USB hub.
  12. Yakob

    Yakob TS Rookie Posts: 55

    ok... i had a smilar problem, except it was a case of my brother being as turd. i noticed that inside the port the pins were touching where they shouldn't have been, resulting in my usb port malfunctioning, nothing was recognised. so just make sure all connections to motherboard and ports are normal. The slightest thing could kill the mobo, i had to change mine because of this.
  13. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Hunter_Thomson - it you have access to a good quality voltmeter you could check to see what the output is?
  14. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter

    Thanks - I will try the multimeter. If there are 4 pins on a usb connection, which pins have what voltages? I'll do some googling. Cheers for the tip; might just go buy a powered hub. Any links to recommended hubs?
  15. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409


    Voltages are probably fine, otherwise no USB device would run. I have no idea why amperage wouldn't be as strong, but you can't measure amperage very easily (really at all) like that.

    What you could do is buy a PCI USB card and they usually have a way to connect internally so you could run your front panel to the card.
  16. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter

    This is exactly what I am going to try, just bought one for 5 bucks off Ebay, so can't be too miffed about the price!

    However I still think this is a very weird situation I have, and yet again proves I get the bull**** strange issues that cannot be resolved.
  17. Hunter_Thompson

    Hunter_Thompson TS Rookie Topic Starter

    Bought a PCI card that gives me 5 USB 2.0 ports and two FireWire ports - I'm back baby. Cheers for the help guys!
  18. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    Heh, finally some good news around here.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...