Realtek AC'97 Audio driver & iTunes

By amkazen ยท 9 replies
Jul 26, 2004
  1. I cannot get iTunes to play an audio CD. I have a new Gigabyte GA-7N400 L motherboard and AMP XP Athlon 2600+ processor. I, and Apple, have tried everything. I reformatted my hardrive and updated the drivers from the Gigabyte and NVIDA websites. I do not know what chipset I have so that driver may not be current, although it is a new motherboard as of last week. I updated the Realtek AC'97 Audo driver but still iTunes will not play any audio CDs. Do any of you know if Realtek AC'97 Audio doe snot work with iTunes? I came into work this morning and installed iTunes on my Dell laptop that uses Crystal WDM Audio Codec and guess what? No problem, iTunes plays my audio CDs without a problem.

    Thanks for any info you cam provide me on this problem.

  2. ratty

    ratty Banned

    try another cd player on your system if that doesnt play then my guess would be that you dont have an audio cable connected from cd-rom to the mother board or sound card :)
  3. Yeah right I would check the audio cable out first
  4. lttan78

    lttan78 TS Rookie


    I have the same problem here too with iTunes not able to playback audio CDs. I'm using AMD Sempron 2200+ with Gigabyte 7FN-RZ motherboard. I had tried switching from onboard sound card AC97 to CMI3878 add on sound card and in the end up with Creative Sound Blastive Live 5.1, still the problem is not resolve at all. Are you using Nforce Chipset as well? I suspect it is either the motherboard or the chipset incompatibilities... iTunes flawlessly on my previous AMD Anthlon XP 1500+ with MSI K7T266 Pro2 motherboard which is on VIA Chipset using AC97 too.

    Anyone else got a solution? Will Apple help?
  5. lttan78

    lttan78 TS Rookie

    The most irritating thing here is that the Audio CD can be playback by all other software such as Windows Media Player, Creative playback softwares but just not iTunes... if not for the iPOD, i will just dump the iTunes away... :mad:
  6. exoteric

    exoteric TS Rookie

    I have Exactly the same problem, on almost exactly the same system, GA7n400 Pro2 M/board, AMD 2600+. All I can get out of Itunes, wether ripping or just playing is a series of blips. Anyone recently found a solution?
    Cd's play perfectly in WMP10
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

  8. Tangled_Kid

    Tangled_Kid TS Rookie

    Did you manage to sort this out? I'm having the same trouble. I'm sure I sorted it last time I rebuilt my PC, but I can't remember what I did to fix it.


    Sussed it! I went back through all my old saved drivers. I installed the nVidia unified drivers (v4.27).

    Hope this helps you all. btw, I have a GA7n400 Pro board (not gonna buy another Gigabyte motherboard though. RAID controller's gone on this one, & had a similar problem with my last motherboard.)

  9. exoteric

    exoteric TS Rookie

    Yes, that Fixed it. You know, I was actualy hesitant to update the drivers, it certainly wasn't what I expected to fix the problem, but, there you have it, motherboard drivers are good for stuff you wouldn't expect!!
    btw, used the latest version 5.10, which worked fine.
    interestingly, the audio drivers from Nvidia would not install via windows update, though it had them listed and downloaded them, ended up downloading direct from Nvidia and updated a whole heap of other stuff as well.

    Good Stuff.
  10. phani kakarala

    phani kakarala TS Rookie


    this site is helping well to get easily the mother board softwares
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...