Realtek HD Audio Microphone echo problem. Help

By Bertolli ยท 9 replies
Mar 7, 2007
  1. Hi, About 1,5 month ago I purchased a packard Bell MC2270 with realtek soundcard + and Advent 2 speaker -1 subwoofer set up. From the start I'm having problems with the audio/microphone. When doing the hardware test in Windows Voice recorder (set up) the testing of the microphone works ok (although I have to keep it fairly close to my mouth) but then the second test which is the playback test goes terribly wrong. I say "test" one time, and suddenly I hear myself saying test trough the speaker again and again, and the sound becoming louder and louder. It then automatically drops down the mic volume all the way to zero (as the echoing keeps on going). I know that one of the reasons might be that my microphone is too close to the speakers. However I tried the same test with a headset with microphone (and the regular speakers turned off) and it does the same then. I downloaded the latest realtek drivers and I tried to play around with the Volume equalizer of both Windows and the realtek audio manager, but no success.
    Any help is greatly appreciated

  2. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    If it's card you can replace that with Creative Sound Card. If it's on the MOBO then you need to update the system chipset drivers and sound drivers.
  3. Bertolli

    Bertolli TS Rookie Topic Starter


    Not sure I understand what you're saying
    I found the following information about the soundcard:

    Manufacturer: ASUSTek
    Model: ASUSTeK Tiger Capture Device
    Driver: 3xhybrid.sys
    30 October 2006

    Can you confirm what a solution might be? In case update the drivers then should I go to the ASUSTek site? I already downloaded all the realtek Audio HD manager software again, but that doesn't help

  4. indianmoon409

    indianmoon409 TS Rookie

    I Was Messing Around One Night With Realtek Audio And Thought It Was Fun All The Sounds It Made In My Microphone Talking To Contact In,alot Times I Talk In Mic,my Sound Makes Echoes.why?i Tried To Reste To"none"foe Sounds,and Stilll Makes Echoes Noise
  5. worldcrafter

    worldcrafter TS Rookie

    i know this is an old thread, but i ran into this problem as well (echoing mic volume) by messing with my own audio settings, and couldn't find a solution online. so I'm gonna post how I fixed my problem. I went into control panel, double clicked Realtek HD Sound Manager, and when the manager screen showed, I clicked on the mixer tab, then on the Record area, I muted Stereo Mix.
  6. manneblask

    manneblask TS Rookie

    I ****ING LOVE YOU!!!! =D =D
    I've been cursing over the problem for weeks. I'm really thanful that you posted the solution here!
  7. Alster37

    Alster37 TS Maniac Posts: 290

    I love worldcrafter!!!!
    I worked for me tooo yyyyyyyyyyyyyyyyyyyyyyyyyyaaaaaaaaaaaaaaaaaa!!!
  8. abrashinka

    abrashinka TS Rookie

    You saved me a ton of money and countless more hours of headache - thank you

    I'm been testing out Google Voice with Gizmo5 combination for the last few days with a microphone headset. I kept on getting complaints from everyone I spoke to that they heard themselves twice.... I looked all over all of the Gizmo and GV help sites and found nothing that would get rid of the echo. Finally I started trying to isolate where the problem was coming from trying all kinds of combinations. I figured out that using my webcam microphone cut out the echo - so I decided that the problem must have been in the headset I had bought... was going to return it and buy a more expensive one... Thank god I decided to try more combinations anyways and at some point realized that if the computer was set to use my realtek sound card for input and output EVEN IF MY HEADSET WAS UNPLUGGED - meaning there was no mic or speaker attached to it - if I called a phone from Gizmo or from Google Voice (or both together...) anything said into the phone by the party on the other line echoed back to them - so it couldn't be the headset... The echo had to be in the soundcard... looked around for mention of the echo issue with the soundcard and stumbled onto this... Thank you Thank you Thank you!!!!!!!!!!!!!!!!! I just hope anyone else trying to work this out finds this solution. I would never have thought to disable stereo mix. What is that supposed to do anyways? Whatever it is it's function can't possibly have anything to do with echoing... must be a flaw somewhere... Thanks again - Good luck guys!
  9. Seint

    Seint TS Rookie

    Thank you! I've been having this problem for the past 3 years (yes years). I managed to get my hands on a headset that automatically canceled the echo, but then they broke and I couldn't get another pair. Thanks so much for posting your solution =)! Maybe now people will talk to me... lol.
  10. DJLO

    DJLO TS Rookie

    wow, worldcrafter you just changed my outlook on life. im so happy i don't have to return this and buy a new one!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...