Recovery Console

By COMPfreak ยท 6 replies
Apr 18, 2004
  1. Hi, my computer just recently crashed and came up witht eh error: "Windows cannot be started because the following file is missing or corrupt: <Windows Root>\WINDOWS\system32\hal.dll please reinstall a copy of this file"

    So i thought to myself... ok i need to try getting into safe mode, but that didnt work and it came up with the same error message. When i tryed knoppix it didnt work. So, i tryed the windows Recovery Console after i put a copy of the hal.dll file on a floppy off of another computer. When i went into the Recovery Console i tryed the copy command to see if i could copy it into the c:\WINDOWS\system32 folder, but, it says acess denied. So i looked at the commands to see if i had to login, and u did. so i typed the command "LOGON" but nothing happend just that the propt came back up, like....



    so i started looking for help and i found a site that showed exactly what i need to do. It showed the way the recovery console is supposed to look when you first start it. But mine didnt.
    The way it is supposed to come up is asking for a installed OS and an administrative password. And mine didnt have that. My prompt didnt even have the windows root on. It is supposed to look like this.

    and mine was like so


    Im am now clueless at this point in what to do and i am not reinstalling windows at any cost...

    Thank you for any help.
  2. OS samurai

    OS samurai TS Rookie Posts: 159

    what happened when you attempted to boot from the knoppix cd? did your system boot or did you get an error?

    have you tried using the cd command to get to the windows directory? e.g. cd windows according to the error you posted this directory looks like it is missing?
  3. Saintman

    Saintman TS Rookie

    I have the same problem as above

    I tried runnin bootcfg /scan and it comes up with no windows installations. Any ideas on what to do, short of re-installing windows?
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.COMPfreak and Saintman

    Have you tried doing a repair install of Windows as per this Thread ?

    Regards Howard :wave: :wave:
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Guys, you should learn a few DOS commands.
    When you want to GO to, or Change Directory, use the command CD
    You are in c:\>
    While there, type c:\>cd windows [hit enter]
    and you will now see: c:\windows>

    To get out of any directory, back to c:, type in: cd \ and hit enter

    You need another drive, type in its letter + colon, like d: and hit enter.

    Starting from a boot-floppy, you cannot access your harddisk, because it is a different file-system, not compatible with the floppy-program you booted with.
    Find for yourself (Google?)what the differences are between NTFS (as in XP) and FAT32 (as in DOS and e.g. Windows 98/ME)
  6. ayaraine_01300

    ayaraine_01300 TS Rookie

    i'm sorry if i have to rehash this thread, but i'm having almost the exact same problem, except the corrupted file is \WINDOWS\system32\config/system

    i tried repair through windows setup using the cd, but there is no repair option, and if i try to reinstall, it can detect the previously installed windows.

    so i tried using recovery console. only i was having the same problem as the threadstarter, i only have C:\> instead of C:\WINDOWS>, and if i try to type cd windows, it says Access Denied.

    so... is there no way to repair my windows xp pro?
  7. lipe123

    lipe123 TS Evangelist Posts: 719   +236

    its not supposed to say access denied. In short u seem screwed, the config\system file is the registry section containing all your hardware. there will be a lame backup in c:\windows\repair that u can replace the missing/broken one in windows\system32\config with. but u'd need another machine to put the hdd in. The access denied thing is weird tho becos console logs in as administrator and should have full access, might be a faullty disk or somone messed up the permissions to the system file in the 1st place.

    Come to think of it, the file is probable fine windows just cant acess it, put the disk in another pc and reset the permissions on the windows folder.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...