Referenced Memory error

By aheffner ยท 12 replies
Sep 9, 2003
  1. I'm getting the following error when attempting to print to pdf using Fine Print PDF Factory:

    Instruction at "OX2603DE97". Referenced memory at "OXF816AFF8". The memory could not be read. Click on OK to terminate the program. Click Cancel to debug the program.

    I have rebooted. Uninstalled and reinstalled the driver and the program that it is giving me the error with.

    I have searched google and yahoo and didn't find much. I am running WIN 2000. Any suggestions would be greatly appreciated!!
  2. MattG

    MattG TS Rookie Posts: 140

    You might want to take a look and make sure your memory timings and all settings in BIOS are correct to your type of memory.

    To me this sounds like it cant read your memory for some reason. Whether it be your actual program your using, or your memory itself.

    Try cleaning out your memory areas...get the dust out of there, and put 1 chip in at a time and try again..see if it actually is a bad memory chip. If this isnt. just post back here and we will see what else we can do.
  3. Nic

    Nic TechSpot Paladin Posts: 1,549

    Try running the system file checker to make sure your system files are original and undamaged. From the 'run' command type 'sfc.exe /scannow'. Make sure you have your windows cd in the cdrom drive when you do this. If that doesn't work, then see if there is an update for that program, or download it again to see if things improve. That error is normally caused by buggy or damaged software.
  4. aheffner

    aheffner TS Rookie Topic Starter

    Well, I don't know what happened, but it is working now!? It'll probably happen again so I haven't got my hopes up! :) Thanks for the advice. If/when it happens again I will give your suggestions a try. Thanks.
  5. filthy_mcnasty

    filthy_mcnasty TS Rookie Posts: 78

    it's just a normal run of the mill access violation. just see if there is an update from the vendor.

    every process is assigned it's own virtual memory map and it's only allowed to use certain regions of it. simply put, the programmer was probably lazy with a calculation of sorts and it tried to read where there was no data or beyond the bounds of a buffer, that sort of thing. OXF816AFF8 is well beyond the program's normal bounds of virtual memory. it exists for that program but the program isn't allowed to directly access it because it's the 'kernel mode' portion which is where windows does stuff. i wouldn't worry about it being a system wide problem unless many applications start giving the exact same message all the time.
  6. StormBringer

    StormBringer TS Maniac Posts: 2,244

  7. troll4444

    troll4444 TS Rookie

    I have been dealing with this error for months now..I tested ram, installed new ram, ran every cleaner I could find.. Never could get it to stop..I even reinstalled Windows 2000 & fully updated it etc.. I did all the proper things.. The error continued..then one day recently, (last week) it "went away"..
    ..I cannot figure out what I did or stopped doing using to cause this..
    I think it was a setting or an app but am clueless asto which one.. I know this is not of any great help to anyone other than to illustrate how tricky a problem it might be. Mybe it was just a loose ram module..dunno.. but the problem has not occurred for a week now..but if it returns I will be in touch & post any discovery made . cheers... g..
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    if you think your memory is bad, it could also be a bad slot on the motherboard instead of your stick

    also run memtest86 to see if your memory is bad.
  9. evoisard

    evoisard TS Rookie

    Hi all,

    As said filthy_mcnasty, it's pure software bug and checking your hardware will not help. I got this message when MS Word tried to save a document in the motherboard's PROM (or was it in the PCI chip) :)

    As was said above it most likely is due to a buffer overflow, or access to memory through an un-initialized pointer. Anyway, some part of the memory which wasn't allocated for the culprit application's usage.

  10. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    hmmm. I wonder if there is a patch for it.

    In any case, I switched to openoffice a long time ago. Never had anyproblems.
  11. Gary Webb

    Gary Webb TS Rookie


    :hotbounce Finally, after all this time and effort... I feel so free! The memory error seems to have disappeared since getting rid of Norton's Internet Security, including Anti-Virus stuff. In fact, some other annoying little problems are gone too.
  12. musisat

    musisat TS Rookie

    Okay, I'm getting the message "The instruction at 0*00401082 referenced memory at 0*00000000. The memory could not be written." This occurs every time I start up my computer. It gives me the option of either continuing or debuging something. When I click either choice, it just gives me a blank screen which will never load into anything else. Is there something I can do about this?
  13. armmon

    armmon TS Rookie

    i'm seeing the exact same issue ... running Windows XP ...

    the only option seems to be power cycling the PC, then hitting F10, system recovery, which basically restores the PC to its original state (while saving user data files) ... it warns that applications must be reinstalled after recovery

    thought i'd check in here before i wipe out my applications ...

    any help would be greatly appreciated !
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...