Referenced Memory Error

Not open for further replies.


TS Rookie
Here's my problem. My parent's computer is continually getting Application Error pop up messages. The error reads:

"The instruction at "0x000000000" referenced memory at "0x00000000". The memory could not be "read". Click OK to terminate program."

It seemingly has no pattern as to the programs it effects. It has effected bootup files (logonui) and application files (word) and installation files (setup). Thinking it was a virus of some sort my dad bought Norton 20004 Professional. After doubtfully installing it. I attempted to run it and the program won't even open.

Please help as much as possible.
Open up that PC, make sure you are "grounded/earthed", and remove the memory-sticks. clean the contacts with an eraser and blow away the remnants. Reinsert the memory. Restart PC.

If you still have problems, go to
and download/run that memtest (preferably over a longer period.


TS Rookie
Did you ever find out what was causing the referenced memory errors. I have been getting them at work. Our tech support ran a full hour memory test on the machine and it passed with flying colors. I've gone on Google and found it occuring in many different applications (there can't be that many bad memory chips out there) and many people seem to be unaware that seems to be a generic problem. My guess is it is some sort of software (read Windows!) problem rather than hardware. But either way, they haven't been able to resolve here at work.


TS Booster
bltassoc, you really need to let us know what the error numbers in the message are- those help immensely.

Instruction cannot be read errors can be caused by bad memory, faulty CPU, bad drivers, hardware conflicts, crappy programming, and fluke luck (to name a few causes.)

Also, you'd be surprised by the amount of bad memory in the world.. Memtest86 is a great program to use to detect this, save it can occasionally have problems on AMD processors (I htink they've fixed that now..)

Look forward to hearing back. :wave: btw, welcome to Techspot!


TS Rookie
I've been getting the same type error.

The error reads (when I close IExplorer, for example): 'The instruction as "0x01803195" referenced memory at "0x00000000". The memory could not be "read".'

It reads a different instruction for different programs. I'm just beginning ASM programming, but I can't see why any program would be referencing that memory address. It happens with a bunch of different programs, but not all, so possibly it's a bad kernel...? Some rogue instruction?

I'm going to try to re-install Windows and see if it helps any. I tried switching my memory slots, but no help. I may try a stick from my other computer first. I'll try to post what I find out, but if anyone knows what the heck could be going wrong, please post.

Also note, it only happens when you close a process, NOT a thread (for example: open IExplorer click New->Window [this creates a thread] Close the New window; Nothing happens, but when you close the original; Error!)


TS Rookie
In continuation:

I swapped out my memory sticks and nothing changed, so [in my case; you should verify this in your own] it is NOT a memory problem, which means it has to be a problem with a shared library, kernel, something.

Any ideas?


TS Rookie
Well I tried re-installing Windows XP Pro Sp2 (by just booting the CD and repairing the current install). That didn't do any good either, possibly it's a motherboard problem? Eventually I'll completely format and reinstall Windows. If anyone has an easier solution, please let me know.


TS Rookie

Ok, I think I found the problem, but I would like to hear some feedback. Anyone else who was having this problem: Did you have MS IIS installed? I forgot I installed it and just un-installed it and all my problems went away.

If more people have had these problems and have IIS installed it might be worth notifying MS.


TS Rookie
Hello 2 all!
I myself faced the same problem. A lot of apps rises memory fault with "memory can't be "written" or "read". Checking and changing memory cards didn't helped! Besides, i tried to change or disconnect nearly all equipment, except MB and CPU! No effect. One more interesting thing - flash movies don't work - they terminate or restart occasionaly. Video playback may hang the system at all, but not always (it's the only thing that hangs my comp now - it can work 2-3 days without problems and reboots (I mean uptime) and one more - 3D DON'T work after POS sleeping :confused: . I don't want to comply on ASUS. My OS is WinXPSP1bld2600 + critical updates.
To ac3d912
Internet Information Services (IIS) not installed (and never was).


TS Rookie
W00t. Im having this problem too, and it's becomming extremely irritating. I normally only get it while using Internet Explorer, but lately my graphics aps have been crashy as well, they usually run smooth as ice. I notice Im getting a few other strange things happening too. I cant seem to navigate MSN very well (keep getting those "Document moved" errors, and my google toolbar is crashing along with IE.

Dammit Microsoft, cant you NOT break stuff when you update your junk? >:

Anyhow, any help would be great. I doubt I have a real memory issue, because this is happening to way too many other people, and it didnt start occuring til after I got the Service Pack 2.

Grrrrrr, Msoft! :shakes fists:


TS Rookie
I am getting this error when i log onto different sites then it shuts off my internet explorer and I have to restart it. could you tell me how to fix this.

The instruction at 0x0112110b referenced memory at 0x01155250. the memory could not be "read".

I would appreciate and or all the help i could receive.


TS Rookie
referenced memory error - IE

I see that I'm not as crazy as I had thought. I can't tell you how thankful I am to have found you. Microsoft's free support is worthless.

I'm getting the "The instruction at "0x7c9105f8" referenced memory at "0x01650010". The memory could not be "read". error when I close completely out of IE 6.0. I've also discovered that the Symantec anti-virus has begun causing the computer to restart itself right in the middle of a scan. Something tells me these incidents are connected, but I don't know how.

I will try to follow some of the suggestions posted here, but if anyone finds a definitive answer how to fix to this problem, I'd be most interested. It's getting really aggravating to keep getting the error and have my computer reboot for no reason and without provocation.



TS Rookie
New info

I've got a new information for now. I've tried to change the hardware (all except CPU) and found out that problems with 3D were because of vidceocard (GB Radeon 9000Pro). Now I've got GFFX5200. The situation with memory errors still was terrible, even on clean system. Eg, I reinstalled OS and tried to open .CHM files right after first boot ( no drivers yet). It crashed... (hh.exe) :giddy: . Last night I reinstalled the OS again :)hotouch: Bill) and installed Intel inf update 6 ver (latest). Since that I haven't seen any errors. This night I'll inspect more closely (it's a home comp).


TS Rookie
Hello all,

I just signed up to this website because I want to add my piece! Basically, I'm getting the same problem as you guys, I'm getting these referenced memory errors all over the place, with different numbers at different times. The common factor for me seems to be when I'm viewing a folder which contains video files and sometimes pictures. It's really doing my head in.

After doing some research in other forums etc, it looks to me like the problem that I'm experiencing could be to do with Windows SP2 (as someone else mentioned earlier), but the person who told me that elsewhere does not know how to remedy the issue. I would have thought if the problem is quite widespread (which seems to be the case) then Microsoft would have more comprehensive information about how to resolve this issue.

Anyone had any joy in removing the problem?




TS Rookie
In case this helps:

I used to get the same problem when I closed the last IE window. I found out that the problem was my ISP's home page which was the first page I went to. Also, if I had Outlook open when I opened IE it would give me a similar problem when I closed it.

I changed my home page. If I did not visit my ISP's home page at all I did not get the problem any more.

My ISP's home page also had MSNBC News Video on it. If I played it I would get a BSOD. But I did not get this problem with online video on any other site.


TS Rookie
I just talked to another co-worker who has the same system I do, but doesn't get the referenced memory error when he closes IE or any other program. He's got 2 GB of RAM. I have 512 MB of RAM on my home machine (it also has the same XP setup), but my computer here at work has only 256MB. I'm wondering if the memory error is occurring because I have the bare minimum amount of memory to run Windows XP. Has anyone added memory (so total meets or exceeds 512MB) and have the error disappear?


TS Rookie

I don't think it is a memory problem. On my laptop PC I have just a little more memory than you do and I don't have this problem.

The only time I had this problem was when I visited my ISP's then buggy home page. Is your co-worker visiting all the same webpages you are?


TS Rookie
I've found that gunny was correct. My home page was causing the problem. The ISP is apparently buggy. When I don't visit that website, I don't get the error. I had tried re-installing IE 6.0, repairing Windows XP, updating drivers, and scouring for viruses. But once I changed my home page, and didn't visit that buggy site, I didn't get the error anymore.

Thank you all!


TS Rookie
seperating out the problems

Although I haven't tested it yet, It's highly unlikely that my computer has bad memory since it's brand spankin new, I am planning to test it and I'll keep all you net leaches up to date on the subject. Here's the deal, it looks like there are a couple of different reasons why this error occurs

1.) outlook express: it can be caused when an e-mail doesn't have complete header information such as a from heading

2.) Internet Explorer 6.0: appearently it had a bug. it should have a windows hotfix. It could be this period because windows uses IE for everything. Even when you're not online.

3.) unkown error: the one we are trying to determine on this thread

3.) bad memory: could be I'm going to check myself next, but doubtful

Things it's not: SP2 I REFUSE to run windows XP. It's a piece of crap. Microsoft got greedy with it, it is badly coded, cannot alloticate memory, and finally is a pain to use as a PC repair tech because of their STUPID copyright protection scheme. (PS bug microsoft to not put that in longhorn) So I run Windows 2000. I'm getting this error too. So this means that it's not localized to just XP, which lessens the likelyhood of it being windows itself (although the kernels and stuff for XP are based off 2000). this means it's likely something (like Internet Explorer) or some other common thread. Maybe we should be comparing our installed programs lists to see what's up?

Any ideas?



TS Rookie
Okay... very strange. I also am getting the same error msg.... just started today. For me, it only happens (so far) when I try to open IE directly from the desktop shortcut or from the start menu. I've been keeping the windows I already had on my screen open, as I can only open a new functional window from the already open one.

I've tried all suggestions offered on this thread... no luck. Any other suggestions?? Thanks.


TS Rookie
Same problem here

3.06 ghz P4
512mb DDR RAM
64mb intel graphics card
WinXP w/SP1

I get this message when playing Half life 2, and counter strike 2. Im pretty sure its not a game bug.

Ive heard several rumours of it being a memory leak, and until now i was sure it was to do with windows not allocating the memory properly. Ive tried all the hardware test and blah-d-blah. still no luck. Im in desperate need of help!

My error message is:

The instruction at "0x241734a5" referenced memory at "0x01168348". The memory could not be "read".

Click on OK to terminate the program.

I think it is one of problems:

Graphics card
Memory allocation
Virtual memory
Memory leakage.

Help, please!


TS Rookie
Probs here to


Ive been getting the error message The instructions at "0x004052a3" referenced memory at "0x00001518" the memory could not be read.

I was getting this when playing Call of Duty (United offensive) after playing for about 10 mins. But the other day had it a couple of times when online.

System specs
AMD XP2800+
Gigabyte GA-7VT600L
Radeon AIW 9800pro
1GB PC3200 memory
Windows XP home

Any help would be appreciated as Activision said update to latest drivers which I have anyway.



TS Rookie
If you are getting it after some time, e.g. 10 minutes, then I should think it is a memory leak/vitural memory problem - your memory is filling up.

But I think the problem is with the game you are playing - not with Windows. Your game's software probably keeps on grabbing more and more memory without releasing or reusing previously used memory. AFAIK games are memory hogs.

You might try looking at your game's executable in the Processes tab of Windows Task Manager while you are playing to see if its Mem Usage keeps on growing. You could also look in the Performance tab of WTM to see if CPU Usage and/or PF Usage keep growing while you are playing the game.


TS Rookie
Have had same problem, after i bought new mainboard, CPU, memory 1GB and grapich card, after uppdating all drivers and so on, same old same old. Then i got the bright idea to uppgrade my BIOS, And after that the problem was gone.
It had som memory fix in it.
Not open for further replies.