Spread the love! TechSpot Tech Gift Shortlist 2017

registering with dhcp server

By 69 Bay ยท 8 replies
Aug 9, 2006
  1. Hi - hope someone can help!

    I have a W2K machine that has worked on the network, but has had some 'tinkering' done on it and now i cant get it to work. It doesnt appear to find the dhcp server (which is our router), and therefore isnt assigned an IP address. Trying ipconfig /all, i get:

    Connection specific DNS suffix :
    Description : Intel(R), etc
    Physical Address : etc
    DHCP enabled : Yes
    Autoconfiguration Enabled : No
    IP address :
    Subnet Mask :
    Default Gateway :
    DHCP Server :
    DNS Servers :

    If I try fixed IP, it works and I can see all machines on the network, but I am unable to get connection to the internet.

    I have tested all hardware, by unplugging the network lead from the 'faulty' PC and plugging it into a knoown good one (XP OS though) and this worked OK.

    Is there any way I can monitor the W2K network traffic to see whether it is actually attempting to register with the DHCP server?

    Is there any handy tips that anyone could recommend for me?

    I have just spent the last day trying to fix this and i am just about ready to throw it out of the window (no pun intended!)

    Thank for any help

    69 Bay
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Wireshark, formerly known as Ethereal.

    Maybe your router has its own logs, too. But why is DHCP server in broadcast address ( ?
  3. 69 Bay

    69 Bay TS Rookie Topic Starter

    Hi - thanks for replying

    I presume that when the W2K PC boots up, it broadcasts on to find the DHCP server. If the server responds, the address will change to the actual address of the server.

    I did try connecting my XP laptop to the hub, which in turn is connected to the router. All worked OK. I then disconnected the uplink to the router and tried again, and the PC came up with similar results i.e. DHCP Server address set to 255.etc.

    I dont know too much about networks, etc only stuff that i can pick up off the net (a dangerous thing!)

    Thanks again

  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Do you have the DHCP Client service running? See the Event Log for any odd messages.
  5. 69 Bay

    69 Bay TS Rookie Topic Starter

    where do i find the Event Log?

    I have run MSconfig, and DHCP Client is shown as ticked, and running in the services tab, if that helps

    69 Bay
  6. 69 Bay

    69 Bay TS Rookie Topic Starter

    right, I have found the event viewer, and YES there is a problem with DHCP!

    I have this listed under a DHCP error:
    Your computer was not assigned an address from the network (by the DHCP server) for the Network Card with network address *****.
    The following error occured:
    An operation was attempetd on something that is not a socket. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

    It looks like the DHCP client is trying to register approx every 5 mins, as there are now 5 errors listed, each 5 mins apart...

    I also have another error - I dont know if it is related. Its source is DCOM, the description is:

    The server {****} did not register with DCOM within the required timeout.

    What is DCOM? Could this be the source of my problem?

    Have you any more advice on this problem?

    Thanks for helping

    69 Bay
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

  8. 69 Bay

    69 Bay TS Rookie Topic Starter


    It turns out that my boss had tried to install a Vodafone package to get inetrnet access thro his mobile (Bluetooth). I have just uninstalled this and all works!


    Thanks for helping guys

    69 Bay
  9. alidabiri

    alidabiri TS Rookie Posts: 441

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...