Reinstall of Canon Multipass 3.01 software for Canon C5500 printer

Not open for further replies.
I recently uninstalled and reinstalled the software (Multipass Manager 3.01) for my Canon C5500 printer; during the reinstall, I am receiving the following error "Failed to register mpservic.exe to windows NT as domain or service". Can anyone give me any insight on how to make the software register this executable to the service MPSERVICE? I tried to remove all entries for the Canon printer in the registry and reinstalled the software; but I am receiving this same error everytime and the software is uninstallled after the error. Please help!!


Posts: 613   +2
canon problems

i've had the same problems on 2 canon printers and i'll never buy canon again. i think besides all of the usual canon problems you will have to insert brand new un used cartridges. the tatoo date scheme in the cartridge is a major problem in all printers and i think it is against the law because it causes land fill problems with these companies promoting the use of new rather than refilled cartridges...i hope this helps you cyril....
I got the same error message on repeated attempts to reinstall my Canon Multipass C530 driver under Windows XP ("Failed to register MPServic.exe to Windows NT as Device or Services" ). Here's the solution that worked for me:

Download Microsoft's Windows Server 2003 Resource Kit Tools from
and run cleanspl.exe to clean your print spool. (Ignore the box for filling in a computer name and just click on Clean Spooler. Say no to all questions that ask whether you want to remove various Windows components.) I found that after doing this, the reinstall of the printer driver was able to run to completion successfully. Whew!

Not open for further replies.