1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Related SanDisk Cruzer problem

By rasty9 ยท 5 replies
Oct 16, 2006
  1. My cruzer appears to work - the lights blink on the drive when you try to access it. But it can't really find the files. Still says the drive ISN'T FORMATTED.
    Based on one post, I changed the drive letter away from the default F: to an unused letter. So far, so good.

    But... No matter what I have tried, when I format it in a variety of ways, the info window works up to 99% complete and then tells me it can't format the disk. But won't say Why... So I have an unformatted Cruzer.
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    Try formatting from a different OS or Computer or both. Then never format again, its flash memory not a hard drive. Fragmentation is essentially a non issue, and I don't see anything you are gaining from formatting over just deleting the file.
  3. rasty9

    rasty9 TS Rookie Topic Starter

    I'm not trying to 'gain' anything except the use of the drive. I've tried it in two computers (both running XP Pro) and they both say that the drive isn't formatted -- and yet neither computer will let me complete a reformat. It runs up to 99% complete, and then says the format was not completed. No further diagnostic info available, apparently.

    And I'm not surprised by others' comments that they found no useful info or help through SanDisk's web site. I had a problem with one of their CF cards once, and I found it completely impossible to get Help, either online or by phone.
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    Lots of people have problems with flash memory, and it seems like Sandisk is the most common to have problems. What I was saying about not formatting was more of a general comment and not directed specifically at you - just a quick look around this forum shows a lot of these issues with flash drives happen after formatting the drive.

    Your best bet at this point after trying 2 machines is to change the OS you are trying in. If you don't have access to a 98 machine, then try a live linux distro and format (FAT32) from within that.
  5. N-Guy

    N-Guy TS Rookie Posts: 105

    Oh snap! I have two of these D:
    They're relatively new & haven't experienced the problem yet >_< Hopefully never.
  6. cjanien

    cjanien TS Booster Posts: 159

    I had a problem with a sandisk 4gb usb flash. Called the company and was told it was counterfeit. Call Sandisk!
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...