Removing "lexbce print server"

By dekko36 ยท 15 replies
Sep 10, 2005
  1. I am trying to remove the lexbces print server that lexmark installed.

    The print spooler is now dependent on it, so I can't disable it and still print to another printer.

    On Lexmark's website, I found the following...

    ...Uninstalling the lexbces.exe file:
    When this file has been extracted, it must be properly uninstalled from the system while you are still at the command prompt. Do the following:
    1. Type lexbces -u and press ENTER. You will receive confirmation that the file has been removed and that you have to delete one other lexbces.exe file manually.

    I tried this several times, but never received the message that the file has been removed.

    Any help will be greatly appreciated.

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    This is also from the Lexmark site.

    "Extracting the lexbces.exe file:"

    "1. Go to Start, Search, All files and folders, type in lexbces.* and search the (C:) hard drive for this file. Delete any instances you find and then empty the recycle bin."

    You might want to do this from safe mode.

    Regards Howard :)
  3. dekko36

    dekko36 TS Rookie Topic Starter

    Thank you Howard!

    I just tried that (in safe mode), but it is still there, with print spooler as a dependency.

    The search found three instances. I deleted all and empied the Recycle Bin. Re-booted and found nothing has changed.

  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Mmm, this seem to be a real pain to remove, see HERE

    I`m not sure, but maybe doing a Windows repair, as per this thread HERE might help. I`m assuming that you`re either running Windows 2000, or XP.

    Please understand, that if you choose to do the repair, you will need to update your Windows again, as the repair will wipe your current updates.

    Regards Howard :cool:
  5. dekko36

    dekko36 TS Rookie Topic Starter

    Looks like I'll go with the Windows repair.

    Thanks for the help, Howard.

  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Get HijackThis from and install it in Program Files\HJT
    NOT on the Desktop or in Temp!

    Boot in Safe Mode, see how here.
    Switch System restore OFF, see how here.
    In Windows Explorer, turn on "show all files and folders, including hidden and system". See how here.

    Next, open Windows Task Manager by pressing CTRL+ALT+DELETE.
    Click the Processes tab, select the process (if there) and click End Process for:

    Next, click Start/Run and type services.msc and click OK. Look for the service:
    Doubleclick it, click Stop if it's running, and change the Startup type to Disabled.

    Run Hijackthis, do a scan and FIX any lines with lexbces.exe in them.

    Delete that file.
    Delete ALL files from C:\WINDOWS\Prefetch.
    Boot normal. When all OK, switch System Restore back on.

    Now promise me, you will NEVER buy a printer from Lexmark/Dell again!
  7. greenflash

    greenflash TS Rookie Posts: 100

    rofl.What's your suggestion then? ;)
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Canon Pixma series 2000 or better.
    Cheap cartridges for individual colours, superb printing quality, fast.
    I have the Canon Pixma 4000.

    Or get a Laserprinter if most of your work is black/white.
    Small HP or Brother or Samsung.
    I have a still perfect HP Laserjet 1100 from 1997.
  9. dekko36

    dekko36 TS Rookie Topic Starter

    Thanks for the info, RealBlackStuff!

    I tried everything you said to do. Three times.
    No Luck, it's still there.

    When I ran Hijackthis, nothing with lexbces showed up.
    I wasn't able to delete anything from it.

  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Click on Start/Run and type regedit and click OK.
    Click on Edit/Find and type in lexbces and click Find Next.
    If found, rightclick that and select Delete.
    Press F3 to find the next, and repeat until the end of registry.
    If you can't delete an occurrence (under LEGACY probably), just skip and press F3.

    Then reboot, and do that HJT thingie again.
  11. dekko36

    dekko36 TS Rookie Topic Starter

    I'll give it a shot. Thanks again.
  12. dekko36

    dekko36 TS Rookie Topic Starter

    It partially worked. I was able to disable lexbces, and run the print spooler.

    I also found more on Microsoft's site. Article ID 324757, "Spooler subsystem app has encountered a problem and needs to close" and "Operation could not be completed" error messages

    With your info and the info from Microsoft I was able to remove it.

    Thanks again for all the help, RealBlackStuff!

    Another thing, Lexmark is NO longer in my vocabulary!

  13. tony17837

    tony17837 TS Rookie

    Thank You

    Hey Dekko-

    Thanks. The lexbce thing has bee a thorn in my side even since I got my new printer, and my system crashed while removing Lexmark's crappy spyware drivers. Anyway, thanks to you, I got it removed and my new Epson Leterjet 1022n up and running :grinthumb
  14. gozo

    gozo TS Rookie

    Still happening

    Tried to install an old Lexmark Z708 that has been running fine on an old ME system (i know!). Bloody horrendous install on Vista even with Lexmarks vista drivers form their site. Asked for all sorts of exceptions to ZoneAlarm and already created Vista firewall exceptions. Couldn't get teh printer to work then saw all this LexBce crap on my print spooler dependency. Did the regedit thing as above and now all seems fixed, I hope. Have ordered a Canon Mp160 as it's cheap and looks good for the price. Never Lexmark, ever again, I promise!
  15. axisworks

    axisworks TS Rookie

    Worked for me

    This worked for me, but as for the LEGACY entries, those have to be deleted and it will say failed on deletion. So what has to be done is right click on the key and select permissions and give everyone full access. then try deleting again.
    And for the dendency strings that come up, you can't delete those, you have to just edit it and remove the lexces value but leave the RPC.
  16. d4san

    d4san TS Rookie

    Thanks. It worked.

    The origin of this thread goes back a ways. But I'm thankful it is still here because it fixed my problem. I didn't have to do any of the HJT bit, just deleted the entries in the System32 file and in the Registry (I had previously dumped the Lexmark folder from Program Files). Then spoolsv.exe started at system boot and I was able to install my new printer. Test print worked fine.

    Thanks again.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...