Renamed files - XP won't start

By pcforum ยท 4 replies
Jan 13, 2007
  1. Hi Guys,

    Feeling a bit stupid here....

    I'm running a Dell Dimension 9150

    Yesterday, I renamed all instances of file psapi.dll to psapi.old and ever since windows won't boot. After many hours of searching I've worked out the offending file is found in the \windows\system32 folder.

    In the good old days I would have booted from a floppy and renamed the file back using DOS but....

    I can't find a boot disk (or boot CD) or any way to get to the DOS prompt.

    So as a bit of background info:

    I can't boot in safe mode
    Restoring to last known configuration doesn't work - we don't get that far!
    I don't have a floppy drive
    I'm running Win XP service pack 2

    All I need to do is rename \windows\system32\psapi.old to \windows\system32\psapi.dll

    How hard can it be.......?

    Surely not a complete restore....?


  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

  3. pcforum

    pcforum TS Rookie Topic Starter

    Thanks for your quick reply - That's what I need....

    I think I tried this earlier today but I only got the C: prompt, I couldn't see any directories. Also, the only drives I could see were G: (USB stick) and I: which seemed to be the boot image the CD created.

    All other drives C-I were empty.

    Any ideas?

    A little bit more info...

    When I see the

    "The Recovery Console provides system repair and recovery functionality.
    Type EXIT to quit the Recovery Console and restart the computer."

    Message, I go straight to the c: prompt, I'm never asked for a password....

    Might help?


    Hi all,

    a bit more info....

    After I boot from the Windows CD and press "R" to get to the repair console, I get the following message:

    "The Recovery Console provides system repair and recovery functionality.
    Type EXIT to quit the Recovery Console and restart the computer."

    I then get a "C:\" prompt.

    I am never asked to "Which Windows Installation would you like to log on to
    (To cancel, press ENTER)?"

    If I then try any DOS commands all I get is "There is no floppy disk or CD in the drive"

    Any ideas....?

  4. westy_jesty

    westy_jesty TS Rookie

    More input

    As an acquaintance of pcforum, I can add this info.

    We removed the C: drive and connected it to a USB to SATA adapter on another computer. Now although it found a drive (listed in the Safely remove hardware box), it did'nt give it a drive number, as you would expect.

    This meant that the drive could not be accessed, to rename the psapi.old file.

    It seems very odd that just changing a single .dll file would cause these problems.

    Any ideas.
  5. pcforum

    pcforum TS Rookie Topic Starter


    Ok Guys, need some serious help here....

    SNGX1275, We are almost there. I can get to the recovery console but my hard drives are not visible. I didn't realise it before but the Dell Dimension 9150 uses a Raid 0 disk configuration. Obviously, the drivers aren't loading during setup.

    I now realise, I need to press the F6 key to install SCSI / Raid drivers but if I do that, I'm only given the option to add them via the A: drive. This computer doesn't have a floppy drive. I have the drivers on a USB stick and I can put them on CD if necessary but I don't get the option to specify any other drive - any suggestions. There are two CD drives in this computer but no floppy drive.

    Various people have suggested using a Linux live CD or BartPE - I've tried both and in both instances, it looks like raid 0 support is not provided. I've used BartPE and Ubuntu - both load ok but neither have raid 0 support so the hard drives are not visible.

    So, we are so close now - I can boot off CD / DVD. I have the raid 0 drivers on USB stick. I'm sure all I need to do is rename the psapi.old file in the windows\system32 folder and all will be fine.

    So, can anyone help.........

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...