right clicking takes too long

By Amigosdefox · 12 replies
Mar 28, 2003
  1. Ever since I installed a nic in my computer to connect to my dsl provider, whenever I right click a file or folder (to change its name, view its properties etc.), the menu takes really long to appear. The dsl software installed the pppoe protocols in my computer but I think the problem started right after I intalled the nic and before installing the software. Does anybody have any idea of what could be causing this?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    It's most likely caused by something added to the shell context menu not working properly (e.g. you just deleted winzip instead uninstalling it).

    I can't imagine anything that could have come with the NIC or DSL that could put itself there though.

    Try running a registry cleaner, these usually take care of nonexistent handlers and such.
  3. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,667   +987

    If you are running a fast computer with enough RAM where excessive disk thrashing is not supposed to take place, I believe it could be some program running in the background causing the problem.

    I'm the kind of user that can't be bothered with slowdowns of this nature. At most times, I have my computer running the following programs in the background: ZoneAlarm, Trillian, iTouch (logitech keyboard) & the UD Client.
    You know, the first and most important reason why I have all these is because none cause abnormal slowdowns, otherwise I could live without any of them.

    Antivirus utilities, I believe, can cause such problems, same goes with all non fine-tuned programs in general or beta versions of them. Look for all programs running in your computer when you start up, look in the startup folder and in your registry and try to run the minimum number of programs possible.
  4. Amigosdefox

    Amigosdefox TS Booster Topic Starter Posts: 100   +10

    Thanks for the replies. I cleaned the registry with system mechanic, and tried making a selective boot without the startup programs but still the problem ocurrs. I had a similiar problem with another computer, when trying to view the desktop properties. The window would take up to a minute to appear.
  5. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    Never hurts to defragment your hard drive too ;-). Worth a try though I doubt that is your problem.
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Click somewher in Explorer, wait fro the menu to appear. Try uninstalling/reinstalling programs that have entries in the context menu e.g. archivers, virus scanners etc.
  7. Amigosdefox

    Amigosdefox TS Booster Topic Starter Posts: 100   +10

    Now ive noticed that the problem not only occurrs when right clicking a file or folder, it also happens when I select a file or folder and then click on "file" in the menu bar. The menu hangs for about 5 seconds before displaying the available options for the file or folder. I also disabled almost all the programs in the context menu but that didn´t help. Another strange thing is that the problem occurs with all files or folders including shortcut icons Except for url files and other windows icons like "my computer" and "recycle bin". The problem doesnt occur if the file selected is an url or if it is a shortcut icon targeted at an url file. If I create any file and right click on it the problem ocurrs, but if I change the file extension to ".url", the problem doesnt ocurr.
    I have narrowed it down and apparently the problem actually is the network adapter. First I tried booting in safe mode and the problem didnt occur. Then I uninstalled the network card and uppon rebooting i got an error message saying "Exception on ESockError in module shellapi.exe at 00056267 10038: Socket operation in non-socket", however, the rigth clicking problem stopped. The error message dissapears if I reinstall the network adapter. I had seen the error message before installing this specific nic, it happened with another nic when I uninstalled and reinstalled it to make my computer the host for the internet connection instead of a client sharing the connection. That network card did not detect my dsl modem so I installed the current one. Ive tried installing new drivers for the nic but it doesnt help.
  8. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,667   +987

    BTW, have you tried updating your chipset drivers?
  9. RustyZip

    RustyZip TechSpot Paladin Posts: 322

    Just a thought, but have you got Microsoft Office installed ??? After installing it i noticed something similar to your problem...
  10. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    Sounds like your Registry is pretty hosed at this point. I'd suggest a fresh Windows install.

    When I first got DSL I used the software that came with it. It was Enternet 300 connection software. It caused all sorts of annoying problems. Even uninstalling it didn't fix the problems it caused. Now I have a Linksys DSL Router and with a clean install of Windows everything is happy. No more need for DSL PPPOE software; Just tell the Router your username and password once and no more logging in. When you start the computer the NIC automattically is connected and on the internet. Getting a DSL router is worth it even if you have only one computer. Far less hassle than the crud your provider makes you install.
  11. StormBringer

    StormBringer TS Maniac Posts: 2,244

    You probably should restore the backup you made of the Registry before you cleaned it.... You did back it up right?
  12. filthy_mcnasty

    filthy_mcnasty TS Rookie Posts: 78


    download the "Power tools" on that website and it gives you all kinds of registry cleaning options and you can edit your "new" menu and all kinds of cool things, if you dont know what you're doing then this program has some ***** proofness built in but you could do a lot of harm too so make sure you read up first. should speed things up.
  13. Rick

    Rick TechSpot Staff Posts: 4,572   +65

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...