Router limiting packet size

By pacsailor ยท 7 replies
May 15, 2006
  1. I have been using a D-Link wireless 802.11b router for several year and just decided to replace it with an Airlink101 AR420W 802.11g router. The router gets the connection to the internet going but the packet size is very limited therefore I cannot access any website that has a bit of graphics like the Yahoo home. When I monitor the network status window it shows that the "Sent" bytes is about 8-10% of the "Received" bytes. I can get to Google home web because it does not have any graphics (not a lot) but nothing beyond that. I can ping, and sometimes I can ping Basically when I open the IE6 it finds the website but gives the message "Website Found. Waiting for Reply" and just sits there until it times out. My connection from a Desktop PC running Win XP SP2 to the router is an ethernet cable, my ISP is SBC (or AT&T) DSL using a SpeedStream 5360 modem. I tried the wireless connection from my laptop but I had the same problem. The MTU was first set to "Auto", I then set it to "Manual" but it is set by the ISP to 1492 and could not change that.

    When I plug my old 802.11b router everything works well.

    I actually tried an 802.11g router from D-Link two months ago and had similar problem, I spent at least 7 hours with the tech support who gave up on the problem, and at that time I thought it was a D-Link product issue.

    Any help is appreciated.
  2. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    Actually, that's a good number. With it, set DO NOT FRAGMENT.
    MTU discovery will limit all upstream nodes to your 1492 and you should be fine.
    Dial-up MTU is better with even smaller numbers, like 1024, so your graphic
    problems are not due to the MTU choice you've made.

    If all else fails, go back to "auto" but leave DO NOT FRAGMENT.
    Packet reassembly (for fragments) is a typical hole for attacks which
    will get obviated by not fragmenting in the first place :)
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Have you set your firewall to block ICMP messages? MTU discovery runs over ICMP and by default firewalls tend to block it.

    You can also force the MTU on your PC (some fudging in Windows registry). Make it something small like 1300 so it will definitely fit into your ISPs network.
  4. pacsailor

    pacsailor TS Rookie Topic Starter

    Modem compatibility

    The customer service fellow at AirLink101 suggested that the modem I have (SpeedStream 5360) is old and may be incompatible with the new router. Is there any truth to this??

    I searched for Firmware update for this modem but I found only one that was to fix a specific problem with a specific batch of these modems. There was no other firmware update posted anywhere I searched.

    I had the Firewall and the AntiVirus software turned off during this process.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The modem worked fine with your old router, didn't it? WHat if you plug a PC in the modem directly without a router?

    If it fails to work only with a specific router, then it's highly unlikely that you have modem issues.
  6. pacsailor

    pacsailor TS Rookie Topic Starter

    I did hook up the modem directly to the PC and was able to get online. The reason I tend to believe it is a modem compatibility issue is because I had this problem with two D-Link 524 802.11g routers. Basically only my old 802.11b router works with this modem.
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How about a non-D-Link router? Surely, if two diferent kinds devices work and one specific model doesn't, then it cannot be the fault of that specific model, right? :rolleyes:

    BTW you do have the latest firmware on that D-Link, right?
  8. pacsailor

    pacsailor TS Rookie Topic Starter

    So I have tried that too. My original 802.11b router is an old D-Link which works find, but it is 802.11b. So my first thought two months ago was to buy another D-Link but 802.11g with 108Mb (model 524) of Super G as they call it. I ran into this problem, the tech support told me it might be a defective unit so I replaced it, well, the second unit had the same problem. So I thought D-Link has a design problem and returned the router to the vendor. Last week I decided to go at it again, so I purchased an AirLink101 model AR420W, it is 802.11g Super G with 108Mb. I ran into the same problem that I had with the prior two D-Link routers. All of these routers were upgraded to the latest firmware. So now the only thing in common is the modem, there is no firmware upgrades for this modem that I can find. The only upgrade is for a specific batch to fix a specific problem so I did not download that firmware.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...