Samba up, but only able to share CDROM.

By novkhan
Apr 27, 2004
  1. My Samba have been set up and now i can share my CDROM between 2000 .
    Using my network place---Workgroup---CDROM from 2000.

    I tried to put my Root folder from RH9 to share .

    I used my win 2000 to access the folder ,
    i get a message

    " \\Localhost\root is not accessible. The network name cannot be found"

    But the strange is that i can access RH9 CDROM folder from WINDOWS!

    i wonder if my Samba setting is set right!
    But my CDROM settings from Samba is exactly the same as ROOT settings.
    The Samba settings is displayed below.

    Base Options:
    path: /root

    Security Options:
    guest account :nobody
    read only:Yes
    guest ok: No

    Browse Options
    Browseble :Yes

    Miscellaneous Options
    Available: Yes

    I have also tried playing resetting the Base Option
    Base Options:
    path: /

    but still it doesn't work
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    First of all, there is no need to create multiple threads for the same problem.

    & as allready said in your other thread, if from the windows machine you are trying to access localhost, you are accessing THE WINDOWS MACHINE, not the Linux machine.

    localhost refers to the machine you are working on, not the machine you are connecting to.
  3. novkhan

    novkhan TS Rookie Topic Starter Posts: 35

    Oops sorry for that!

    Here is my samba.conf file. Please Help!

    # Samba config file created using SWAT
    # from localhost.localdomain (
    # Date: 2000/04/30 15:56:56

    # Global parameters
    server string = Samba Server
    encrypt passwords = Yes
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    printing = cups

    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775
    browseable = No

    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    comment = Share CDROM
    path = /mnt/cdrom

    comment = Windows File
    path = \\\mnt

    comment = root
    path = \\root
    guest account = novkhan

    Tried \\\...
    all sorts of way but in vain!

    Onli able to share CDROM!
    strange huh!.....
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You are supposed to specify pathnames, not network addresses.

    Forget the IP addresses: you should specify the root share just like the CDROM share:

    And while you're at it..

    And the slashes go forward in Linux when you are defining path names.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...