Sapphire Radeon 9600 sux?

By fazi1985 ยท 13 replies
Dec 24, 2003
  1. Hi!

    I bought yesterday a new config. (ASUS P4P8X P42.66/533 Sapphire 9600Pro 1024/333 RAM) I've catalyst 3.9, DX9b & the latest intel chipset drivers. The problem is: the system halts during 3d apllications eg. 3dmark01/03, street legal redline ...
    I'm downloading cat3.10 now (Dial-UP) so haven't tried it yet but I suppose it won't. Any idea?

    Merry Xmas! :)
  2. SubKamran

    SubKamran TS Rookie Posts: 166

    The 3.1 (the supposedly "new") only works for Windows XP 64-bit. :)

    I have a sapphire Radeon 9800 and it works perfect (on a Intel 815 chipset).

    Is your power supply connected to the 9600? (or does it even need a power supply connection at all...)
  3. fazi1985

    fazi1985 TS Rookie Topic Starter

    Well, it's plugged in correctly. I tried all kind of catalyst drivers, none of them works. When I start benchmarking in 3dmark the first test runs for a little amount of time (this time is changing), and then freezes. <= (don't know how to write) Sometimes I can do nothing with it but reset, sometimes a window pops up and states somthing like this: "VPU Recovery has reset your driver to default settings due to a problem..." So that's the case. I've no more idea. I suck with my Xmas "surprise". I hope you don't!!!

    Merry Xmas! Ciao
  4. ak_in_charge

    ak_in_charge TS Rookie Posts: 119

    I would recommend just doing a repair install of windows. This will usually fix any conflicts that you are having.
  5. Scol

    Scol TS Rookie Posts: 88

    Hmm... driver issue? Perhaps uninstall the card deleting all old remnants, then reinstall? I dunno...
  6. werty316

    werty316 TS Rookie Posts: 185

    Try the older Catalyst drivers.
  7. fazi1985

    fazi1985 TS Rookie Topic Starter

    Now I have 3.10 Cat. I can run 3dmark in Software T&L mode. It works correctly, but Hardware T&L and Pure Hardware T&L doesn't do so. And how can I downgrade to older Cat drivers? Can they be uninstalled?
  8. SubKamran

    SubKamran TS Rookie Posts: 166


    Add/Remove Programs

    Uninstall anything related to ATI :)
  9. tripleione

    tripleione TS Rookie Posts: 154

    Make sure that you have installed any chipset drivers for your motherboard as well, such as AGP drivers.
  10. werty316

    werty316 TS Rookie Posts: 185

    Oh yeah forgot about those chipset AGP drivers. Install them whether it be Intel or VIA or SIS. Get'em from their respected websites.
  11. fazi1985

    fazi1985 TS Rookie Topic Starter

    OK, I try different Intel chipset drivers. Well, this issue is a main problem. I talked some guys having the same problem. ASUS P4P8X vs Radeon 9600Pro. They also have no solution.
  12. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Try lowering the card's core/mem speed. Sometimes the cooling system might be defective leading to overheating from the card.

    The fact that it can run a few tests before crashing makes me thing that might be the culprit.

    Also try keeping the case side panel open while performaing your tests, see if that helps.
  13. fazi1985

    fazi1985 TS Rookie Topic Starter

    Hi! To my great suprise lowering AGP speed from 8x to 4x has solved the problem. And anyway? Does this 4x difference effects speed?
    Thx all your help!
  14. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,978   +15

    No you wont see any difference in numbers or performance, going from 8x to 4x.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...