SATA and MSI K8N NEO4 Mobo

By easydog ยท 18 replies
May 8, 2006
  1. Hello ....
    I am building anew PC. I have two SATA drives and an MSI K8N NEO4 Platinum mobo. Windows XP Home edition SP2 will NOT finish installing. It hangs as it is trying to "save settings". The drives are Seagate ...
    a 250Gig and an 80 gig. Both, are I believe, SATA II. I have them plugged into the high speed SATA ports on the mobo and the onboard controller shows enabled in the BIOS. But XP will not detect the drives either as regular SATA drives or even in a RAID configuration. At F6, I have tried loading the manufacturer's disks, but they do not appear to read. I don't think those drivers should even be needed, but the floppies spin but do not read.
    The floppy drive is brand new so I guess the floppies could be bad but I also made my own floppies and they do not read either. I am at a loss.
    The BIOS is V1.B which is the latest oner available.
    Any ideas are greatly appreciated.
    Thanks much .... Easydog
  2. theholmboy

    theholmboy TS Rookie

    Ah yes, the good ol' nForce4 chipset

    What do you mean when you say "the high speed SATA ports"? You will want to use the purple SATA ports for the system install, since they more closely work like an IDE channel. Also, is the 80GB drive is for the system install? If so and you aren't planning on RAID striping them, I would just try to install with the system drive plugged into the #1 purple sata connector (oddly, the 2nd one from the battery).

    As for the floppy drive issues, I have had a high failure rate on floppies as of late, so I just keep trying a different one until one works. My complaint with the nForce4 chipset is that all the components it controls aren't recognized by Windows until it is completely installed and you run the main nVidia installer that installs all of the individual drivers. Then, your RAID & LAN and the rest start working. Also, at that point, you should be able to get the Silicon Image RAID stuff working correctly.

  3. easydog

    easydog TS Rookie Topic Starter

    Thank you for your reply. I finally got the XP Home Edition to finish last night. I changed floppy drives and was able via F6, to load the SATA/RAID controllers. I am not sure why, but those drivewrs are apparently critical even though they were RAID related and I am not using RAID.
    I do NOT have the drives plugged into the purple slots as you indicated but perhaps that is the right place. Actually, the 250 Gig drive is a SATA I and the 80 Gig is SATA II (careful planning.. ). I am bothered however that the BIOS still can not hardware detect the drives .... if I try it, it just hangs.
    I am afraid to move any of the drives now that I finally got it to work.
    Appreciate your suggestions and input.
  4. theholmboy

    theholmboy TS Rookie

    BIOS detecting SATA

    I'm glad you got it to work. I only have 2 motherboards (out of 8) where the BIOS recognizes the SATA drives and doesn't require the floppy during install. I do hope Microsoft removes the floppy requirement for installation of Vista onto SATA drives, because that is the only purpose floppy drives serve anymore (for me anyway), other than a BIOS upgrade here and there.

    I still recommend using the purple SATA connectors if you are not doing RAID mirroring or striping. I don't believe there is a performance difference and you can disable the Silicon Image RAID BIOS = faster boot times.

  5. easydog

    easydog TS Rookie Topic Starter

    Though my system is up, I don't think all is well. Explorer hung last night as I was merely trying to look at the C drive. MSI indicates that I may want to clear the CMOS via the SW1 button. I'm not sure of the procedure for that.
    Also, an earlier comment about plugging into the purple connectors, has me a bit concerned. I don't see any reference to them in the BIOS .... only SATA 1 - 4. I have a strong feeling plugging the SATA drives into those purple ports will result in boot device not found. But I will try it. Thanks very much again.
  6. theholmboy

    theholmboy TS Rookie

    Boot device

    If you plug the system drive into the first purple SATA channel (the second from battery) and then go into the BIOS and make sure that drive is first in the boot order, it should boot the same way. If that doesn't work, no harm done, just plug it back the way you had it. When you are in Windows, go to the Device Manager (Right-click on My Computer->click Properties->click Hardware tab->click Device Manager) and see if all drivers are installed correctly, particularly the Silicon Image RAID drivers. If any aren't, they will have a little yellow exclamation icon next to the.

    Running the system off of a RAID can be problematic, hence the nForce SATA drivers (the purple SATA channels).

  7. easydog

    easydog TS Rookie Topic Starter

    THanks again. I don't want to belabor this but I believe the yellow ports/channels are the high speed (SATA II) and are NVRAID while the purples are the Silicon (SATA I) ports. At least, that's the way the documentation reads. But, what do I know. I'm going to try it. I just feel there has to be somethiong wrong sinced I can't get the "hardware detect" to work in the BIOS. But this is one of the "benefits" of building my own PC. Thanks ...
  8. theholmboy

    theholmboy TS Rookie

    You may be right

    I only briefly glanced at the manual and just figured that the Silicon Image ports were next to the chip on the board. Anyway, it doesn't hurt to try different configs until you find the one that works correctly.

    Good luck!

  9. easydog

    easydog TS Rookie Topic Starter

    More issues ...

    Thanks to theholmboy for your help and any others.
    My system will "machine check" event code 51, paging errors on
    \device\harddisk0\D each time a load the video manufacturer's (XFX) CD into my DVD reader. So, I'm wondering if there is a mismatch between my RAM (2 sticks Crucial 512MB, one stick for each of the two green memory slots on the K8N NEO4 Platinum) and the Segate ST3250823AS (250gig) SATA drive. I say that because when I boot, the system indicates that I have
    DDR 333 single channel, 64 bit when in fact it is DDR 400. I don't know whether that is an issue. Also, best I can tell, the 250 gig drive is at firmware level 3.03 ... the drives (from Newegg) are OEM .. so I don't think Seagate deals with any firmware upgrades fo OEM. I can't tell whether 3.03 is current or not. I would welcome any s****tions about this memory check/paging error ......... thanks again to all.
    easydog ........
  10. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I have the same motherboard as you, the MSI K8N Neo4 Platinum. Your two RAM modules are set up incorrectly. They should be in DIMMs 1 & 2 or 3 & 4, with DIMM number 1 closest to the CPU. For example, one module should be in the Green slot next to the CPU and the other in the Purple slot right next to it. That would be DIMMs 1 & 2.
  11. easydog

    easydog TS Rookie Topic Starter

    Mailpup reply ....

    Do you have DDR2 or DDR like I have?
    I swore that the instructions indicated to populate the green slots first.
    Thanks much??
  12. kirock

    kirock TS Rookie Posts: 1,221

    I'm not so sure mailpup, I'm looking at the manual now, pg2-8 and it says for either single or double sided it should be 1 and 3 (fill the greens first). This is indicated in rows 5 and 6 in the table.
    Here's a quote: "Always insert mem modules into the green slots first, and it is strongly recommended not to insert the mem mods into the purple slots while the green slots are left empty."

    I've got my installed in 1 and 3 (greens) from minute/day one and have had no issues.

    Edit: I have the MSI K8N NEO4 Platinum SLI (not sure if SLI makes diff)
  13. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I have DDR (2GB Corsair XMS 3200C2PRO). The MSI board doesn't support DDR2 anyway. I admit the manual is confusing, possibly bad translating. Note that on page 2-9 it says that if you install double sided memory (is there any other kind these days?) in DIMMs 1 & 3, maximum memory speed decreases (to DDR333). That is confirmed by reading the table on page 2-8. It will still work but not at DDR400. So if you want dual channel functionality with double sided RAM, install into DIMMs 1 & 2 or 3 & 4.

    Where the manual gets confusing is when it tells you to install in the green slots before the purple, as you pointed out. I believe this really means just don't install one or two modules in the purple slots while leaving the green ones empty. The other way around is ok. But again, look at the chart on page 2-8 and note that for two double sided modules, 1 & 2 or 3 & 4 gives the maximum speed.
  14. kirock

    kirock TS Rookie Posts: 1,221

    Umm, by Joe! I missed that little DDR333 in the right hand column in row 6!
    Maybe that's why I can't OC this puppy worth sheet. I did this the morning I was building her and never really looked at it again until now, but still missed it!

    Thanks mailpup.
    Commencing system shut down.
  15. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    You are very welcome. :)
  16. easydog

    easydog TS Rookie Topic Starter

    Okay .... I guess I can't read. The Crucial RAM is double-sided so I will populate one in a green slot and one in a purple. Sounds "politically corect" to me. I'll give that a shot, but I still have concerns about the machine check and whether this will correct it. More later .... Thanks easydog....
  17. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    The RAM positioning issue caught my attention so that's why I commented on it but I don't think it has anything to do with your SATA/RAID problem. Sorry, I didn't mean to imply your original problem would be fixed by changing your RAM configuration.

    I only thing I can say about your original problem is to make sure both sets of SATA/RAID controller drivers are installed. Your motherboard came with two floppies for two different sets of controllers, Silicon and Nvidia. But I think you've done that already so I don't have much else to contribute.
  18. kirock

    kirock TS Rookie Posts: 1,221


    Couple of things to check in your BIOS and sata connections. Sata 1-4 ports are control by the on board nForce4 chip, Sata 5 and 6 are controlled by the on board Sil3132 Silicon Image chip. The F6 install is required bc both these chip need drivers and WinXP STILL hasn't included these drivers yet. Hopefully Vista will.
    In BIOS goto Intergrated Peripherals/IDE Function sub menu:
    Make sure SATA1/SATA2 are enabled.
    Plug both harddrives into SATA1 and SATA2 ports on the mobo. Your master HDD should be in SATA1 (the 2nd port down, of all things).
    Also press enter on the Inter. Periph/nVidiaRAID to open sub menu and set RAID if so desired.

    you can enter the onboard DEvice menu from Intergrate Peripherals and enable/disable the Sil3132 RAID chip. (note* these are not need unless you are running 6 HDD's in some higher RAID mode (i forget the RAID modes right now)

    That should do it, that's how mine's set up and I haven't had any problems since day 1. Except for the bonehead move of putting my RAM into slots 1 and 3. :blush:

    Let us know how things are coming along. By chance what wattage is your PSU, you know you need at least 400W crappy if not more if you've got a 7000 series nVidia or an X1800X or higher?

  19. easydog

    easydog TS Rookie Topic Starter

    I have a 400 watt PSU, SmartPower which came with the Antec case.
    Today ... I rebuilt XP on my spare SATA drive (80gig) and that seemed to build okay. However, reading the CD from XFX causes the machine check as always. So, I pulled the Sony DRU 810A DVD unit out and shipped it back to TigerDirect. Don't know if that is an issue, but I'll find out when the new one arrives. I also solved the memory issue .. sure enough, one in green and one in purple....
    I did load all the drivers form the two diskettes via F6 for each of my builds.
    MSI sent a CD with drivers as well... I didn't check, but assume they are the sam vrsion. I still am mystified why the hardware detect hangs when trying to detect either SATA drive. SATA1-4 is enabled. The drives are in the first two SATA ports......... Wish I was smarter.....

    Thanks to all
    Easydog .............
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...