SATA DVD not found in BIOS but HDD is

By Haydnc ยท 7 replies
Nov 17, 2007
  1. Hi all,
    Have a weird one I can't fathom and looking for any advice/s****tions I can get.
    My wife's PC uses a Gigabyte GA-8VM800M-775 motherboard. It has two SATA connectors - SATA0 an SATA1. I have a Maxtor SATA HDD drive connected to SATA0. Before now, I never tried connecting it to SATA1 but if I now do, it isn't found in the BIOS or in Windows (XP Pro) despite the SATA switch in the BIOS being set to "Enabled". As I have only the one HDD drive, I installed the SATA driver when I first installed the Maxtor. The SATA type is set in the BIOS to "IDE" rather than "RAID".
    I have just replaced a Lite-On (IDE) CD-RW drive with an LG (SATA) DVD burner. If I remove the HDD and connect the DVD to SATA0, it is found in the BIOS without problem but connecting it to SATA1 doesn't, just like the HDD. I have installed the latest BIOS for this mobo and chipset drivers from Gigabyte's site but without success. The boot sequence is set to "HDD, CD, and Floppy" though one suggestion was to reverse this - I've done so, without success.
    To test a solution, I purchased an Ultra ATA (IDE)/SATA connector - it fits into the IDE socket on the mobo but has two SATA outputs; SATA1 is one for a SATA mobo to parallel ATA HDD whilst SATA2 is for a parallel ATA mobo to a SATA HDD. Using this device with the SATA cable connecting the SATA2 output to the DVD drive and inserted into IDE1 socket on the mobo, it's found in IDE Channel 1 as a Master and works in XP OK.
    When I bought the DVD drive, I thought it was going to be a simple matter of plugging it in. I have searched the Gigabyte site and the Internet but haven't found any reason why the SATA1 connection isn't working or even how to turn it on or off, so perhaps the mobo connector is useless. Ideally, I would prefer to get the SATA1 socket working as it allows geater speed transfers rather than using this connector. Anyone got any other suggestions or ideas I can try on how to get SATA1 turned on?
    Thanks in advance.
  2. davids

    davids TS Rookie Posts: 96

    i would first check if there are jumpers on the dvd drive (probably not as i dont think sata needs jumper settings).

    If not, it is probably an issue in the bios, in the drive setup see what other options you have besides ide, also check that the secondry drive setting in the bios is set to auto and not disabled.

    then post back
  3. Haydnc

    Haydnc TS Rookie Topic Starter

    Thanks Davids, but there are no jumpers on the DVD (or the Maxtor HDD). I went back through the mobo manual and there are no jumpers to tweak there either. All the drives set in BIOS to "Auto". The only other thing I could try is set the SATA mode from "IDE" to "RAID" but with only one hard drive, it seems the wrong thing to do. I even tried using another SATA cable but no success. If I do try setting the SATA to RAID, what type should it be set it to with only having one drive?
    I saw on another website this afternoon a suggestion that it may be necesary to re-instal the SATA driver for each drive, so I tried it but to be honest, don't know how successfully. I created a floppy with the required drivers on it, started the WinXP set up, entered 'F6' as soon as it started and after loading a series of third party files, it found the VIA VT8237R SATA/RAID controller. The required files were then allegedly installed but I didn't then proceed to re-instal Win XP as it didn't actually recognise the partition - showed "unknown disk" and rather than lose all my data, I quit. On re-boot, the drive is still not recognised within the BIOS.
    I did try selecting the .sys file from the floppy and right mouse clicked, selected "Instal" and something did load.
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    You may need SATA drivers.
  5. davids

    davids TS Rookie Posts: 96

    Yea may need sata drivers, seems unlikely though. I know when installing xp you often need them, but as far as I know when windows is already loaded it asouldnt have any trouble picking the drive up.

    I would say it was most likely a setting in the bios, I seem to remember a computer that was in my shop the other day and we had to enable raid in the bios for it to recognise a secondary sata drive (even though we wernt using raid as such, asnyone else have an opinion on that?) and if it was mine I would just mess around with the settings, but that would be bad advice to give out in case things go wrong!

    Of course there is a possibility that the sata1 pin is faulty but i find that quite unlikely.
  6. nickc

    nickc TechSpot Paladin Posts: 923   +11

    Haydnc, set the SATA to IDE in the BIOS and it will work.
  7. Haydnc

    Haydnc TS Rookie Topic Starter

    Hi Nickc, the BIOS is already set to IDE. Will try Davids' advice and set it to RAID and see if it'll pick the drive up.
  8. nickc

    nickc TechSpot Paladin Posts: 923   +11

    hope that helps the and it might but I think u may have to a cd or dvd to install the drivers for that then.

    Good Luck
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...