1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

SATA Harddrive not being detected

By john_a
Nov 29, 2005
  1. This situation is a bit screwy, and I might not be able to explain it fully. If there's something I said that doesn't make sense, feel free to say so.

    My story starts out with one rainy day and cleaning out my harddrive. I'm a fairly messy fellow, and kept most of my personal files just in the C:\ directory. Going through and cleaning it out, I deleted ntdetect.com. I know -- it was a stupid thing, especially not knowing what it did, however my stupidity isn't part of my question.

    Jump forward two weeks when I finally restart my computer. I get an error saying "NTLDR is missing". A quick search on the internet shows that this ntdetect.com file I deleted could very well be the source of these troubles. "No problem" I think. I just pop my XP disks into the computer, run the system repair on it and try and copy the file over to my C:\. However, it turns out that C:\ doesn't exist. My harddrive now goes urecognized by my computer. Grumbling a bit, I head over to the bios. In the CMOS section, it tells me I have no primary master drive, but a primary slave drive (LITE-ON LTR-523275 if that helps). This is a bit peculiar I think, however I think I remember seeing this before, and this computer has ran for over a year with no problems.

    Another weird thing -- the f6 to install sata/raid drivers with the XP disk doesn't work. When it says it doesn't detect any mass storage devices prescent though, I am able to go select the XP drivers from it with no problem. If from there I go to recovery I get the same problem as before -- no C:\ drive, or any letter drive representing my hard drive. If I go to a full install, it says to choose a device from the list to install on (the list is empty too). Upon hitting the up or down arrow, I get a blue screen telling me a critical error has occured.

    The whole problem is baffling to me. I've tried just about everything my novice head could come up with, and so now I'm turning to you guys. If it helps, my motherboard is a k8t neo.

    Thanks in advance for any replies -- I really appreciate your help.

  2. Carobu

    Carobu TS Rookie

    I had a similar problem a while back with my Sata drive however the sata wasn't the C: drive for me so I could still do many things fine. I had to go into the Bios and Checked around long and hard and eventually I started enabling things and such that I thought would involve a Sata drive eventually I got it and It worked however I can't remeber the setting so my advice would be look in the bios and search around and play with them a little don't change things that are critical though try to play with minor things untill something happen don't mess with things that are obviously not invloving hard drive like cpu settings but you probably already knew that you probably know too it's not smart to screw with the bios but I did and it fixed my problem even though I got lucky It'd say it's the best option unless someone else has a better idea.
  3. Techno_Dragon

    Techno_Dragon TS Rookie

    Try Reinstalling Sata control Drivers

    My motherboard is Asus A8V. It has settings in the bios to enable the Sata/Raid controlers. On this motherboard I can use either the VIA controler or the Promise controler. First make sure your Sata/Raid controller is enabled in the bios.
    If this is enabled then your problem might be that when you get to the Windows setup screen where it asks to install Sata/Raid drivers they may not be located on the Windows cd. I had to download the drivers for the VIA controler from the internet. Once I placed the downloaded drivers on a floppy into drive (a) and selected (S) then (Enter) from the install screen the third party driver installed and all was well. Also If you have 2 sata drives and are setting up a raid array you may have to set up a new array and start from scratch. During post I press the Tab key to get to the raid array set up screen. There are several different arays you can set up. I use raid 0 for performance. I guess Satas are new to most of us. I don't know whats wrong with your Windows boot. Maybe once your Sata is seen by Windows all will be okay. I have never had much luck with fixing a corrupt windows boot. Even if I get into Windows problems usually continue. I usually start from scratch. If these tips don't help I don't know what your problem is other than perhaps a hardware problem. Once your up and running get a backup utility for all your important files. There are many third party utilities as well as freeware even Microsoft has a good free utility to do the job. I'm not an expert just someone who had a simular problem. Good luck!
  4. computerguy9

    computerguy9 TS Rookie

    I had a similar problem with a K8V and western digital SATA drive. The trick that solved my problem (which I haven't seen mentioned anywhere else) was that the K8V boards do NOT support SATA2 -- only 150mb/s SATA. I suspect that the same is tru of the A8V. I was able to add a jumper across two pins at the back of the WD drive to make it run in "150mb/s only" mode (directions were written on the label on the top of the drive). That solved the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...