SATA HDD as extra storage

By BadMonkey ยท 9 replies
Sep 28, 2007
  1. My situation, bought a 500 GB SATA WD (WD5000AAKS) to install on my home built machine, Mochspeed PT88AS with a gig of ram, and Windows XP Pro. I also have 2 EIDE HDDs, one of which crashed and lost its FAT that I want to pull all the data off of, and I have 2 EIDE disk drives. I physically installed the drive, no jumpers just power and data cable to the built in SATA port on the mobo. My mobo bios options are set to look for SATA before SCSI, but my bios doesn't recognize the drive, no matter what driver I try from my Mobo or any other manufacturer, I still get the yellow ! in the device manager. By pure dumb luck I did get the drive to work one time enough to use WD's lifeguard program to recognize the drive, partition and format it. After that, my drives don't show up in my computer, still the yellow ! in device manager, still not recognized by the bios, and running out of drivers to try. Suggestions?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Right-click on My Computer, select Manage, Disk Management. Find your SATA drive in the list, right-click and select FORMAT
  3. gavilan

    gavilan TS Rookie Posts: 62

    Ok, is your BIOS not recognising the drive, or just Windows? If you enter the BIOS config (before Windows boots up) it should correctly identify the drive and its specs. If it does not, then I would check your physical connections, then go to the motherboard manufacturer's website and see if a BIOS update is available for your board.
    If it is just Windows that is not recognising it (which I suspect, since you said that you're seeing a yellow <!> in device manager) then at least that means that your BIOS does recognise the drive. Double click the yellow <!> and see what the error message says. Also, make sure Windows is up to date. Windows requires at least service pack 1 to recognise drives bigger than 320GB. Keep this in mind if you are doing a fresh Windows install.
    If that checks out, then try moving the drive to a different SATA port. Uninstall and reinstall the drive in Device Manager.

    Hope this helps. If you finally get it to work and the cause was no Windows service packs, then you will need to re-partition the drive.
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    To me, yellow in the Device Manager means you need to install the SATA controller drivers. Has that been done yet?
  5. BadMonkey

    BadMonkey TS Rookie Topic Starter

    1. Drive does not show up in device manager, drive manager, or bios screens.
    2. Have tried newer version of sata drivers, searched for drivers, and even just tried reinstalling, etc.

    No it does not look like it is recognized. My comp has the initial bios screen that identifies the EIDE drives, then the next screen it goes to identfies the SATA drives by channel 1 and 2, nothing on either of them there. It also says hit TAB to enter a SCSI or SATA setup, when I go into it, it says no drives are recognized. I have tried all kinds of windows drivers for the drive from my Mobo Manufacturer, so maybe I should try to find a Bios Update and go from there as a next step?
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The drive has to be bad... unless in IDE, the jumper is not set properly. SATA drives don't need jumpers set for proper detection...

    I really doubt if a bios update would help
  7. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Does your MOBO support 500GB SATA? You might have to split the drive into 250GB each if it doesn't by using the WD cd. Did you use the WD CD to setup the drive on your system in DOS not Windows. WD uses some driver that would load prior to Windows. But since your BIOS doesn't see this drive there could be problem with the HDD itself. You can return for another brand or you can buy a SATA USB2.0 case and stick the new drive into that and see if Windows detects the drive that way. If not then the HDD is faulty, take it back or have WD replace it for you..
  8. BadMonkey

    BadMonkey TS Rookie Topic Starter

    Fixed It!

    Got it fixed, found mention in a single posting on WD's website forums about my chipset being an older chipset that doesn't support SATAII. All I needed was a jumper between pins 5 and 6 of my new HDD. I had read and read lots of things and kept seeing that I didn't need a jumper at all. Turns out that is not entirely true if you have an even slightly older.

    Thanks for the help guys!
  9. daronforlife

    daronforlife TS Rookie

    Please help

    I have the same problem my bios is reading my drive but when i try to install windows it just won't read. Badmonkey you said that you fixed it from reading about it on a forum on western digital if you please can you post the link for that forum. Ive been trying to get this POS to work but its just sooo frustrating. Any help or posts will be greatly appreciated
  10. BadMonkey

    BadMonkey TS Rookie Topic Starter

    Sorry bud, like my other post said, my mobo was older so it didn't recognize the new Sata II drive. I had to put a jumper on the pins as the tech support on the website directed to allow the HDD to operate at the older Sata standard. Take a look at your hard drive very closely and/or check the manufacturers website to see if there is an option to jumper it and allow it to work with an older motherboard. If you still need some help, post some specifics and I might be able to help you out. Let me know what type/speed of processor and motherboard you have along with the details on the HDD and I can try to help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...