Sata HDD wont boot, wont reformat

By croixdan · 4 replies
Jan 19, 2005
  1. The Pc was set up for dual boot – both with xp pro 1 60gb Maxtor ide Hdd, and the other 80gb Maxtor Serial ATA , was working excellent. Son downloaded a music program I think it was win amp which affected the pc - now the pc wont boot with both drives connected. It boots and works fine with the IDE drive, but won’t boot at all on the SATA drive. at start up screen it gives me the options to boot it either- safe mode, safe mode with network support, safe mode with command prompt, boot form last known good working order. or boot normally. Whatever choice I make, when the pc tries to boot, there is a blue flash on the monitor, and the process starts all over again, it keep going round in cycles – can’t get to safe mode to delete offending software.

    I decided to do a repair or re install, but the computer just freeze after xp examine the system and load drivers. It does not get to where I press the F8. when it freeze it says “Examining 78529 mb disk 0 at id 0 on bus 0 on viasraid.”
    Is there a solution?
    --croixdan --
  2. HomeStoned

    HomeStoned TS Rookie

    Sata| Drive

    Yeah i have the same problem...
    Everything was ok i had my sata maxtor 160gb as
    my main windows drive, with a partition so if windows
    were to have any problems i could just delete that partition!

    Basicaly my problems started with a blue screen after my house mate
    was transfering from me over a LAN, so turned Pc off.. then alas no more

    It gets to the windows splash screen "winXP pro" loading the little bar going
    then it crashes and restarts or just frezzes.

    I've tryed winxp setup but stops @ 156328mb
    also sata hd can't be found if use floppy Win'ME boot disk to do fdisk.

    Also have tryed WinXp on another standard ATA hd then add the Sata
    whole system slows, takes about 10 min to start windows but Sata Hd
    is listed in my computer, but can't access it.

    I checked some error logs thses 2 mentioed a lot:
    The driver detected a controller error on \Device\Harddisk0\D. - Event ID 11.

    An error was detected on device \Device\Harddisk2\D during a paging operation. - Event ID 51.

    So at a guess i think we need new HD's!!!
    i got 1 month warrenty left on mine...
    shame about the data i had about 90gb of films waiting to be burnt
    but it still spins though so i'm gonna try some apps and see if i can get anything back.

    Let me know if you have any developments

    Cheers Jay
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    This might be a sign of a damaged partition, which could be caused by a failing hard disk, virus or a number of other problems.

    This may also be caused by your SATA drivers not working properly. If you can get ahold of the original floppy disk that came with your SATA controller, I'd be tempted to try a Windows repair using that particular disk.

    You can either use the original floppy disk, or make a new one with newer drivers from the manufacturer's website. When you first press any key to begin the Windows setup, a blue screen will appear and it prompts you to press F6 to install third party RAID or SCSI drivers. You'll want to press F6 at this moment and insert your floppy disk.

    A couple of minutes later, Windows setup will prompt you to specifiy the drivers that will be loaded for the controller. It should be able to read this from the floppy drive and you can install the appropriate driver.

    If this doesn't work, then this will help rule out your SATA driver as the problem.

    I would then attempt to run a drive diagnostic utility to make sure your drive is not defective before attempting to work on it anymore. There's a list of such utilities here:

    This might help you get in the right direction to diagnosing the problem.
  4. HomeStoned

    HomeStoned TS Rookie

    Hard Drive probs

    Thanks for your help Rick but alas i have tryed the winxp setup with my driver floppy @ F6 in winxp setup, gets to where i want to install xp,
    then checks consistancy and stops at 156328.

    Then tryed repair, then tryed to maxtor powermax app, nothing just hangs, tryed as a 2nd master then 2nd slave my Bios see's it my computer see's it but can't access it, only once have i seen the files on it when trying this but still no joy...
    Mmmmm maybe i'll pop it in the freezer, then failing everything :knock:
    then send it back to maxtor as it's in warrenty but i can't find the shop reciept.

    I thought the reason for windows blue screen was to avoid hardware damage :suspiciou
  5. croixdan

    croixdan TS Rookie Topic Starter

    Thanks for all the help you gave - got drive woking again. Tried to boot from windows me and 2000 boot cd, but nothing worked, I finally decided to take the drive to a pc specialist shop, which said it was a virus. They reformated the drive, unfortunately they could save my data. Thanks again
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...