SATA HDs not formatting on Silicon Image 3114 controller

Not open for further replies.

I installed a Silicon Image SA3114-4R four-port SATA RAID card (PCI) on a P4M800-M7 mobo to add additional disk drives for data only. (I just need RAID0)

The case has a 6-slot backplane installed.

Slot number one is connected to one of the mobo's SATA connections, and the other mobo SATA connection is hooked to an internal HD that has the operating system on it. (XP Pro SP2)

I have three additonal SATA drives. The drive in slot one (hooked to the mobo) works fine. The drives in slots hooked to the SI card can be seen in Windows as healthy, onlline, basic, with correct sizes (465.75 GB) and drive letters.

However, when I try to format them, Windows returns a "The Format Could Not Complete Successfully" I can either do a quick format, and see the message right away, or a full format, and get to wait a couple hours before I get to see the message....I've tried it repeatedly.

I can swap drives between slots, and whichever drive is on slot one (hooked to the mobo) works fine and registers as being formatted NTFS.

Device Manager lists the SI 3114 as being correctly installed and working properly.

Also, when I boot up, I see both drives (with correct sizes) listed, then the message 'No valid device available' (something like that). It gives the option of pushing hotkeys to get into the RAID utility. When did that, it shows the drives as physical drives, but no logical drives. I tried creating a RAID set, and the BIOS utility acts like it is doing it, but no logical drives appear, and when I exit out into Windows, nothing has changed. I have tried this multiple times, with no progress.

What am I missing here? Thanks!



Posts: 4,512   +66
I tried creating a RAID set, and the BIOS utility acts like it is doing it, but no logical drives appear, and when I exit out into Windows, nothing has changed.
This is pretty good evidence this is not a Windows problem, which means it is not a driver or windows-based utility issue.

Very strange. The thing about SATA is it is pretty much zero-config... there are no jumpers to set etc. Since we can rule out Windows and drive configuration, that leaves your SATA RAID controller. This in turn, points to either a hardware, firmware or compatibility issue.

Just throwing out some generic ideas, but you may want to try updating your SI 3114's firmware (which is done through a system board BIOS update for controllers which are integrated into the board, usually). If this is a compatibility problem or just a bug, a firmware update MIGHT fix it. Your backplane may have its own updatable
firmware as well, so look into that.

As well, have seen the format error you mentioned caused by two different things - drivers (shouldn't be an issue here unless you have two separate problems) and a setting that controls the speed of SATA in the BIOS (integrated controllers.). There could be an option for 3GHz or 1.5GHz SATA; SATA-I or "SATA-II"; SATA-150 or SATA-300 etc.. (and it may be called other things...) If you see it, lower that setting to SATA-I / SATA 300 or 1.5GHz. There are a select handful of drives out there which do not play nicely with 3GHz-capable controllers. It's a long shot - you may not even have the option - but worth trying.

You know, other than that, unless there's just something you aren't doing right in the RAID BIOS config utility, there isn't much else. I will get another RAID card and see if you have the same issue, but the RAID card really is the only component that sounds responsible for this.
Not open for further replies.