1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

SATA Lag???

By DullOxide ยท 6 replies
Feb 23, 2006
  1. Okay so im having a problem with my SATA drive ive installed for whatever reason whenever I access the drive for anything my system lags like crazy I cant do anything it even lags when I type. So this is currently what I have going on hardware wise that I think matters for it.

    Mobo-Soyo KT880
    HD-Seagate 200gb IDE -Master
    Seagate 300gb Sata

    So far I couldnt find anything on the seagate site about sata lag so im at a loss if anyone can help please reply.
  2. Qendiil

    Qendiil TS Rookie

    this is NOT what i was wanting to find Dull
    i also have a Soyo 880 Dragon MB. Dragon 2, V2.0.
    my SATA drive ALSO is lagging hardcore. i have to wait 20 seconds for Firefox to come up. i can only barely play BF2 due to the time it takes this machine to "verify client data". some of the other players are saying it sounds like a SLOW hard drive.
    so now i'm thinking it sounds like we NEED an updated SATA driver. sounds like were SOL 8(
    i'm browsing all the SATA threads i can everywhere i find them. i'm gonna guess it's our MB tho 8(
    if i find anything useful ill let ya know :)

    oh yeah...
    i DID find a little while ago on the Soyo site a small article that was explaining how to install the SATA driver. they actually used the VIA_RAID driver in their example. we MIGHT give that a try. i just bought a Raptor drive for this thing. gonna be REALLY ticked off if i find out it's the MB and not the drive. i'm going to try using that driver for the F6 install this time. HOPING to swap drives yet tonight. i'll keep you posted

    http://www.soyogroup.com/kb/kbdesc.php?id=377 (that article on soyo site)
  3. Qendiil

    Qendiil TS Rookie


    download this driver set and read the readme file. this was my first build. after reading this readme file i'm really thinking i messed up the driver installation. looks to me like i/we need to have installed a sata raid driver??? not sure, but ive read things that are suggesting that in 2 different places now. download it and the via_raid one and read all the documentation in them. if i/we DID install the wrong drivers, or installed the driver/s wrong, i'm just gonna guess that to fix this were gonna have to do a complete XP and SATA reinstall 8(
    of course, if this IS the problem, i will happily reinstall if it fixes the terrible performance of this drive :D

    forgot to post the page that driver was on :p
    here is the page with all of the updated software for our MB on it. it has listed the ALI sata driver, and the VIA_RAID driver. both are sata driver is if not mistaking


    oh yeah... make sure that is the exact same MB. there's another one with very similar name/numbers... if it's not: click Support>Downloads>English>Your MB
  4. Qendiil

    Qendiil TS Rookie

  5. Qendiil

    Qendiil TS Rookie


    also just found this excellent article on the VIA website. i think this will definitely help you, and you'll also find the defacto most recent version of our chipset drivers too :)


    once again, i'm not sure if you have the dragon 2, or the dragon 2 v2.0. they may use the same controllers/drivers /shrug
    read that article. they'll get you straightened out in a hurry

    i have decided that i tried installing the wrong drivers, and then i messed them up by running SATA instead of RAID. we want to be using RAID in JBOD i'm pretty sure
  6. DullOxide

    DullOxide TS Rookie Topic Starter

    Yes, It is the Dragon 2 v2.0 currently im not booting on my sata drive so luckly I dont feel lag UNTIL I try to access it if I were you I would install another drive for the time being and just use the sata for storage until we figure out whats wrong because this lag im getting is relly bad so if yours is anything like this I think its a good idea. I will keep you posted if I find anything to fix it.
  7. Qendiil

    Qendiil TS Rookie

    hey Dull
    got mine up and running buddy
    i upgraded to the 10k rpm Raptor. i have both installed. both are running very well now.
    not sure if this is the fix you need or not, but...
    i reinstalled XP and this time i used the VIA raid controller driver instead of the ALI one. not sure if i used that one or not, but somehow during installation i screwed the raid configuration. you WANT to use the raid controller even if you are going to use a stand alone drive. that is why ours are lagging. mine anyway. i reinstalled with the VIA raid controller and it's smoking now.

    oh yeah...
    here'a an installation guide for SATA drives and our chipset.

    SATA Installation w/8237 chipset

    and i followed this guy's advice about the sata drivers i used during xp installation:


    Hi Evil Noob (scarry name--LOL)

    I recommend using the Hyperion 4in1 Pro 504A to use post-OS install as well as to use when making the floppy disk (copy the contents of the DRVDisk Sub-Directory to the floppy) for the "infamous" F6 prompt during XP's SETUP if you are installing to a SATA drive (either standalone or in a RAID Aray). The 5.04A installer will correctly check and install the applicable components for your chipset.


    Version 5.04A includes the following components:

    INF V2.50A
    AGP V4.43h
    RAID V4.30H
    IDE Filter V1.20D

    Since at least on my system, I have found "issues" with the combined VT8237/VT8251 SATA/RAID drivers ( SATA/RAID 5.20A Suite) ...that were introduced with the Hyperion 4in1 Pro 5.07A version. I would recommend since you have the VT8237 Controller to stick with what appears to be the last driver suite that does not integrate driver support for the newer VT8251 Controller---which is the 4.30H Suite.

    STAY AWAY! from the "buggy/beta" IDE Accelerator unless you plan on formatting and re-installing XP once you discover that it causes more problems then its worth--

    If you are installing XP to a SATA as I mentioned above you will need to create your driver disk so that XP can SEE your SATA(s) ie: "mass storage device and/or RAID Array"

    Post back if you have any questions

    Saphire X


    youll find the 430H Suite he's talking about HERE

    if i remember right, i used the DrvDisk files he says to use from the 430 suite, and then i had the 5.04 4in1 drivers on CD ready to install after XP was done installing.

    the BIOS can still be tricky even after getting the raid drivers installed and XP installed. youll have to play with it. i MEANT to get right back on here after my install and tell you what i did. but... i thought i had messed it up again and so didnt. then i kept playing with the BIOS settings until i got lucky and got everything set right or so it seems. i never ended up with the SCSI option i heard someone talking about. i dont even think the SCSI option showed up for me during installation this time. prolly due to using the VIA raid driver/s this time. first time around i think i ended up using the ALI drivers or somthing. i cant remember what i did. it seemed like the thing to do at the time, but proved to be counter-intuitive.

    i hope these links and pages help you. if youll follow them i think youll get it up and running. after about 7 hours on here that day i started all this, i now hav a pretty good understanding of how to install a SATA drive and XP :)

    good luck and i hope this helps. lemme know if yer still drawing a blank on any of this after you read those posts. i pretty much found answers for all my questions. not sure if these links will cover it all or not tho. lemme know :)

    i think the MAIN thing i did wrong the first time around was that i THOUGHT that the raid drivers were wrong because i wasnt planning to have a raid. i still dont have a "raid" even with 2 sata drives now. but... this board and bios and chipset and SATA drive must use the raid controller. stick with the VIA raid controller driver/s and you should figure it out. the BIOS settings were pretty intuitive after the 5.04 4in1 update. i just kept fiddling and it finally started working right. after i hooked up the second one i think it even worked better. or smoother.
    one problem i do still have tho and have no idea how to fix at this point is that my machine will no longer shut off by itself. i have to power it down manually. i was sort of spoiled in that department. but the fantastic performance i'm getting now, hitting the power switch is certainly a good trade ;)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...