SATA RAID data corruption problem update

By Per Hansson ยท 9 replies
May 2, 2003
  1. Last time I reported that the data corruption issue had been solved that was indeed correct, however the simple driver update had one drawback; it reduced performance considerably...

    Abit said more than a week ago that they would have this fixed within a week, that has not happened, but now all of a sudden Silicon Image has released a program that makes some modifications to your BIOS and fixes this problem without any performance degradation, although this is not a very easy procedure...

    See the comments for info on how to fix this, big thanks to Arris for letting me know of the fix.

    Note; if you are not severely affected by this problem I advise you to wait for the official BIOS from Abit, after all that is what you have paid them to do if you bought their mobo...
  2. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Well, Silicon Image released a program that (IMHO, and probably Nvidias also) is a very advanced program that should not be let out in the open..

    However, I'm not one to tell you not to use it...;)

    This is what you will need to do with it:

    That method should work for all mainboards, simply install the .28 Silcon Image driver and all should be well... (please read this entire thread before trying)

    Go to Silicon Image web site Click "Product Support" (flashy thing on the lower middle left side)
    Click > Serial ATA > Controllers > Sil3112/3112A
    Click article no. "10516"
    On the left side there is an attachment"
    (UPDATE: seem I was correct about that this program was not intended to be released; it has now been removed from the Silicon Image website, see below for an alternate download site)

    That is the program you will need to put on the dos boot-floppy to modify your BIOS... The .28 driver is also available in the previous list of articles (look at the bottom)

    You can download DR-DOS here

    UPDATE:The problem seem not to be as easy as just that... Please read my reply at this thread for more info...

    Note, StinkNbreff BIOS was removed because it was proven not to fix the problem...
  3. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Hmm, seems like Silicon Image doesn't know what they are doing, they first removed the BIOS changer utill and now this text is on that same page instead:

    After further testing and evaluation, it was determined that flashing the motherboard BIOS is not as straightforward as we had previously thought so the utility has been removed. For the latest BIOS updates for your nForce motherboard that fixes the data corruption problem, please visit the website of your motherboard maker for the appropriate BIOS and flash utilities. There were no revisions made to the drivers for the SiI3112A so you may use the latest version posted on this website. Please check the Related Articles link on the lower right.

    I did try the program on my comp with BIOS v15 and it did not work, however I believe you will need the newer BIOS versions v16 or 17 which updates SATA BIOS for this BIOS modification program to be able to work...

    I dunno really, will test further tomorrow... Till then play safe with this utill and don't yell at me if you hose your box...
  4. It does work...

    I had been working on an ABIT NF7-S w/ a 3/27/2003 dated BIOS for a friend. He'd been experiencing the data corruption problems too. I hadn't been able to solve the problem. It just so happened that on May 1,2003 I stumbled across a forum post for silicon images website that had a driver available. I kept looking and found the SATA BIOS file you are describing. It looks like the file had been released on April 30,2003. Flashing the SATA BIOS was not much different than flashing a motherboard BIOS. I would however think there is one more step to add to the 'list'. After the BIOS is flashed, nvflashs will ask if you want to use the old safe table, use the new one, or type a custom one in. I'd chosen the old safe table at first. And found it didn't help. I reflashed but this time chose to use the current or newer safe table. And since then, I setup Win XP with RAID 0 on two WD 40 GB hd's. I'd installed sp1, directx 9 and 3dMark 2003. I ran 3dMark 2003 continuously for over an hour with NO PROBLEMS. So, because I'd been sooo frustrated with this problem, I just wanted to tell of my success story to further support the solution in this forum. Good luck. Oh and by the way, the SATA BIOS version was originally 4.2.12. After the SATA BIOS flash it still was 4.2.12. But since then, all data corruption issues seemed to go away.

  5. Oh, and one more thing

    The two WD drives were EIDE drives. Both had Serial to IDE adapters.

  6. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Now I'll quote my own reply to the ASUS forums:

    Slartibardfast; seems your are right, the Silicon Image BIOS calls both the _EN_CODE.BIN and (new) BGROUP.BIN file...

    The NF7-S BIOS only calls _EN_CODE.BIN, so it is darn near impossible for us to fix this...

    I've had a look at the source code in the BGROUP.BIN file, and it's not much code really...

    Just a few pages of actual data, rest is just there to take up space it seems...

    Unfortunantley I don't know Assembly programming so I don't know what I'm looking for, but somewhere in that file our fix should be...

    Note: I used WinDasm to decompile the BGROUP.BIN file

    So there you have it; It was not possible to fix it with the Silicon Image BIOS after all because that was a generic BIOS that mainboard manufacturers will need to incorporate into their own BIOS files...

    However Bearacuda, I'd really like to have a chat with you, I think you have found another BIOS file... I'd really like to have a look at it...
  7. I sent the BIOS file...

    I don't use ICQ. I use Yahoo Msgr: my name is 'Bearacuda2'. Otherwise you can email me at

  8. rubjonny

    rubjonny TS Rookie Posts: 19

    Hey guys, this BIOS fix, does it change hardware register values in any way? It would be interesting to see if this fix could be implemented simply with wpcredit & wpcrset.
  9. Did you get the BIN I sent??

    Lemme know if you didn't get it. I'll resend it.

  10. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Re: Did you get the BIN I sent??

    I though I did reply to your mail...

    Well, I've sent a new one, check your mail account...

    And thanks for the .BIN file BTW, however it indeed was the same as Silicon Image posted on their website
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...