Scan driver problem with Canon ImageClass MF8180C

By waterbear
Jun 9, 2006
  1. I have just purchased the Canon ImageClass Mf8180C. This is a all in one machine. I have managed to get to printing and copying working but failing with the scan option.

    During install of the MF Drivers it does not mention the Scan driver at all. After installation (and reboot), the machine is not listed in the Control Panel, Scanners and Camera option (I have another scanner from another machine which I successfully use). The machine is listed in the printers with 2 entries - 1 for printing and 1 for faxing (which also works across the network). I have uninstalled and re-installed several time in hope that it fixes/triggers something.

    If I select to Manually add an imaging device and put the CD that came with the machine, I located the scan.inf file and select it, when it asks you to select the Model - there is none listed. I have tried every .inf on the CD for all the different operating systems listed, but always get an empty listing display. I have looked for updated drivers on a variety of web site, but it seems a too newer model for any to be listed once you drill down and actually try to download it.

    I have logged a call with Canon Australia and one day they will get back to me, but in the meantime, if anyone can tell me what I am missing, I am welcome to suggestions. It is very frustrating to buy a new machine and not have it work to expectations.

    I am using the network connection option on the machine, I have given it a fixed IP address and can successful print across the network. So I feel that there is no problem with my laptop recognising the machine. I looked through the entire CD and installed everything with setup.exe in hope of finding the right file - but no luck. (And I do not think that this stopped the scanner installing as I have tried a variety of installs and options)

    I am running XP Home on a Toshiba laptop with AVG.
    Any suggestions welcome !
  2. waterbear

    waterbear TS Rookie Topic Starter

    Canon MF8180C will only Scan using the USB Cable

    After finally hearing back from Canon, it appears that although the Canon MF8180C has an network port it is only active for printing and faxing.

    To Use the Scan option - you have to plug in the USB cable. To me this defeats the point of having an network option/cable (and the point of buying this machine). A very expensive lesson learnt - and everyone take note !

    Anyway end of problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...