SCSI "JEM" Drive problems

By mobkon
Apr 20, 2005
  1. Hey all! I have an older SCSI JEM drive (probably about 4 years old or so) and its not working right. I just recently reinstalled Windows XP (the computer was running 2000 for years prior to XP). The SCSI card is installed correctly and seems to be working fine. The drive shows up as having 200MB free space, but the total capacity is showing as 512 bytes. The drive opens on My Computer and there are a bunch of folder in there, but nothing in the folders. I tried to reformat but I get a "Cannot lock current drive. Error in IOCTL call". Anyone have any idea whats going on? Could it be this drive doesnt work correctly with XP? I cant find any info on this drive so I dont even know. Thanks alot!
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You could try deleting and recreating the partitions in Disk Management in case it's a problem with the filesystem.

    Am I correct assuming that the drive worked with the same controller before?

    Never heard of someone called "JEM" making hard drives. It might be a rebranded drive from Seagate or some other "real" HD maker. You should run HD diagnostics on the drive in case it is failing but you need to know the manufacturer for that.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...