second hard drive not accessible

By cbc ยท 4 replies
Feb 18, 2006
  1. I just revamped my pc and installed a new 80gb hard drive as master.
    The old 30gb drive I left as a slave.
    I installed win xp fine but I only see one drive in My Computer.
    The bios sees both drives as master and slave.
    I went to disk management in control panel and I can see both drives , disk 0 and disk 1 but the slave has no drive letter attached. If I right click on the slave drive all I get is an option to make it dynamic which is no use.
    As I have a lot of data on the second drive how do I assign a letter to it and get to use it .
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    you can try using paragon or acronis 2 very good disk managers
    both make a boot cd to format and change drives
    what ever you do do not let chkdsk run for that drive you will loose all data
    you may want to look for a recovery app now and copy to your good drive before palying with volume types
  3. lukeyu

    lukeyu TS Rookie

    I suggest you use data recovery software such as EASEUS DataRecoveryWizard to recover files.

    Download demo version:

    You can use "AdvancedRecovery" to scan your drivew. After the scan is complete, the lost file will be displayed in DataRecoveryWizard, you can select them and recover them.
  4. cbc

    cbc TS Rookie Topic Starter


    Thanks for that info.
    I am still confused tho since how do I adress the HD without a drive letter?
    I tried using command prompt but it didnt respond to any letter.
    I also moved it to another PC and its the same thing.
    The windows manager just says the disk is heathy and gives the gbyte free etc but no drive letter.
    If I run a disk recover program surely I have to give it the drive letter.
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    first start with disk manage software like paragon or acronis
    see if you can change the letter with one of them
    if it is there (kinda) see if you can take possession of drive
    properties/security tab advance setting your admin name tick box for all folders
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...