Server 2003 Disk Part Problem

By VorTechS ยท 4 replies
Jan 15, 2007
  1. I've recently had a problem with my server mobo dying on me [IDE ports blew out] and having acquired another mobo found the O/S no longer boots up.

    It'll start and then just hang. Using the boot CD I've booted into the recovery console and used disk part, and can see that for some reason the drive letters for all the partitions aren't what they used to be.

    According to MS KBs I should be able to run a bunch of commands like:

    diskpart list volume
    diskpart list partition

    to get the volume/partition info, and then I should be able to re-assign the drive letters. But if I run these commands, I get nothing, just dumped straight back to the DOS prompt.

    Anyone got any ideas?

    All help appreciated.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Hi Vortechs and welcome to the TS forum :wave:

    When you changed the board was it to one of the exact type?
    you see NT based products such as XP and 2K wont boot at all if you change the motherboard to one that is totally different to the one it was installed on.

    This because during install the OS builds a list of installed hardware and stores it in what is called the HAL, during boot this HAL is checked and if a signifigant hardware change is detected then a blue screen will occur.

    If im teaching granny to suck eggs let me know...

  3. VorTechS

    VorTechS TS Rookie Topic Starter

    Hi and thanks for the reply - it's nice to be here! :giddy:

    The mobo was of the same type, although not exactly. I replaced a Jetway 663AS Ultra with a 663AS Pro.

    I had managed to boot once off the drives using the mobo, and I performed a bunch of roles removals, including removing the DC role.
    So yes, you are right the HAL had changed and I had a Windows Notification to that effect.

    I was under the impression that NTFS stored the drive letters with the partition info - but perhaps the one-off boot had changed them in some way? Seems a bit odd to have done that.

    Anyway, finally found a tool to give me access to the DiskPart I was expecting:

    I've used this to boot, and re-assigned the drive letters, and am in the process of a reboot. Looks to be working as I'm stuck at the old 'Applying Computer Settings' which is much further than I was getting before.

    By the way... very very useful admin tool!
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    Glad to see that your nearly sorted, your right that tool does look useful and is being downloaded now.

  5. VorTechS

    VorTechS TS Rookie Topic Starter

    Certainly is useful, it had the DiskPart tool I was expecting and despite manipulating the drives back to the correct drive letters they were reverted back as soon as the O/S tried to boot up.

    Having said that, I think the replacement MoBo has the same IDE port problem - as I've tried a clean install using a fresh drive and the install fails to copy files in the first part of the install. [Yup, I swapped the CD-ROM out too to be doubly sure].

    So I guess I need to find another replacement MoBo.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...