1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Sil0680 SD-ATA133I non-RAID PCI IDE Controller Card

By cobraxus · 4 replies
Oct 17, 2007
  1. below describes what I'm dealing with:

    To set the boot device on the Syba ATA133I, reboot the system in which the card has been installed. During the boot cycle, the card will post and show the following message:

    Sil 0680 ATA/133 Controller Bios Version 3.2.10
    Copyright © 1997-2003 Silicon Image, Inc.
    Press F3 to enter Configuration Utility

    Press F3 to enter the BIOS. The card will then display the devices attached to the card and will show the following lines:

    Press F1 to assign first (HDD) set
    Press F2 to remove first (HDD) set
    Press ESC to exit

    Press F1. The screen will then show:

    Enter the Set number selected
    Press ESC to exit
    Your Selection?

    Enter the set number of the drive that you want to become the boot drive.

    Press ESC to exit the utility.

    Your selected drive will now become your boot drive.

    In addition to these settings you will also need to adjust the motherboard’s BIOS to boot from the Syba SD-ATA133I IDE controller. Please refer to the motherboard’s documentation on how to choose a boot device in the BIOS.

    Note:>/b> The process of assigning a boot device would not need to be utilized for attaching non-bootable devices such as DVDs or CD-Burners.

    my DVD-ROM is connected to the IDE Controller Card.BIOS detects it but my computer doesn't.I went into BIOS>BOOT>BOOT DEVICE PRIORITY and disabled the DVD-ROM.then I went thru Configuration Utility and pressed F2 to remove it.no effect.
    I'm using an ASUS P5GZ-MX motherboard with Intel Celeron D 3.6Ghz.I'm running WinXP Home Edition(SP2).
  2. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

  3. vedhapuri

    vedhapuri TS Rookie


    I just got the above IDE PCI card inserted to the PCI slot and got the two ide connectors cabled to a HD (non OS - data only) and a DVD RW. I have the other primary OS HD (dual OS XP & Win 2003) connected to my MoBo.
    But the PC won't boot - it hangs after reading the PCI IDE card.. goes no further.. I have learnt from these forums that I need to connect the HD with OS to the IDE Card.. I have tried that also.. but the problem is my default XP OS is in Drive D of the HDD ( single partitioned) and Win 2003 is in Drive C. When I try to boot with the OS-HD connected to the IDE connector, it gets struck at c:/windows/system32/ntoskrnl.exe missing error.
    My question is :
    a) How I do I make the IDE PCI card as non-bootable device; how do I set the PC to boot from the MoBo IDE only? (I could not find this in BIOS set up of my latest Intel DP35 MoBo)
    b) If I can not not escape from connecting my OS HD to the PCI-IDE Card, how do I make the card to read the ntoskrnl file from Drive D instead of C ? and pass through the boot completely ?

    I spent almost 2 days trying out different combinations.. but at a loss.. an immediate answer will help me a lot.
  4. JVene

    JVene TS Rookie

    I just signed up to the board, thought I'd toss my 2 cents worth in.

    I have a Rosewill version of the non-raid Sil0680. I got it to work, but with caveats and 'learning' experiences you should hear about.

    The board will not let my ASRock nforce 430 board boot with the on board IDE enabled. If I disable the onboard, it works.

    There's a jumper on the board not mentioned in the docs, and I don't yet know what it does, but I know it's significant. I thought it might alter the card's I/O position to aid in coexistence with onboard IDE controllers, but no. In fact, I must run this card with that jumper removed, but discovering that crashed my OS on the SATA drive (onboard SATA can coexist).

    Here's what happened. Thinking this jumper might alter the card's argument with onboard IDE, I re-attached the jumper, enabled the onboard and tried to boot the OS. It hangs as usual.

    Upon an attempt to reboot after disabling the onboard IDE, leaving that jumper on, the OS on the SATA was crashed.

    Fortunately I know to back that up, so after a restore of the OS, I removed the Sil0680 for now. I plan to reattempt it in a few days while my RMA options are open.

    The board did run for my intent. I have 2 DVD burners and a PATA HD I want to run with the SATA drive as the main boot/workspace. The PATA drive will be 'auxiliary' storage, and the two DVD drives offer flexibility. I got that much to work. My BenQ 1620 is a bit touchy compared to the Pioneer 111D. Placed as the slave, the BenQ was set for PIO Mode 1, some 3Mbytes per second burst rate. This isn't workable for a 16x drive.

    Moving the BenQ to master position, letting the Pioneer play partner, things worked fine. The HD is on a channel by itself.

    One thing I didn't track down was an oddity after some two hours of use - the Pioneer disappeared from Windows, and from that point forward the Sil0680 (during boot) no longer identified it as a Pioneer (merely IDE3). I re-seated cables, and after a reboot, the drive worked in Windows again. I'm not sure what that was about.

    My guess is that this card is an older technology not practiced with newer boards (even though mine is a chipset from 2 years ago). From what I can tell, virtually everyone selling the Sil0680 makes nearly the same thing - from some reference design (which makes sense, there's two chips, a voltage regulator, a transistor and a few caps. Hardly much innovation possible there).

    The all seem to use the same bios image (and this one isn't flashable it seems - stuck at 3.2.10).

    It's not exactly product of the year material, but with quirks it can work.
  5. cobraxus

    cobraxus TS Rookie Topic Starter

    the jumper I think you're referring to is the HDD indicator light.My problem is the Sil0680 ATA/133I BIOS wants me to assign first HDD set for the device attached to it(making it the boot device).problem is I've attached an ODD(DVD-ROM)and the computer won't recognize it(except in BIOS/BOOT/BOOT DEVICE PRIORITY).Silicon Image makes the chipset but won't offer technical support to end-users.Syba the company the sold it has only one employee named Michael who offers such profound wisdom as "Install correct drivers" "Update BIOS" and my personal favourite "Try it on another computer">
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...