Slooooow Start-Up After RAM Upgrade

By bearpaw ยท 16 replies
Jan 24, 2008
  1. Hey Techspotters,

    I'm hoping this is the right place to post this, if it isn't let me know.

    I had a recurring BSOD problem for a month or two, which was eventually traced to Panda IS (thanks peterdiva) and has been sorted by switching to Kaspersky IS 7.0.

    To rule out faulty RAM, and because I fancied upgrading anyway, I added 2GB of DDR2 memory, two 1GB sticks to go with my existing 2x512MB, the following day (yesterday).

    These were standard Crucial sticks, 'guaranteed compatible' and installed as per the instructions, in the two empty slots.

    Strangely though, ever since, Windows has been starting up extremely weirdly. Boot to log-on is fine, no problems there, but logging on is where it goes off the rails.

    It loads the taskbar, with one icon in the tray (safely remove hardware, for my USB wireless adapter) and then sits and does nothing for a while. The mouse moves, the desktop shows, but clicking does nowt and Alt+Ctrl+Del doesn't respond. Eventually (ten minutes or so) the case hums, the fan starts up, and everything starts as usual, icons in the tray, start menu, everything works.

    And there's no more problems until I next start it up.

    It's bizarre, I can't find a reason for it all, and as you can imagine, ten-minute start-up is not ideal.

    Task Manager shows all 3GB of RAM are physically there, the BIOS recognises the new memory, so I haven't the foggiest idea what's going on. And the Virtual PF is set to system managed, in case that has any bearing.

    I'd appreciate any ideas you could throw at me, at the moment I'm away back into the case to check I didn't knock a wire loose when I was guddling around in there. I don't think Kaspersky's causing the bother, hope not anyway.

    Cheers, sorry for rambling a bit :blush:

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    What happens if you take out the 2x 512 rams ?

    Also even though new, you can run memtest to confirm all ok

    Tutorial: How to use Memtest
  3. bearpaw

    bearpaw TS Rookie Topic Starter

    Don't know. I might try it in a bit.

    I ran Memtest for 14 passes a week or two ago on the two 512s, came back clean.

    I fiddled about inside the case this afternoon, and switched the two pairs around, so the 1GBs are now in the primary slots, and I thought I'd got it sorted when I booted it up just now, but it just got a bit further through the startup process, loaded a few more things, and then went clunky for a while again.

    Going to try emailing Crucial first, see what they say. Otherwise, one thing it could be is Kaspersky blocking system files. It's on training mode right now, and it keeps popping up with warnings saying modified system files blah blah, so that could be what's slowing things down.

    I'll probably try setting the rules manually, turn off training, see what happens then.

    It could save a few hours of Memtesting :)

    Thanks for the reply, kimsland.
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    This is almost certainly Ram mis-matching, or a faulty new stick - obviously test the ram with only units of the same size and spec at a time. Also check the Bios ram refresh rate etc settings, see if the new is not up to what was there before.
  5. wanna be geek

    wanna be geek TS Rookie Posts: 80

    Try going to misconfig and disabling everything them reboot... If the prob stops it is not the ram... I think it a mem prob. Always when mismatching ram (not supposed to ) put the larger, faster moduals in your primary slots...

    Oh yeah, Kaspersky sucks! It is a hog... I like Avast. Right now I don't even use any and I know my system is clean...
  6. bearpaw

    bearpaw TS Rookie Topic Starter

    Righto, I'll run Memtest on the two new sticks while I'm out tonight.

    How do you check the BIOS thing?

    Thanks, BP.

    PS. I like Kaspersky! Much better/faster/cheaper than Panda, which is what I was running before (my dad had a spare license). I've turned off the registry checker anyway, so if that was the problem it'll boot fine next time.
  7. bearpaw

    bearpaw TS Rookie Topic Starter

    Ok.... ran Memtest for a bit (just three passes, I needed back on the PC) using just the new 2GB RAM with no errors.

    Then I booted up, no problems. Switched all the Kaspersky stuff back on, rebooted, no problems...

    So, the problem is RAM, and the problem is running both pairs at once. It worked with 2x512, and it works with 2x1024, but not both at the same time.

    Any ideas why?

    The new memory *should* be compatible, all I did was put my PC details (Dell Dimension 5000) into Crucial's website and clicked the 2GB guaranteed compatible kit. With a quick check to see it wasn't any cheaper elsewhere.

    The new sticks are DDR2 PC2-4200, the old ones, well, I'm not sure, but the sticker says PC2-3200U-333-12-D1.

    I'm a bit confluded.

    edit: And now slightly more so. Crucial's help form thing asked for the codes on the stick, so I shut down, opened the case, took out a stick, got the numbers, put it back (in the same slot), shut the case, booted up.... and it went all clunky again.

    I guess there must be something funny about this new RAM then?
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    On top of size and speed of ram, there is also manufacture.
    Some manufacture (name) brand rams, don't work with other name brands.
    I still say remove the 2X 512M
  9. bearpaw

    bearpaw TS Rookie Topic Starter

    They're out right now. It worked fine the first time with them out, but the second boot with just the 2x1GB went wonky again.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Change the ram slots to the other two, try again


    Do a longer memtest scan
  11. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    I have known problems when taking out and reinstalling ram sticks. It is possible not all connections are really sound (and there are up to 128 of them !!! Press down firmly but not so hard as to bend the motherboard.

    Whatever you do, DONT touch the ram connectors AT ALL on the chips.

    It sounds as if you might need to reseat several times before you get a stable system. Certainly there is every reason why your mix of chips will not work - they are completely different speeds for a start !!! The new ones are 25% faster !!!!
  12. bearpaw

    bearpaw TS Rookie Topic Starter

    Ok, thanks for your replies again. Got an email back from Crucial, as a result of which I downloaded a BIOS update from Dell. I've booted a couple of times since then (still with only the 2x1GB sticks) and it's been fine, so I'll add the others at some point and see what happens.

    gbhall: If it randomly conks out again partway through startup, the first thing I do will be to reseat the RAM, make sure that's 100% solid. I think it is right now, obviously, but there's no way to be sure.

    The speed difference - how much does that matter? According to Crucial, these new chips *should* be guaranteed compatible- they're supposed to know these things. The support guy who replied to my email didn't mention the two speeds (I had done) so I suppose he thought it should be fine...

    Thanks a lot, hopefully the BIOS update will have sorted something... could be that I had a BIOS corruption and the update has patched it up, I've no idea.

    Cheers, BP.
  13. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    well, as kimsland says, at least put the faster chips in the first slots. Always in the past, it has been a case of never mix chip speeds, and even mixing manufacturers is dodgy. You dont think MS have found a solution to this do you ? I dont.

    If you persist, you may find that it works, but is not 100% stable. Be a pity to lose some valuable work to a lock-up just for the sake of an extra bit of memory, that you probably wont use 99% of the time anyway. Most XP PCs work perfectly well on 500Mb. Only big gamers really need more. Of course Vista is another beast entirely....
  14. bearpaw

    bearpaw TS Rookie Topic Starter

    What did I say? I'm trying your advice, but I can't try it all at once!

    The faster, bigger sticks are already in the primary slots (since my second post) and I appreciate that mixing speeds is a bit iffy, but went on the assurance from Crucial that DDR2 was backwards compatible in terms of speeds. I'm not a RAM expert, so I took advice from the folk that cetainly should be.

    Naturally, I spent money upgrading my RAM for no reason.... not. I run some fairly memory-intensive 3D modelling software (Inventor) which would frequently use 90% of my Virtual Memory, plus a gig of physical, so I reckoned that maybe some more RAM could actually be useful.

    I posted this thread to see if anybody had any ideas what was causing the problem, and if there was a way to sort it.

    Seemingly, the problem is mixing speeds, and the answer is get RAM to match the old ones.

    So, thanks a lot, that gives me somewhere to work from.
    Cheers, BP.
  15. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    the only way to make sure they are compatible is to RTFM the mobo book.
  16. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    That's fine, you just might see a more responsive system. You are aware XP cannot use more than 3Gb unless it is a 64bit version? Not recommended to use the 64bit for the present due to lack of drivers and shocking incompatibilities with much software.....
  17. bearpaw

    bearpaw TS Rookie Topic Starter

    Yup, 3GB is plenty though.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...