1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Solved: Drive letters cannot be assigned to flash / USB drives under Windows XP

By Bluemouse · 69 replies
Sep 24, 2006
Post New Reply
  1. Hi,

    I have been having a few drive letter problems with my computer and flash drives, and I was hoping you wonderful people might be able to help diagnose the issue.

    Whenever I connect a flash drive (both my USB stick and my flash mp3 player), it installs properly but does not show the drive letter in my computer.

    When I go to my computer->Disk management, the device does show up. If I assign it a drive letter, it goes smoothly, but still does not show up in my computer. I can still access the drive if i open it from the disk management console, but where the drive letter/name usually are it is just blank.

    When I restart my computer it still doesnt show in my computer, and when I try to assign the drive letter again, the one that I had previously assigned to my device is not in the drop down list, meaning that it still thinks it is in use.

    Computer Specs:

    Toshiba Laptop M30
    Windows XP service Pack 2

    This is a rather annoying problem, and I would really appreciate all the help I can get on this issue.

    Thanks and cheers,


    Edit: To add, when I try to format it in device manager, i get "The operation did not complete because the drive or partition is not enabled. To enable the partition or volume, restart the comptuer." However, restarting does not work. Disk management says the device is healthy.

    Moreover, when I go to Device manager, two of the same drive are present under disk drives. This may be due to the mp3 player having two partitions (one being a small hibernation partition), but i dont know :S It is a Sandisk e260 player, just for that added bit of information.

    Just to add a bit more odd information:

    When I go into a program such as notepad, or anything where I can see the drive letters when clicking "save as" or something, I can see the drive letter that I Cannot see in My computer. The old drive letter (before disconnect) was still there as well, although nothing is attached to it. I can, however, access all the folders.

    I am also experiencing problems with my usb drive disconnecting, which is when I get all these unused but still there drive letters. Every time it disconnects i have to go into disk management and assign a new drive letter again...

    Edit2: The problem with my device disconnecting was the power supply to the usb drives. I got an external and it doesnt disconnect, but I am still having problems with that damn drive letter. All the "used" ones clear upon reboot.

    Hm, still can't figure it out. I just keep running out of drive letters when I continuously disconnect/reconnect/reassign drive letter with my mp3 player...
  2. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    How many drives you have in that M30?

    E: (should be your USB2 drive)

    You can go into adminstrative tools and change the drive letter for D: (DVD/ROM or DVDRW drive to F: this is a quick work around. This problem also comes up on a corp domain, I have to change mapped network drives letters around so that a USB2 drive will should up correcly.
  3. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I have a few partitins,etc

    C: System Disk
    D: CDROM
    E: Data Partition
    Z: USB2 External drive
    ??: Flash drives

    So you think its because it wants to go to the E:\ driive or something? It "used" to work, but now it does not (maybe before, maybe after I upgraded to xppro sp2, im not quite sure).

    What would you suggest given my current setup/mapping?

  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    This doesn't make sence. How many partitions do you have off of the C drive?

    It might be like this:

    C Boot drive
    E 1st partition off C
    F 2nd Partition off C
    G 3rd Partition off C
    H USB Hard Drive
    I-Z Flash drives
  5. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I have two partitions on my CD, my C:/ Drive and my E:/ Drive

    I also have an external usb2.0 Hard drive which works fine, and is mapped to the Z:/ Drive.

    My CD-ROM is on my D:/ Drive

    I then have two flash drives, a USB key and an mp3 player, both of which do not work properly, experiencing the problem I mentioned above.

    Extra steps taken:

    - Changing the drive letters so that D:/ E:/ F:/ are all free
    - Upgraded the BIOS
    - Uninstalled the usb drivers and let them reinstall at boot

    Both of these flash drives work on other computers, and my USB 2.0 Hard drive works on this computer. I have tried all three usb 2.0 ports.

    Hope that clarified it a bit.

  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,009

    how many usb ports do you have
    3 usb devices and ??ports
    usb driver confusion
    can try mapping the drives
    should keep main hdd to no more n 2 partitions
    move or change E to d need to do some juggling round
    with this much mass drive CD or DVD should be after the hdd

    hope that helps
  7. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I have a mouse and external harddrive plugged in, and then either my mp3 flash or usb key flash plugged in sometimes.

    I have 3 ports in my laptop, but one of them is connected to a usb hub with 4 ports. I have tried resolving this issue both with and without anything else plugged in besides one of the flash drives.

    I have tried mapping the drives. Only mapping the flash drives fail

    Main hdd only has 2 partitions, C:/ and E:/

    Tried that

    CD Drive is now F:/ instead of D:/ but I still have the same problem

    Thanks for trying though :) You did better than microsoft or toshiba....

    I just love it when level 2 tech support guys on both ends first suggest that it is a fault with the other company (ie if I call toshiba, they say it is a problem with the OS, and if i call microsoft they say it is a toshiba driver issue)

    They then proceed to tell me that formatting my hard drive would most likely solve the issue, as if I didnt know that already, and am only calling to avoid having to do that in the first place.....

    I even had to convince the level 2 microsoft guy that I was running Service pack 2, even when he was remotely connected to my computer and could see that it said sp2 under my computer...
  8. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    Somehting else TRULY odd....

    Like I said, when I go to my computer, i cannot see the flash drive. However, If i go to disk management and map it, i can still open it from there. When I check the folders tab in the now opened explorer window, i cannot see the drive still under my computer.

    HOWEVER, if I create a test html page (test.html), open it in internet explorer, and then get rid of the test.html so the url/path is just file:///D:/ (where D is the drive mapping of the flash drive), I CAN see it in the left (folder) pane. It appears that internet explorer acting as windows explorer can see it fine, its just my computer/windows explorer that has problems. Of course, if I unplug it i still need to remap.

    I really am completely stumped on this issue....
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Gremlins? In the system...
  10. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    im beginning to think so...
  11. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    I haven't thoroughly read this thread, but here's some ideas.

    Do you have any network drives mapped? Windows seems to get confused between the two sometimes and I don't think this is just a network drive mapping problem.

    For troubleshooting, disconnect your USB drive and try reassigning Z, Y, X, etc.. to your internal drive partitions, optical drives and network drives to free up lower letters (D, E, G etc..). Reconnect your USB drive and reassign a lower drive letter to it such as E instead. What happens?

    Since drive letter issues are more common than they should be with Windows, it appears others have created drive letter managers. Check this out. Let us know if using a 3rd party tool gives you any positive results.
  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,009

    ack I forgot that one
    ya I had a virtual drive use a usb drive letter
    usb device vanished
    this happened with flash disk drive as well
    usb driver port assignment is scarey
    i wonder if you can make xp see them as a standard drive (not removeable)
    looking at doing testing with my hotswap drives thought I saw something about
  13. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I dont have a network drive, and I did try reassigning my D:/ Drive and E:/ drive to something like R and S. Didnt do anything :S Even if that is my problem though, it should show once I remap the drive letters, and it doesnt. THen there is that odd thing about showing in Internet explorer, but not my computer->windows explorer.
  14. Sphere

    Sphere TS Rookie

    Ok I have the exact same problem and I have tried the above and nothing seems to work.

    It is very annoying because I have tried both USB sticks with the same outcome
  15. N3051M

    N3051M TS Evangelist Posts: 2,094

    Reinstall your USB drivers: Device manager>USB controllers>Remove all under that tree. Reboot your PC with all your devices that use a letter on the My Computer list and let it reinstall the USB controllers. See if that helps.

    Have you tried different ports, or if you're using an external hub, a port directly connected to your motherboard (eg the back ones)?
  16. Sphere

    Sphere TS Rookie

    Nope. No luck, still can’t recognise it still :(
  17. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I have tried all 3 ports, plus a powered hub with no luck. I have also tried removing the controllers and letting it reinstall, but that didnt work either :S

    Sphere: How did you install windows? Clean install? upgrade? Lets see if we can work out some similarities and narrow it down. Is yours a laptop?
  18. Sphere

    Sphere TS Rookie

    Windows was installed with this yes, I used to be able to use them but all of a sudden it won’t pick them up now :(. It is a laptop and I have just done a windows xp repair with no luck still. I have tried all 4 USB slots with the sticks and none are recognised. I am using them though so they aren’t damaged.

    I mean I can see then when I go to my computer>manage>disk management

    This is very annoying because I also can’t do a windows update as well for some reason :(
  19. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    SAME PROBLEM! I have problems with windows update too, and I have a laptop... repair did jack all.

    It seems that it just stopped working after a while. I upgraded from XP home sp1 to pro sp2 though, did you do something similar?

    Anyone have any more suggestions?

  20. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Any chance either of you have attempted to use a 3rd party drive letter manager?

    I'd just be curious if it works or not, although it would technically be a workaround and not a solution.
  21. Sphere

    Sphere TS Rookie

    No i have had sp2 since i got this laptop. This is soooooooo anoying
  22. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    Havent tried it, though Ihave tried using the gmail drive thing. Mybe that screwed it up.
  23. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    How did you upgrade from Home to Pro?

    Running Home then upgrade to Pro.

    Can you just backup that drive
    Then blow it out and install a new copy of Pro.
    Try it this way, if it doesn't work then have the M30 serviced.
    Faulty USB ports on the MOBO...

    Replacement of the MOBO....
  24. Sphere

    Sphere TS Rookie

    That cant be my problem because all my other stuff is working through the usb ports
  25. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Improper current can cause all sorts of nearly unexplainable problems, but I agree - this definitely sounds like a software issue. I've just been casually following this post, but when I get some more time I'm going to search for answers. I like a good mystery. :)

    Don't forget about trying a 3rd party drive letter manager when you get the chance. I'd like to see the results, if there are any worth seeing.

    You know, I was thinking, maybe using diskpart will do something different. You can access diskpart by going to Start > Run > cmd and type diskpart in the cmd shell. It might also help us get some more info about you have been looking at.

    So type in the command to fire up diskpart - you'll be taken to the diskpart command shell. DISKPART>. At the shell, type:

    list volume
    list disk - Copy and paste the results in this thread

    Is your USB drive listed anywhere in there? It should show up under the volume list for sure.

    Using the volume number, issue the command select volume # - '#' should be your USB drive's volume number.

    This should bring your USB volume into focus so any commands you type will apply to that volume only. Now issue the command: assign letter=M - (or whatever letter you'd like)

    I'm just curious if this works and if the changes stick or not, so please try it and let us know what happens.

    You may also poke around a bit. Just type help for the full list of options or [command] help for sub options. If you find anything useful or unexpected, please post it here so we can take a look.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...