Tech Stocking Stuffers: 18 awesome gifts under $50

Solved:IBM Thinkpad Win98 recovery issues

By S&W ยท 5 replies
Jun 3, 2007
Post New Reply
  1. I have a 1999 IBM Thinkpad that originally had Windows 98 on it. I reloaded it with Windows 2000 but did not like it due to how slow it make it run. I'm attempting to go back to Win98 by using my IBM Recovery CD that came with the computer. I know it works, because I used it once before with no problem before I loaded Win2000.

    Problem: When I boot the laptop with the Recovery disk in the CD ROM drive, it will not grab it and start the "recovery" process. Instead, Win2000 would continue to load as normal. I've done the following below trying to fix this and get the CD to start "recovery."

    1. I checked the CD drive, it is working and would run in Windows2000 and also in MS-DOS when selecting files or doing "DIR" commands.

    2. I checked the boot sequence in my BIOS and it is set to CD first, floppy second, and hard drive last. I don't have the ability to disable the hard drive, or any item for that matter. I can only change the sequence or order they are accessed.

    3. I removed Win2000 by reformatting the drive and partitioning it. So now it is a blank FAT32 drive with no OS on it.

    4. I boot the laptop using a Win98 start-up floppy disk and can view the files on the Recovery CD using DIR commands, but when I attempt to run any of them they don't start the process either. The ".exe" commands are the only ones that do anything when I type their name at the E: prompt (CD drive letter), but none of them thus far have started the "recovery" process successfully.

    I don't know DOS well enough to know if I'm not typing a specific command sequence to get it to start "recovering", but I can't figure out why the Recovery CD will not begin as usual in the first place. It's not the CD, because I have a backup which won't work either.

    I also have a Knoppix and Helix boot CD, and they will not start either, they begin to spin-up, but would allow Win2000 to load as usual, or do nothing after I reformatted the drive.

    What can I do? Is there a sequence of DOS commands I can type to have it run every EXE file on the CD until something happens? It appears my Recovery CD and my boot CDs are not starting for some reason, but the CD drive seems perfectly normal/in good working order.

    Help, I have a Thinkpad brick/paper-weight! Thanks!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    HI S&W and welcome to the TS Forum :wave:

    It is a rare thing when a previously bootable device suddently stops working, but it sounds as though that is your problem, I dont know how the file structure on an IBM recovery disk is arranged so its hard to say what you would need to do.

    However being as helpful as I am, try this

    Boot from the Win98 floppy and ensure that you choose to have CD Support

    When booted up (dont a floppy disk take its time) change over to the CD and see if there is a folder called Win98 or one that has lots of files called "CAB" in it.

    If there is try just typing setup from within that folder.

    Its possible that its a PQI file or a ghost file or similar, these are images created by the manufacturer of a complete disk with all drivers installed and when run returns your disk to a workable OS without the need to click through the setup program.

    If this is the case you need to look for the program that recreates the image, like I said PQI and ghost or Arcronis true image are the most popular types, if this is on the disk and you can run the program then its a case of looking around the disk for the image.

    Again this is all guess work but someone may have a better idea, especially if they happen to be in possesion of an IBM RD.

    AS this is your first post can you please take a look at the following guides they will make you stay here more enjoyable.

    Techspot FAQ.

    A message for all newcomers.

    SNGX1275`s A guide to making a good post/thread.

  3. S&W

    S&W TS Rookie Topic Starter

    Some progress, but still no dice

    Hi. All the CDs actually work, and work in my other computer. Below is what I did and results thus far, some progress, but still not good-to-go.

    1. Went to IBM site and downloaded newest BIOS version and loaded to laptop. Returned all settings to factory settings as website suggested. Apparently when I loaded Win2000, it corrupted my BIOS to some degree but it wasn't evident until trying to revert back to Win98. Strange and scary at the same time isn't it?

    2. Also dowloaded the PC Doctor utility and completed complete diagnostic on system, all checked OK.

    3. Loaded the Knoppix CD and wiped the drive and repartioned and formatted to FAT32. All sectors tested good.

    4. Put "Recovery" CD in and reboot, it initialized successfully and seemed to complete the "recovery" process, right down to the last success sign of saying, "your computer has been successfully recovered, please reboot after removing the Recovery CD."

    5. Reboot machine w/ all CDs removed and now I get an "I/O error" that prevents Win98 from completing to load.

    I read on the IBM site that for older laptops that have "recovery" issues with the CD (which I thought I overcame with step 4) that the hard drive may have to be reformatted in FAT16 prior to running the Recovery CD. The note is vague though and seems to apply to hosts that won't start the Recovery process at all, not ones with my "I/O error" after going thru the whole process.

    The default Recovery settings splits the hard drive into two halves, and loads the OS onto one partion, and leaves the other logical partition for personal files/storage. I tried it twice thus far, allowing it to do that, and making it use the single FAT32 partition I create as well (it gives the option). Both give me the same result with the "I/O error" upon reboot after recovery.

    I'm game for trying to format my hard drive to FAT16 to see if this is the final fix for the Recovery process, but don't know how to do this. Does anyone know if FAT16 reformatting is available from the 3.5" floppy Win98 boot disk?

    Any other suggestions I'll do as well, just name them.

    thanks, Andrew
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    To format in Fat 16 get hold of a win95 boot disk.

    I last saw an I/O error when I had a faulty CD, it popped up when I tried to copy it on to my HD.

    Let us know, this thread is interesting and may be of help for others with IBM's

  5. S&W

    S&W TS Rookie Topic Starter

    Finally got this corrected. In addition to the BIOS being corrupted by the Win2000 load which I did years ago (no errors were present that I was aware of until I attempted this reload/recovery) I also found IBM likes to play practical (or unpractical) jokes on clients.

    First, if you run into this problem update your BIOS, and then run a program like PC Doctor to confirm all your stuff is working. Mine was OK. The BIOS corruption showed no signs whatsoever except that it would not allow ANY bootable CD (floppies worked fine) to spin-up. What are the odds eh?

    Next, make sure you read every word of the "Readme" file that pops up when the Recovery CD initially spins-up, and then take it out again to do the below step (at least I did).

    Then, partition the drive as one big active partition and format in FAT32. This may not be necessary with yours, but on mine it worked in the end. However, mental note, your Recovery OEM load may split the hard drive during recovery installation into one FAT16 for the OS and one FAT32 drive for storage. I was not aware that Win98 ran on a FAT16 drive space. Maybe all loads of Win98 don't, but this one does.

    Next, if you ran a previous Recovery but it failed, reboot the box with the Recovery CD in the CD drive and when you see "Win95" press the "F5" key. At the DOS prompt find the directory where the "RESETC" executable is and run it. It resets the Recovery log and makes it start fresh the next time around. Not sure if this caused me problems, but possible I suppose.

    Finally, when you run the Recovery CD for hopefully the last time, make sure you select "Recover using factory installed configuration for the hard drive" (or something like this). If you select "Use existing partition on drive C:" you'll get the stupid I/O error after going thru the entire Recovery process, even though it says it was "successful."

    IBM allows the user to select either choice above, but I don't know why, because if you chose the "Use existing partition" choice, it doesn't load correctly and spits out the I/O Error after you wait an hour for the installation to complete. Isn't that stupid? In the Readme file, it tells you this, so why they'd ever write the Recovery CD to allow the user to select that option is beyond my best guess. No purpose that I can think of.

    That about does it. Thanks for you help. Let me know if I can specify any clearer.

  6. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Hi Andrew

    Thanks for the clear guide that you have posted, I'm sure at sometime sooner or later someone may come across a similar problem, as these pages can be googled it will be of big help.

    Any way glad that you finally got it sorted and that you can now use your laptop, hats off to you for your perserverance...


Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...