Solved: Pressing key disconnects USB Lenovo 3000 N100 0689GRA

Not open for further replies.
Hi there,
Can anyone help me? I'm quite desperate here.
I'm having problem with my keyboard/USB.
When I press any key on the keyboard, that instant all USB devices are disconnected. And soon after I unpress it, the system will detect all USB devices like they were just plugged in. I say all USB devices, cause it doesn't matter USB mouse or USB drive, they all get disconnected.
It's frustrating me cause I can't use a USB mouse.
Please help :(

I'm using a Lenovo 3000 N100 0689GRA.


Posts: 316   +1
How many USB ports does that have? and what are connecting them. If you could also please look in your event viewer (Start>control panel>administrative tools>eventviewer, and check the "SYSTEM" area. double click any item in that list for a detailed description. You should see some errors.
  • Thread Starter Thread Starter
  • #3
My laptop has 4 usb ports. They use direct connection to the usb port (not using a usb hub). The usb ports connected through the Intel 82081G (ICH7 Family) USB universal host controllers. I even tried to turn off the "Allow the computer to turn off this device to save power" option in the power management of the USB root hub.
Tried to check the event viewer as you said, but nothing there. weird. I cleared all the logs and tried the whole thing over again, but still nothing in the event viewer.
I even tried to do windows update, and system update from Lenovo. all done, but no luck. the problem is still there.
Am I the only one that ever experience this? :(
It has nothing to do with power options ! I was also driven mad by that observation. The surprise, I know its shocking, but it has something to do with the BIOS. The BIOS is faulty :S
For me to overcome this problem, I had to go the lenovo website download the latest BIOS for Lenovo N100 3000. (v3.01)
Then you upgrade your BIOS using the image file in the Realtek folder (you will probably figure that out)
Flash the BIOS, and have fun :)
No more USB problems (damn ! I will sue lenovo for the **** they did. I already lost my data on a usb drive).
The problem you might face then laterwards is with sound. This would be easy, go to the realtek website, and get the latest sound codecs for High Definition audio. Install that and u will be fine ;)

Tell me about how it went :D

  • Thread Starter Thread Starter
  • #5
hi zimo,
I'm glad I'm not the only one who suffer :)
I was thinking to updgrade the bios to v3.01 (i'm currently using 3.00), but after I download the .exe (63af04.exe or something like that), use WinPhlash and use the bios file from the realtek folder.
Weird thing is when it tries to flash the bios, suddenly there's a blue memory dump screen, then my laptop restarts. checked the bios version, it's still 3.00.

Someone suggest to use Phlash16 in DOS environment instead of WinPhlash in windows. But I don't know if this is safe. Maybe someone who had experience with this can help me? :( or maybe you can help me with this zimo? :)

thanks for your reply zimo. I can't wait to flash the bios until I know that it is safe using Phlash16 :)

zimo, bad news :(
I can't seem to update the bios using Phlash16. it said that the rom is not for my system or something like that.
So then I try to use older bios which works fine with winphlash, but got the same error with phlash16.
I think the rom files don't work with Phlash16, and i'm still stuck :(
I am sorry, I forgot to tell you about that problem too :(
The solution is simple (although I know you might freak out) and its not that long.
The idea is that you will have to flash your BIOS with the C200 check the file 63af02us (I know its wierd but don't freak out - trust me, the only error you will get is invalid model ID or something like that at the startup screen no harm at all (just to make sure that everything goes fine the BIOS is compatible and it will pass the check by the flash tool). When you get to windows, you might experience a change of resolution).

Now when you get to windows, just forget about all drivers that windows is trying to find and all the mess which is there, then simply flash your BIOS with the correct file (the one that you failed to flash).

Once again, trust me I know its wierd but its the only way.

Tell me about how it went !



I just forgot to tell you this. use Winphlash :)
  • Thread Starter Thread Starter
  • #7
heya zimo! man, u totally rock!
my system is now NORMAL.. hooray! :D
Now I don't have to send it back and just enjoy my laptop.
The bios upgrade fix another thing too. Previously the audio had problem with earphones (whenever I want to use earphones, i need to plug it and restart). But not anymore...plug it in, bam! direct audio to my earphones :)
Now I don't have to buy another usb keyboard/bluetooth mouse.

Thanks my man! You're a real help :D
Don't mention it ;)


I am so glad that you solved your problem ;)

Best regards zimo.

Mohamed Abdulazim Aly

German University in Cairo

Department of Computer Science and Engineering

Hi Zimo,
i have seen you help and I have the same problem.
My pc is a lenovo 3000 N100 0768 FFG with vista.
My problem was caused by a wrong installation of the bios files. I have installed the ADI version DL00204A.WPH instead of the Realteck version: DL01107A.WPH
Now the audio works only in play and not in record, i have the same keyboard/mouse conflict and i see often some system crash.
I have tryed to flash the bios again but the system crash witha blue screen memory dump.
I have tryed to use a ERD commander live cd to have an XP OS but the flash still crash also from XP.
I have tryed with an older version of bios but it still crash!
Lenovo assistance doesn't reply to me...
Can you help me?
many thanks
  • Thread Starter Thread Starter
  • #10
hi marco,

Have u tried downloading the new BIOS from lenovo's website?
Recently when I visit, they already have 2 new BIOS upgrades since 3.01.
I dowloaded the latest recently, and update it with no problem (after zimo's fix).

When u said old bios, was it the 63af02us for C200 like zimo had mentioned?
Because I think I did the same thing like u did (update with ADI, not realtek), and the C200 BIOS works fine just like zimo said.

Btw, I tried contacting Lenovo too, but no reply until now, sadly :dead:
Hey Zimo!

I wanted to follow your method, but I am now stacked with BIOS 63ET14WW v1.02 saying
0232: Extended RAM Failed at Offset 1E
0232: Extended RAM Failed at Offset 20
Press [F1] for SETUP, Press [F12] for boot device selection menu

[F12] does not work
[F1] gets me to SETUP, but saying

Installed memory 66560 MB! :(

I have 1GB or RAM installed...



BIOS problem with N100

Hi there!
I took the advices read this forum and I think it is important to write down my event.
I installed the bios for c200 as it wrote near the update on lenovo site, and my machine said it was successful but it never starts again. I took it to the ibm service (my notebook is 2 days old...) and they have to change motherboard in it becouse of this update!

I want to pique your attention that the bios update is not as easy update as I thought and many of us think. It is a fortune that ibm change it in garantee, becouse it is available and accessible for everyone. Unfortunately. It shouldn't be I think.
I think who has the same mouse-usb-keybouard problem, take trouble to take his or her notebook to the nearest ibm service. They are very kind and helpful.

Thanks for the attention.
Hi Dorothea,

My scenario was exactly the same. I visited the nearest IBM service where they have replaced the motherboard under warranty. IMHO IBM is very much aware of this issue ant they feel guilty that the C200 BIOS update does not warn you and prohibits itself from being installed onto a N100! I think that would have been the "normal method" but the programmers at IBM made a stupid - but very expensive - mistake. Luckily it is not us who have to pay its bill... :)

Best regards,


Dear Wizz_Away,

Yes I thisnk exactly the same. They were very kind becouse that missing of the warning.
I was very frightened, but after I talked them I calmed and, yes it will be free for me...Tomorrow I'll take my machine from the service:)

Best regards,

I also flashed with the wrong BIOS

I also flashed my laptop 3000 N100 (0768-BTG) with the wrong BIOS, due to, in my opinion, misleading BIOS information in Lenovo site. For some unknown reason their system suggests which version to install by the pre-installed OS, either Windows XP or Vista, instead of pre-installed hardware. My computer came without pre-installed Windows, so I manually installed Windows XP and therefore decided for the BIOS that Lenovo suggest for Windows XP systems. That was my mistake because instead of chosing BIOS for PC with Realtek audio I chose the second one (3.12). The results of this unfortunate update was the same as described earlier in this thread which means: stopping (and restarting in a moment) connected USB devices after any key was pressed on the keyboard and improper headphone audio jack detection. When I figured out that BIOS was the problem I tried to come back to version 3.11 but BIOS programming failed - blue screen was displayed and BIOS remained unchanged. Then I retried the procedure with other, older BIOS versions from Lenovo site until I was successful with 2.02 (61af11us). The weirdest thing was that changing to this BIOS didn't solve the problem at all, so then I changed the BIOS to 3.00 (63af03us). After reboot system started with DISPLAY OFF, therefore there was no other option but to force system off by pressing and holding POWER button. Second reboot was OK, display was working properly, however with low resolution and PROBLEMS WERE GONE at this stage. The one thing left was flashing to new proper BIOS for computers with Realtek audio and this time the operation ran smoothly and me and my laptop are living happily ever after. :)
Not working

My lenovo make me crazy... the usb are underpowered when i click any key of keyboard, i make all atualizations, bios etc... but the problem not solved!!!! I observed the problem starts when computer start before bios check the problem appears, when i make upgrade in the bios (winslash) the problem stop (i see the light of the usb mouse during process) but when the bios are upgrade finish the problem back..... please help me!!!! excuse-me for my bad english, my native language is portuguese (Brazil)


For All Useres That Receive Black Screeen After Reboot

I have USB problem with my lenovo n100 768 FSG. When I flash bios with C200 63af02us.exe all went OK but after computer reboot I receive black screen and nothing else.

If someone experience same problem, you don't need to send your laptop to lenovo for repair.

Here is what you should do:
Turn off laptop
Hold F11
Turn On laptop (holding F11)
You will receive lenovo boot screen and you can now start Windows and apply BIOS update from Realtek folder.

Yes I solve it.

My problem was when I flash BIOS (63af02us) and after flash finished my laptop restarts but I receive only black screen. It didn't boot in Windows and I cannot go in BIOS or do anything else. Just black screen.

Starting my laptop by pressing F11 I manage to receive Startup Interrupt Menu screen and I press there ESC to resume normal startup.

Then my Windows XP start normally and I receive lots of new drivers for C200. After update for all drivers update end I receive Restart Windows
now screen and I select I don't want to restart windows now.

After that I just run 63af08us.exe and go to Installed folder (C:\Drivers\Win\FLASH\63af08us). Run WinPhlash.exe, select BIOS file from Realtek folder (DL01108A.WPH) and BIOS is updated without any issue.

USB is now working perfectly!
Usb Problem

Zicko what's your computer? is a 3000 N100? When i install the BIOS file from Realtek folder (DL01108A.WPH) using WinPhlash.exe the system crash (Blue Screen), arrgggg, this computer make me crazy.
Maybe this article will help you, here

You can download 63af02us here

It's on your risk to Flash Bios with that version. I cannot guarantee 100% that this will work. It worked for me and for many other people.

P.S. Yes, I have 3000 N100 Lenovo laptop.

ALELUIA!!!!!! IT'S WORKS, Tks Zicko, I solve it. I flash BIOS (63af02us) and after flash finished my laptop restarts in black screen, and I resart the computer again and flash the bios with 63af08us.exe Realtek folder (DL01108A.WPH)

USB is now working perfectly!

Many Tank,s
Lenovo 3000 c200 BIOS update failure

I have a Lenovo 3000 C200 (8922-5ng) with Windows XP home as the operating system.

I have problems with a USB mouse which stops functioning when typing and this is supposed to be fixed when updating to the 3.12 BIOS version.

That's what I tried to do.
My version is, when looking at the system info screen before getting windows: 61ET37WW v2.06

The version I tried to install from the Lenovo site is:
63af08US 3.12

When I install it as the instructions tell ho to do so,and check the box "Flash only if BIOS version is newer than system", the installation procedure is not finished and the I get the following message:
The current system BIOS is the same version (or newer) than the version you are trying to flash, so the BIOS will not be changed.

When I don't check that box, I get the infamous blue screen with the message:
STOP 0x0000007F (0x00000008, 0x80042000, 0x00000000, 0x00000000)

In both cases the BIOS version remains unchanged and the problem with the USB mouse still exists.

Can anyone help?
USB error

S-F although my notebook to be n100 the problem must the same be, also the error of the blue screen also happened, makes the flash of the bios with the version older than it is in the Lenovo site, later you makes the update with the new version (63af08US 3.12), when you to make the update with the version oldest the problem go to be solved.
If in the restart the black screen appears, restarting the laptop by pressing F11 I manage to receive Startup Interrupt Menu screen and I press there ESC to resume normal startup.

Then when you Windows XP start normally you receive lots of new drivers for C20. After update for all drivers update end I receive Restart Windows

Intal the correct new bios for you computer and….

USB is now working perfectly!
Not open for further replies.