Sony RS420 Computer shutdowns sporadically...

By jcpcac ยท 6 replies
Dec 20, 2004
  1. For the past 2 months, my RS420 desktop is shutting down on its own. Throughout the course of the last 2 months, a simple toggling of the power button would bring the unit back up again. Now it is to the point, when hitting the power button, nothing happens, until I unplug the pwer cord and plug it back it again. Then I hit the power button, the unit will start to cycle without a good "reboot"... hence no video (I can just hear the power supply and I see the LED on the mother board lit) and the system does not come up. Eventually, after so many tries (performing the same sequence with unplugging and etc), the computer does reboot.

    So, it is the switch? or power supply? or motherboard? The warranty has run out of course..

    Thanks for your help....

  2. mbe0428

    mbe0428 TS Rookie

    Sony RS420 shutdown

    I was curious if you ever solved your problem. I have the same computer and am currently experiencing the same issue. When I lose the video, I have taken the back off the system and reset the Radeon video card and that seems to work for awhile. I suspect power supply but am having difficulty finding the right power supply. Apparently Sony has a proprietary supply which runs > $125.
    If you've determined what the problem is, I would appreciate any feedback.

  3. zephead

    zephead TechSpot Paladin Posts: 1,569

    there is a design flaw in your computers. this is how sony's computer division makes it's money: by creating problems only they can fix.


    I think this sounds like a powersupply problem or Sony's scecret scam!
  5. mbe0428

    mbe0428 TS Rookie

    As an FYI, I called the tech support line at Sony and went into the setup screen at startup and set the BIOS to setup default and that appears to have solved the problem. My system has been up and running with no shutdowns for over week. The system was previously shutting down several times a day.F2 at the Sony screen, go to Bios setup utility and get to the Load Setup default. Good luck.
  6. zephead

    zephead TechSpot Paladin Posts: 1,569

    did they try charging you for the call?
  7. joecolon

    joecolon TS Rookie

    i had the same problem same computer .bad 4 pin connector in the power supply .solve the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...