Sony Vaio VGN-FS Major Problem (I think)

By devlon ยท 10 replies
Jul 4, 2007
  1. Hey everyone,
    I think I've done something to my laptop that is causing it to almost crash.

    About a week ago, several of the keys on my keyboard popped off and I wasn't able to get them back on. So, I ordered a replacement keyboard and it came yesterday. I followed an online guide to replace it by first removing the plastic strip above the top of the laptop, then unscrewing four connecting screws, and finally sliding out the keyboard's ribbon from a clamp. I replaced the new keyboard and reattached. Things worked fine.

    Today, I installed a new CD-RW/DVD drive. I think this is where the problems started. I unscrewed the entire back of the unit, including the RAM door and what I gather was the HD. Once all removed, I removed the old cd drive and installed the new one. The HD has four screws connecting it to the base, and has a pin-attachment.

    After all this was done, I restarted and a couple of things happened. First I got an error message before windows even loaded saying "lsass.exe error .. unable to open" .. then the computer restarted.

    windows loaded successfully this time, but I have a new hardward wizard requesting permission to install ACPI Uniprocessor PC. It says it doesn't pass windows logo testing. What is this all about? Did I reconnect the HD improperly? Does anyone know what the lsass.exe error is all about? Oh, between rebooting and successfully starting, I received another error saying my virtual memory was low and the computer just stalled with the caps lock, num lock, and scroll lock lights all lit. I had to just remove the battery and restart.

    Any ideas what is going on???
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Make sure the Hard Drive is assembled in is holder correctly and is secure... A loose hard drive connection may have corrupted the hard drives data
  3. dontbesorry80

    dontbesorry80 TS Rookie

    Same problem

    My vaio laptop is having the exact same issue. Did you find a solution?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    It might be best to take the laptop to a repair shop to have it looked at
  5. johnhenry

    johnhenry TS Rookie Posts: 69

    Sounds like you should doublecheck all of the components you installed and uninstalled. Make sure everything fits right, then try starting again. If you get the same error then you'll know it's either A) related to the new CD drive, or B) a problem caused by your installation process, i.e. damage to HD or other.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Vaio's seem to be more prone to failures in general than with other laptops. It might be that static has damaged the motherboard, more than an error in installing a hard drive itself
  7. dontbesorry80

    dontbesorry80 TS Rookie

    Thanks for your responses, unfortunatley although I am receiving this error, I didn't actually change any of the hardware, I don't know if something has come 'loose' but I have tested the RAM using MEMTest and that is fine. So I could try a reinstall failing that I am stumped.
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "My vaio laptop is having the exact same issue. Did you find a solution?"...

    So this isn't the exact same issue afterall? You haven't changed anything, but devlon did do something to his. What exactly is your Vaio's problem? Be as specific as you can
  9. shayes15

    shayes15 TS Rookie

    FS-810W no BIOS display

    I am seeing similar issue with Sony Vaio FS-810W that appears not to boot into BIOS and display results, power lights come on, HDD spins up, but no video on LCD or external VGA port, and Num Lock, Caps Lock, Scroll lock all 3 stay lit. Have tried the usual: disconnect CD ROM, Disconnect HDD, Remove mem, clean Mem sockets w/ alcohol and compr air, replace mem stick with new Crucial mem, have not yet tried disconnect other sub boards from MoBo; MiniPCI board, etc. Tried holding down power button 30 sec's, power with and without battery, looks like MoBo is getting DC power and battery will accept a charge when installed. Will ask if they are seeing many FS-800 series Video or BIOS MoBO failures
  10. lamo

    lamo TS Rookie

    BIOS in these models dies VERY rarely. most common problems are: dead of videochip, dead of southbridge(82801fbm), or(very rarely) broken soldering under northbridge(in models with i915GM chip).
  11. shayes15

    shayes15 TS Rookie

    Thanks, I will disassemble, and try some techniques like cooling the chips mentioned and pressing lightly to see if contacts and solder joins need touch-up
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...