Sound trouble with ALC850 in games

Not open for further replies.


Posts: 12   +0
I have some problems with sound in games. It simply vanishes after a brief period, say 3-15 min, sometimes coming back for brief moments.

Not being completely inexperienced, I have upgraded all my drivers and flashed all bioses. I've also browsed forums across the net searching for a solution, sent realtek an e-mail requesting ETA on new drivers (no response yet) and now I've found this forum.

I have tried drivers from ASUS' page and Realtek's, both exactly the same, as far as I can determine.

System specs? Check me out... all there.

Im also posting my DxDiag, just in case.

Personally, I believe I'm doomed to await new sound drivers. Please chear me up.

EDIT: Are no one replying due to specs missing or just no answers? To remove one possibility:

ASUS P4P800-E Deluxe (ICH5R, 865PE, ALC850, GbLAN, IEEE1294, USB 2.0)
P4P 3.0 at 800 (prescott)
Corsair Twins 512Mb (total of 1024)
Saphire Radeon 9600 Pro
WeDigCaviar S-ATA 120Gb on S-ATA 1 (numbered 1 and 2, not 0 strangely)
Plextor CD-RW master on IDE 0
JLMS DVD master on IDE 1
1 run of the mill FDD
PSU at 350W
Case cool due to open. Fans will be mounted ASAP, but note: No overheating at current, with case open.


  • dxdiag.txt
    44.9 KB · Views: 10


Posts: 12   +0
Fans mounted... no change... Since no one seems to have any thoughts on the subject, I'll take drastic measures and order a new card, probably an Hercules.

A friend of mine reports the same trouble with an earlier 5.1 ed on an ABIT MB. Seems I'll just say this: DON'T *EVER* get a realtek! They won't even deign to answer my mail (and it was written in a rather friendly way, too.)
also have troubles with realtek

dear Janan, you're not the only one...

I actually possess a p4p800 with an alc850 and I got troubles with sound !!!

I did not try yet games, but any time I try to uses Winamp, WMP, realplayer of flash... after several minutes (from less than one to more than 30...depending..on what?) the sounds stops and so the video....

unfortunately I had no answer but maybe someone will have.... even if I think this is probably an hardware problem with the chipset.... but sending back the mothercard???? pfuu it will take time...

anyway if you have any news I'll be glad to hear them !!

see U
I have exactly the same problem

Hay, I have exactly the same problem and startlinghly similar system specs as Janan. In games or winamp (or any application using audio) I lose sound after 5-30 min; sometimes it comes back briefly and then leaves for good. The strange thing is that rarely (maby 1 in 50 boots) the problem does not happen at all.
Before I forget, Here are my system specs:

Asus P4P800E-Delux
P4 2.8Ghz HT-enabled 1mb cache
Corsair value select dual-channel 400Mhz dimms (1024 total)
1 AGP NVIDIA eGeForce FX5900XT
1 PCI Radeon 9200SE
2 WD 200GB Hard Drives (1 Special Edition, 1 Caviar SE)
1 Plextor DVD/CD Burner
1 Artech CD/DVD reader
1 Sony FDD
Plenty of Power and Plenty Cool

This may help- The very first time I set up the machine I did not have this problem at all. But to fix other issues (unrelated- due mostly to my stupidity) I re-arranged the hardware configuration several times. Then this problem started- I re-installed the OS and Apps with the Hardware Configuration I wanted and the problem persisted (Uh-Oh). So I'm thinking that there may be a conflict between some onboard devices on the P4P800E-Delux.

From Janan's post it appears we are both using the onboard raid controller. I was not using it on first setup. Also, we both have 2 ATAPI devices- I only had one installed on first setup. It may also be benificial to list how my periferals are connected (let me know of anything in common):

Primary IDE Channel:
Master: WD 200GB Caviar SE HD
Slave: Artech CD/DVD Reader
Secondary IDE Channel:
Master: Plextor CD/DVD burner
Slave: Empty
Onboard Promise IDE Controller (IDE Mode):
Master: WD 200GB HD (Special Edition)
Slave: Empty

RSVP- I'll monitor this thread for a while. I'll keep you all posted of any developments/resolutions. Please do the same for me.
~Bryan (Croco44)
Don't know if anyone is still wondering, but I'v got everything working now.
I think this problem comes from certain IDE setups.
The configurations that did not work for me used 80-wire IDE ribbons for the the primary channel and the promise raid controller, and a 40-wire IDE ribbon for the secondary channel (on my machine this just had the CD/DVD writer). Recall, I had my peripherals connected as follows:

Primary IDE Channel:
Master: WD 200GB Caviar SE HD
Slave: Artech CD/DVD Reader
Secondary IDE Channel:
Master: Plextor CD/DVD burner
Slave: Empty
Onboard Promise IDE Controller (IDE Mode):
Master: WD 200GB HD (Special Edition)
Slave: Empty

I had, in accordance with the plextor manual, configured my CD/DVD writer jumper settings for UDMA (default) as Master
and placed it on its own IDE Channel on the end of a 40-wire ribbon. I'm sure that this is what's recommended as there are clear pictures of my exact setup with this configuration in the Plextor manual.

Anyhow, I did some research and found one website saying that if you use a 40-wire ribbon for your cd-rom and it is alone on the channel, you should put the device on the end (which I had) and configure it's jumpers for SLAVE. This is a direct contradiction with my Plextor manual, but since nothing was working anyways I figured "What the hay".
Believe it or not, it worked- My motherboard recognized it as a slave (Even though it's alone on the channel) and windows recognized everything happily. But most of all, the problem with the audio mysteriously cutting out went away.

Once the machine was running well and I did some more "testing" (I mean of cource gaming), I decided to play with the hardware configuration some more. The whole problem aparently stemmed from a mis-configured/mis-recognized setup with a 40-wire ribbon- so I thought maby if I used all 80-wire ribbons I could avoid this complication and enjoy the speed of having my CD/DVD writer set up as a master. Result: Everything works beutifully and is fast, and the audio does not cut out anymore.

So in conclusion, I offer this advice to anyone experiencing the same problem I was:
Replace any 40-wire IDE ribbons used in your system with 80-wire ribbons and configure all devices in accordance with manuels.
IE: If the device is alone on a ribbon- configure it as Master and put it on the end.
If two devices share a ribbon, jumper one for master and put in on the end and jumper the other for slave and put it in the middle.
This should resolve the issue- it did for me. Good Luck!
Just a follow-up. I've been running well now for a few days and am convinced the issue is resolved. But I have noticed one recureence of the problem. I had the audio cut out again when my system overheated from lack of circulation. Under load my MB runs near 86 degrees F; When my MainBoard hit 116 F I had the recurrence of the problem. I re-arranged the fans and put the comp in a better location (not boxed in as much) and the problem has not recurred.
Another victim of the ALC850 disease

Hi Croco (sorry to call you that but it's the only name I know you by...;-)

I found your post on thru Google when I was desperately searching for solutions regarding my (yeah, you guessed...) Asus P4P800E-DeLuxe, onboard RealTek ALC850, Plextor 712 DVD burner, etcetera. Wow, nice to know I'm not the only one!

First of all, I want to compliment you on posting this helpful information for all to see. This is what cybercommunity is all about!

My question is, does your solution still work? Because if it does, I'm gonna buy myself an 80 wire IDE cable first thing and enjoy my just-bought Labtec 5.1 speaker setup without the sound quitting on me every few minutes or so.

Hope to hear from you... and I'll keep everyone on this forum informed of progress!


Posts: 6   +0
New driver =solution?


I have an Asus P4P800-E Deluxe with ALC850 (and an ATI 9800SE) and had the problem with sound stopping in games, but not otherwise.
I read the thread here and I helpt me not to go crazy….
Anyway, I went to Realtek’s homepage and downloaded the new driver V. 3,64 last night.
I ‘tested’ it with some Call of duty for 40 min. and everything worked.
Maybe Realtek solved the problem?

Besides this I think the mb I great, especially the Q-fan function.

/Per, Sweden
Asus P4P800-E Deluxe
Northwood 2,8
9800SE softmodded 9800Pro


Posts: 6   +0
Update: still problems but better

Update to my post: I have been running the 3,64 driver for a while now and the problem is less frequent but it still happens occasionally. I'm getting tired of Realtek and Asus, the P4P800 is one of the most sold MB's I think, can't the get it fixed?

/Per, Sweden
Asus P4P800-E Deluxe
Northwood 2,8
9800SE softmodded 9800Pro
ASUS P4P800E-DeLuxe ALC850 problems continue

Hi all,

Per, I have just seen your last post.

I have last week downloaded driver version 3.65 from Realtek. Installed it, still no luck. I have now tried almost every version imaginable and the problem still persists. I am not a gamer, but playing sound and viewing movies under M$ Media Player also shows this problem. The same trouble with the Realtek soundcenter application. Everything works fine for 30 secs up to a few minutes and then the sound cuts out.

Croco has posted his research on this thread also, and he has recently informed me that he has thrown in the towel. He has disabled the onboard sound and put in a soundblaster audigy card instead: no problem since. However, I positively *hate* to buy a card with builtin features and then having to disable them because I cannot get them to work. Makes me feel like a loser...

Anyway, up till now I always had good experiences with ASUS. OK, their boards were never cheap, but they delivered superior quality. Something like "you get what you par for" in the positive sense.

However, after having bought this P4P800E-deluxe, I feel bitterly disappointed. ASUS seem to have surrendered to the "quick and dirty -- time to market is king -- let the customer sort it out" kind of behaviour that is getting all too well known these days.

I think I will wait a little bit longer to see if a solution from ASUS is forthcoming: multimedia is not my primary concern, but speed is (I use the system for CAD applications) and in this respect the system certainly delivers. Afer all, the P4P800E-Deluxe is sold by the thousands, so more and more people will experience these soundsystem quirks.

But, deep in my heart I have this uneasy feeling that ASUS have mucked up hardwarewise in the design, with an unstable sound subsystem (and what else?) as a result. They will probably (hopefully?) address this flaw in the next hardware revision: nice for future buyers but no use at all for existing victims like me. In that case the P4P800E-Deluxe will certainly be the last ASUS board I have ever bought (and recommended!), and I will take my future business elsewhere. (I heard that ABIT manufactures nice mobo's too...:)

Kind regards,



Posts: 6   +0
still working the problem...

Hi all

I know I should give up now, and buy a PCI-card. Partly because the sound quality isn’t that great either from the realtek, it doesn’t do my Logitech z5300 system justice.
But two things makes me continue:
1. I’m stubborn as a mule.
2. 2. The problem might be the symptom of some other problem, so putting in a pci-card might just HIDE the problem instead of curing it…

I started to wonder about why not everybody has this problem.
One thing I did when setting up the comp. was connecting the cable from my case ( front audio outlet.) To do this you remove 2 caps on the connector on the Mb.
Could this make the relatek chip go crazy?
I have an Aopen H600B case.
How many of you has some sort of front audio cable connected?

Because many with the problem has an ATI graphics card I loaded the latest driver for that (4,11) I’m waiting to see if there are any changes.

/Per, Sweden
Asus P4P800-E Deluxe
Northwood 2,8
Kingston RAM
9800SE softmodded 9800Pro
AOpen H600B case


Posts: 6   +0
silly me

Hi again

This is embarrasing to seems that I forgot rule number 1A in hardware fixing: Check the heat!
I read in some post by others here that they ruled out heat, so I did too.

But when tweaking I happend to run with the case open- and guess what- the problem dident happen.
So it's heat that is killing the sound, at least in my machine.
Question is what is overheating, the realtek chip or something else like the northbridge, southb or what?
At least I'm glad that I dident just put in a soundblaster, then I wouldn't have known that my system is overheating, at least in some parts!
My temps are Mb 36, cpu 38 at idle, and 39/49 at full load, not so bad.
Guess that's its the graphicscard that is warmning the realtek chip, those radeons are like radiators!

My next move is to try putting a heatsink on that tiny chip, since I dont want more fans.

I read somewere that a guy replaced paste on the northbridge of his p4p800 with arctic silver and the temp went down 10 degrees! Hmm...?

/Per, Sweden
Asus P4P800-E Deluxe
Northwood 2,8, stock cooler
Kingston RAM
9800SE softmodded 9800Pro
AOpen H600B case, 1 case fan


Posts: 6   +0
Too hot to handle

Hi again

Ok, I tested to put a heatsink on that tiny chip and tested it for a while. Worked perfectly. Then the heatsink fell of but thats another story...
So the problem with MY machine was heat, (although the chip dident seem that warm when touched.)
I realised that my whole system is too hot and I'm going to install some more fans.
I still wanted some better audio so I got hold of a old soundblaster live and installed that, and it really improved the midrange. So the ALC850 isen't anything to hold on to anyways I guess, but I'm glad I realized my system ran too hot. Probably it's so hot because the Radeon, maybe they should be called Radiator 9800 insted....hehe sorry for the bad joke)

/Per, Sweden
Asus P4P800-E Deluxe
Northwood 2,8, stock cooler
Kingston RAM
9800SE softmodded 9800Pro
AOpen H600B case, 1 case fan (soon to be 2 case fans...)


Posts: 12   +0
I thought: Bugger all. Got myself a nice Terratec Sky and canceled the problem. Also the new card has superior sound compared to the ALC850. Worth every buck. The ALC now serves as my headset card for teamspeak and such like, which works without a hitch.
Update Drivers for the Realtek sound card

Hi guys,
I have a Asus P4C800 Deluxe Mainboard and had exactly the same problems, which are discussed here (sound goes after 5 Minute playing and never coming back and so). I also have a ATI Readon Graphic card which was also mentioned here maybe to have an impact on that problem .

I updated my grafic drivers to Realtek AC97 Audio Driver A3.77 and now the problems are gone.

Thanks guys, especially croco44. Mine wasn't working at all, changing the connector cable for my 2 DVDplayers from a 40 to 80 connector (I use SATA hdd) fixed my problems (on an ASUS A8nSLI Premium board with ALC850)

I have no problem with my soundcard (ALC850) at all. Im using a spdif connection and it never cuts out and the sound quality is exelent, so are the analog outputs. My thoughts are it must be the ASUS motherboards, they are a cheap company. Im using a Gigabyte GA-8IPE1000-G motherboard with built in ALC850 soundcard.

Gigabyte GA-8IPE1000-G Motherboard
Intel Pentium 4 3.0E 800MHz FSB Socket 478 Processor
512MB DDR Kingston Ram
nVIDIA GeForce FX5600 DDR 128MB VRAM
Sony FDD Drive
iCute A04BH Case
400W Power Supply
I empathize with all of you for sharing this same repeated issue. I've swapped out that 40 pin cable - no change. I avoided the audio downloads from the ASUS site and went directly to the realtek site @

and downloaded the AC 97 drivers despite the act the readme file did not list the ALC 850. That install helped significantly. It was version 3.92 as i recall. I then uninstalled the ASUS Probe software as it was incorrectly reporting the Power SUppy voltage at whereas the BIOS reported 12.16 - seems strange for such a wide variance. That ASUS probe would appear whenever the voltage would exceed the +10% voltage threshold - upon its popup a sound would also occur. I have suspicion this and along with bad drivers was causing the issue. The problem is significantly better about 90% however Itunes while playing continuously still has a few sporatic dropout. I may try changing the IRQ from 17 to something else. I put a tech request in to ASUS as I just received this replacement motherboard which has succeeded a P4C800 Deluxe with whose RAID controller went bad - that's another story in itself. utlimately I'll wind up getting a USB Creative Labs sound card and disable this inadequate sound device.

System is running a 500Watt Allied Power Supply
HP DVD burner
Liteon DVD burner 16x
MSI 52x32x52 CD burner
2.4 P4 w/ 512k
ATI AGP 9500
512 x 2 dual channel ram Kingston
2x 250 gig SATA drives w/ 16 MB Cache on RAID SATA controller
1x 80 gig Maxtor spare drive
Floppy is disabled
1 Case fan / CPU Fan
all 80 pin cables

Thanks to all for contributing to this post.
Not open for further replies.