Soyo Dragon+ won't post

By drgrafix ยท 7 replies
Apr 30, 2005
  1. Hi... Newbie here, looking for some help. This board has been running like a clock since I bought it new a few years ago. I've decided to purge and install a new 120 G HDD as a slave to the 45 Gig master and another 45 Gig slave. So I started cleaning the years of dust with a vacumn fitted with a PC nozzle/soft brush... everything seemed to be going great. Booted a couple of times OK, and then I booted again... and I get no video post on the screen. I hear the board beep, and it sounds like the drives are winding up, but no display.

    I removed all wiring and started with just the video card, mouse, and keyboard. Still nothing when I boot but the sounds are there. It's almost like the system is hung in the boot/diagnostic. I can't get into the bios, or if I did punch DEL, I would not be able to see anything. The video card is a ATI Radeon 8500 DV, the CPU is an AMD 1800 XP, and the memory is a single 500 Meg stick.

    I'm stumped, and there's no trouble-shooting section in Soyo's unser manual. Anyone have some ideas on what I can try?

  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    soyo makes a questionable product, i'd suspect the board went bad on you.
  3. drgrafix

    drgrafix TS Rookie Topic Starter


    If the board had acted flaky a couple of hours ago, or even over the past few weeks/months... I might agree. But simply to die because I added a new HDD? Seems weird.

    I've stripped the board to the bare essentials. Only the video card, the mouse, the keyboard. I did the CMOS jumper reset, and also pulled both the memory and the video card and re-seated both.

    Now, instead of a single beep, I'm getting a continuous beep and an automatic shutdown. Still looking for possible problems, so if you think of anything, I'm willing to try it. I will also try looking on Soyo's web site for a FAQ on troubleshooting beeps.

    If I have to rebuild with another mobo, what would you guys recommend (without breaking the bank)? I need to have a board that pretty much mimics the Soyo with regard to IDE Raid as I have the following IDE devices:

    Root Drive 45 Gig eIDE/ATA 100
    Slave 1 45 Gig eIDE/ATA 100
    Slave 2 120 Gig eIDE/ATA 100
    Zip IDE Drive
    NEC DVD Burner
    NEC CD Drive

    I would like to use the 512M CL2 2400 Memory, plus my AGP card, and since I do a lot of graphic work, I run a second video card (Matrox) and a second monitor (One 21" Sony & One 20" Hitachi). I hear that MSI makes decent boards that might be a good fit?

    Thanks in advance for any/all help.

  4. zephead

    zephead TechSpot Paladin Posts: 1,569

    msi makes a better product than soyo, that's for sure. the gigabyte ga-7n400 pro is a board high in quality and can be cheaply acquired, plus it'd work with all of your existing parts.
  5. drgrafix

    drgrafix TS Rookie Topic Starter

    Well, I did try another PS with the board and get the same result, so I know it's not the PS. I keep thinking its the memory or video card, but I tried two video cards one PCI and one AGP and I still can't get a post. Dies after about 5 seconds. The board LED stays lit though.

  6. mdkoh

    mdkoh TS Rookie

    You Possibly Answered Your Question

    If you vaccumed your M/B you might be a victim of ESD. No matter how cautious you might be Electro Static Discharge is always a problem. I bet you shocked your board. I have built many systems with SOYO boards. I have never had a problem with them. Everyones opinion will vary about specific manufactures, except maybe ECS. You may have inadvertantly toasted your board while vaccuming out the dust. I usually reccommend to vaccume out the case, do not vaccume the board itself. I use an air hose to gently blow the dust from the M/B. Hope this helps out.
  7. drgrafix

    drgrafix TS Rookie Topic Starter

    Yeah... that has gone thru my mind. I used one of those "computer" extensions with a small brush on it? Maybe 1" wide by 1/2" thick with 1/2" bristles. I've been using it like this for years, but yeah... its a possibility.

    I've tested the power supply and memory and both check out OK on other machines. I've tried two different video cards, mice, and keyboards. So it's at the motherboard level now, and I have one last test I'll do tomorrow night. Set it up one more time with bare essentials, and hold down the INS key whn trying to boot. Supposedly that will bypass everything.

    We'll see.
  8. john matrix

    john matrix TS Rookie

    soyo dragon no display problem

    i recently installed a new hard drive on my soyo dragon platinum and since then i have not been able to get the display to work either, i hear one long beep when i boot up the system, i have cleared cmos and reset jumpers and stripped board of everything also to no avail.I think flashing the bios would fix the problem but i am not able to see a display so i cannot do that.On the soyo tech support the beeping noise is supposed to indicate that my monitor is not plugged in or my settings on the bios are incorrect. It said to hold down the insert key when booting up but that didnt work.So basicly it appears as if installing a new hard drive has broken my motherboard some how.? Have you had any luck with this problem ?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...