SP4 installtion problem on Win2000 advance server

By novkhan ยท 5 replies
May 9, 2004
  1. SP4 installtion problem on Win2000 advance server


    OS: Advance 2000

    Service Pack 4 installation problem!

    "The file c:\winnt\system32\drivers\atapi.sys is open or in use by another application. Close all other application and then click Retry."

    I have closed all application but i kept getting this error.

    Please Help!
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Are you updating from a DVD/CD rom and using authoring Software eg. INCD-Nero? Incd runs as a service in processes that might utilize atapi driver
  3. Techn1976

    Techn1976 TS Rookie

    ERROR: atapi.sys is open or in use by another application

    do a search on your computer for atapi

    or may look for it your self in this location


    once found, make a folder on your desk top and drag the file into this one new folder

    now you can update your xp with sp1 / sp2

    once upgraded your may delete this file...
    dont worry! the sp1/sp2 installation will replace this file.



    Same Principle applys to Win2000 advance server... just search for the atapi.sys file.
  4. Goalie

    Goalie TS Booster Posts: 616

    have you tried installing sp4 from a "safe mode" state?

    Also, if you do have any CD Authoring software, chances are it starts a service. You can check your services to see if it loads any ATAPI type systems (Adaptec 4 for example does something stupid like that.) Try stopping them before installing

    Also, Techn1976.. please read the questions.. it was S2k Advance, not XP.... but Welcome to Techspot at any rate!
  5. csnow

    csnow TS Rookie

    Ok, this is an old thread, but I dropped by because my search engine hit it.

    Starting in Safe Mode did not work. The thing that solved the problem for me was uninstalling Alcohol 120%. Other CD Burner apps may lock up the Atapi driver too. Possibly could have stopped a process instead, but there was nothing obvious.

    Took me a long time to figure this out, so I figured I'd drop my solution off here in case someone else Googles by.

    Best of luck.
  6. kersentic

    kersentic TS Rookie

    I have got the same problem and confirm the alcohol source.
    I resolved it by just renaming atapi.sys , then clicked retry and it worked.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...