1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Star Wars Battlefront

By WolfCat ยท 15 replies
Sep 28, 2004
  1. Hi, i have a problem with starting the game! When i try to run it, it doesn't start. At the taskbar 2 icons appear: Battlefront and Fatal. Nothing happens then. The Task Manager shows both processes as running, but actually i cannot swich to either.
    What should i do??
    Perhaps it's because the game requires DirectX 9.0C while i have 9.0B?
    And there comes the second problem!
    I cannot update DirectX to 9.0C! The instal wizard says that "the software was not tested with Windows XP" and stops the install offering no options!
    Can this be helped?
    Thank you!
  2. ChuckSlaprock

    ChuckSlaprock TS Rookie

    Same Problem

    I have the same problem, run the game and it locks up with the same 2 icons in the taskbar, Battlefront and FATAL. I don't think it is a Dirext 9 probs as I am running 9.0c and all my other games work fine.
    I have used the system check in the help section when you start the game, and all sections passed ok.

    Have even tried to patch it with no cd exe's but to no avail.

    I am stummped, any ideas, anyone.....

  3. Grr

    Grr TS Rookie

    Me too!

    I seem to have the same problem as you both.

    Ive sent an e mail of to the LucasArts thech support dudes but nothin yet.

    If anyone knows how to fix this please say how!!!!!:eek:
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,049   +11

    Welcome to TechSpot Forums

    Check here how to install DirectX 9.0c.

    Are you all using XP SP2?
  5. ChuckSlaprock

    ChuckSlaprock TS Rookie

    Problem solved....

    I think I have a solution.

    I was using ATI Cat Driver 4.9, so I have rolled them back to Cat 4.8 and low and behold it works......YIPPEE

    So check your graphic drivers, that solved my problem.

    Good luck.
  6. WolfCat

    WolfCat TS Rookie Topic Starter

    'bout the drivers: i have GeFforce 4200 with newest drivers - doesn't seem to help.
    'bout DirectX - I have XP with SP1, may this be the cause? if yes, Mictlantecuhtli, plese, please tell me how to install SP2. Thanx!
  7. WolfCat

    WolfCat TS Rookie Topic Starter

    Turned Cryptography on, installed 9.0C, now the game runs. YEAHHAAA !!!
  8. alvin_teoh_81

    alvin_teoh_81 TS Rookie

    Hey there,

    I am having the same problems as described above. WolfCat, you mentioned turning on Cryptography. Where can I find this option? Is it part of the video driver properties?

  9. problemsky

    problemsky TS Rookie

    i'VE GOT same problem but with Windows 2000 pro. I click SW Battlefront icon, then screen blinks and nothin happens
    I've got newest drivers to my video card and DirectX 9.0c and like everyone here i passed all test for requirments...plz help......
  10. Cyborg

    Cyborg TS Rookie

    know what u mean

    i had the same problem as well but i managed to fix it by changing the color quality from 16 bit to 32 but after that i found a new problem, after playing for a few minutes some strange stuff happens to the screen and then it locks up and the only way out is to reboot the computer. iv done everything i can think of to fix it but nothing works.

    Can anyone help??? :confused:
  11. Johnny9

    Johnny9 TS Rookie

    Star Wars Battlefront Total Lockdown!!

    I downloaded the new patch (2.0) & everything went to pc hell!!
    I cannot start the game & I cannot even Uninstall the game! Thats right, Pc will NOT uninstall! When I go to "remove programs" & click Battlefront I get the same message every time! InstallShield (R) Setup Launcher has encountered a problem and needs to close. We are sorry for the inconvenience. Not as sorry as I am! Someone Please Help!!
  12. XcoreyX

    XcoreyX TS Rookie

    I have the same problem!

    HI guys i just joined this thing to get this all figured ive got 2 problems
    1. it says battlefront and FATAL at the bottom and shuts down after that
    2. I get this thing that pops up when i try to enter the game called Tnl i have every thing else can some one tell me how the hell to get this Tnl and how to fix this Fatal problem

    P.S. I was able to get in before and play the game but the sky was black but then this FATAL thing happined and i have no clue what to do thanks for your time.
  13. gogger

    gogger TS Rookie

    this is a known problem with this game, firstly anyone useing the intel pentium 4.306ghz HT should imediatly download service pack 2 as there are some major problems. secondly most games relesed after 2001 has an anti-tampering feture wich meens that if you so much as try to break into the game files without the right knowledge you will stuff the game. thirdly directx9c is VERY important its not just an optomisation update but a knew version it completely redoes the system in that format and so any game made using that directx can only work on THAT directx. and last but not least is that some games are just bung and dont work because theres a conflict or they were made on a disc that was dead in the first place so if u do all the stuff right and it still dont work then see if someone you know has the same game and ask if you can borrow it and see if it works on yor computer and vise versa then you can see if it is your computer or the game :) .
    p.s. DONT install a crack uless you are sure of the sorce as alot of them are trojans to get passwords and serials and the game has a file that stops most cracks.
  14. jarvis

    jarvis TS Rookie Posts: 83

  15. Gahlers02

    Gahlers02 TS Rookie

    For some reason I cant make an account!!!

    Whenever I try to create a new account it says 'save failed' and any time it tries to save it gives the same message. Something stranger is that when my brother signs on to his account on the computer it loads his account!!!

    His account is an administrative account and mine is a normal one.
  16. ssbtoday

    ssbtoday TS Rookie

    If you use a normal account the game has to be installed in the documents folder, hence the readme says so.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...