Spread the love! TechSpot Tech Gift Shortlist 2017

startup error when install new card

By conradguerrero ยท 5 replies
Oct 31, 2002
  1. Hi everybody!
    I just bought an agp Kyro 2 64 mb and am having a really hard time getting the driver to function. I install the thing and restart, then I get a windows protection error . If I remove kyro driver and put in my old crappy pci video card then everything works again.

    here's my system:
    300 mhz k6/2
    160 mb sdram
    tyan s1598 motherboard via mvp3
    I have the latest bios and via chipset drivers

    The video card driver I'm trying to use is the powerVR reference driver that is microsoft certified.

    I tried selective booting - no help.
    I tried to delete the *.inf file and then reinstalling the driver - again no help.

    The driver doesn't install W98file.cat.

    I have attached a pcilist diagnostic file.

    Thanks for reading all of this.:)

    Attached Files:

  2. Elcarion

    Elcarion TechSpot Paladin Posts: 169

    You might try the following:
    1) Download and install the latest VIA 4-in-1 drivers for your motherboard.
    2) Disable AGP 2X in the mobo BIOS if possible.
    3) Try using the driver made specifically for the card you have. You may need to delete the old PowerVR driver from C:/Windows/INF before installing the new driver.
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    elcarion gave good advice....

    also try resetting your BIOS to defaults....
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    "Windows Protection Error" is a decent indicator of what is going on.

    It is almost definitely because of the video card you are adding, and the reason can be caused by of three things usually.. If you hvae any questions about how to do any of what I'm about to mention, feel free to ask.

    The usual reasons that I've come across are IRQ errors, Plug and Play is turned off, or the driver was installed improperly.

    First, I would make sure "PnP OS" is enabled in your BIOS setup. If it is not enabled, I would recommend having it enabled.

    Secondly, try booting in safe mode with the Kyro installed. If it boots, then the probably is likely due to drivers. If it does not start, then there is a good possiblity of an IRQ conflict and you may need to assign manual IRQs either in the BIOS or using Windows' device manager.

    Something that might fix your IRQ problem is to reset your ESCD configuration data in the BIOS. Many BIOSes have this option, and this will cause Windows 98 to reassign IRQs.. Hopefully in your favor this time ;)

    A slightly more risky, but more effective way of fixing IRQ/driver problems is to force Windows to redect all of your hardware again. You can open your registry ( Start/Run/regedit) and then navigate to HKEY_LOCAL_MACHINE and delete the entire enum key. Be sure to have your drivers for your system handy, because you'll probably need them afterward.
  5. conradguerrero

    conradguerrero TS Rookie Topic Starter Posts: 310

    Yeah I think it's the drivers, because when I install the new card without the new driver, I don't get a windows protection error ! Also, I forgot to add that when I install the driver and boot in safe mode my floppy and CD-rom (it could be my hard drive)drive is in MS-Dos Compatability mode! :dead:
    I think this has something to do with protected-mode drivers.
    I found all of these possible reasons for my windows protection error problem:
    1. An "Unsafe" device driver hooked the int12h or int13h chain before Windows unloaded.
    2. There is a resource conflict between the disk controller and another device.
    3. The Windows protected-mode driver is missing or damaged
    4. The Windows 32-bit protected-mode disk driver detected an unsupportable configuration or incompatible hardware.

    Someone should translate what this stuff means.
    But I don't know how every kyro driver I downloaded could be giving me problems. There must be something wrong with my system configuration.

    What's everyone think?:confused:
  6. conradguerrero

    conradguerrero TS Rookie Topic Starter Posts: 310

    I have found my problem!

    I got it, the new agp video cards run at a higher power level. It's called ver. 2.0, and my motherboard runs only ver. 1.o:D

    Old Technology Sucks! :eek:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...