STOP 0000008e in Win32k.sys

By Betabob ยท 4 replies
Sep 24, 2005
  1. Hi I have a Pentium 3.2 with 2 512 Kingston ram modules

    Just recently I have been getting the stop 8 error about 1 in every 4 or 5 boots.

    The crash only happens on boot and is always win32k.sys at address bf80d278. If windows boots, everything runs fine.

    I have made some minidumps but as the exception address and details are always the same I have attached just the one dump.

    I am guessing it may be an errant driver or software but if someone could please help on what it may be.

  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    From the stack trace and the failing instruction of your debug report, I believe that it is faulty ram. Run memtest to stress your ram.

    eax=0000000c ebx=8669cc58 ecx=86179778 edx=00080000 esi=0000000c edi=86179780
    eip=bf80d278 esp=f6cc77ec ebp=f6cc77f4 iopl=0 nv up ei pl nz na po nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010206
    bf80d278 8b1e mov ebx,[esi] ds:0023:0000000c=????????

    ChildEBP RetAddr Args to Child
    WARNING: Stack unwind information not available. Following frames may be wrong.
    f6cc7340 8052202d 0000008e c0000005 bf80d278 nt!KeBugCheckEx+0x1b
    f6cc7708 804de403 f6cc7724 00000000 f6cc7778 nt!IoSetFileOrigin+0x58fb
    f6cc77f4 bf87b7ec 0000000c 8669cc58 00000000 nt!Kei386EoiHelper+0x1da
    f6cc7844 bf8c019b 86179778 86663628 00000000 win32k!EngGetCurrentCodePage+0x5de3
    f6cc7874 bf8c0149 86179778 86fac560 86663628 win32k!EngAlphaBlend+0x1039
    f6cc78ac 80589626 f6cc78f0 00000000 86179778 win32k!EngAlphaBlend+0xfe7
    f6cc78d8 8058971c bf8c00e2 f6cc78f0 00000000 nt!PsSetProcessWin32Process+0x190
    f6cc791c 80571ef1 86179778 86fac560 86663628 nt!PsSetProcessWin32Process+0x286
    f6cc7994 8056f2a8 0000002c f6cc79d4 000000c0 nt!CcUnpinDataForThread+0x741
    f6cc79e8 bf8c0d86 00000000 86fac560 00000001 nt!ObOpenObjectByName+0xda
    f6cc7ab0 bf821ff1 00350000 00000001 00000000 win32k!EngAlphaBlend+0x1c24
    f6cc7bc0 bf822a4b ffffffff f6cc7c58 f6cc7c94 win32k!EngMulDiv+0x3126
    f6cc7cc0 bf80effa 8617b5a0 00000000 00000000 win32k!EngMulDiv+0x3b80
    f6cc7cd4 bf80f100 8617b5a0 00000000 00000000 win32k!EngFreeUserMem+0x3b5d
    f6cc7cf0 80584b4f 8617b5a0 00000000 80561510 win32k!EngFreeUserMem+0x3c63
    f6cc7d54 804dd68e 000010dc 0007f460 0007f464 nt!ObSetHandleAttributes+0x16a
    f6cc7e20 7c9102d2 00000000 00000000 7c91030c nt!KiDeliverApc+0x88d
    f6cc7e3c 7c9102ed 00000001 0000ffff 00000000 ntdll!RtlQueryInformationActivationContext+0xf0
    00000000 00000000 00000000 00000000 00000000 ntdll!RtlQueryInformationActivationContext+0x10b
  3. Betabob

    Betabob TS Rookie Topic Starter

    Thanks for your help cpc2004.

    I had actually run mem86 for about 5 passes but it found no errors.

    I also ran the Windows Memory Diagnostic for about 2 hours and it also found no errors so thats why I thought maybe it wasn't memory.

    I will run mem86 for the full 9 passes and then maybe remove one memory module to see if it recoccurs.

    I find it interesting that if it boots at the opening windows screen it never crashes while using windows.

    Thanks again.
  4. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Some faulty ram can pass memtest,
  5. belkins

    belkins TS Rookie


    I ran PC doctor on an IBM Thinkpad and it came back with RAM error. Software will not always tell you that the RAM is bad. The ONLY way to test is to try a KNOWN GOOD STICK of same type of RAM. If the good stick has no issues, there's your answer. I had the same error you did, I reseated the RAM, same problem, I used another stick of KNONW GOOD RAM, no problem. Hope this helps!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...