Strange Hard Drive problem

By TonyH ยท 8 replies
Jan 13, 2003
  1. My second hard drive's (slave) icon is not displayed correctly in explorer and my computer. If you try to open it in my computer I get an error message: "setup95.exe not found". I think the hard drive is being mistaken for a cdrom drive because when you right click on it the autoplay option comes up. This problem occured when my son tried to install an old game (Earth Worm Jim 2). The game failed to install. Can anyone tell me how to fix the icon and tell windows that my hard drive is not a cdrom drive? The problem doesn't really affect anything. I can still use the drive. Its just annoying thats all.

    I'm running Windows XP Professional.
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    You could try and locate it in device manager and remove it - that would force Windows to identify it again.
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    try this:

    right click my computer, select manage.

    select disk administrator.

    right click each of your drives, select "change drive letter and path" and remove the drive letters for each.


    go back into disk administrator and give them drive letters again.

    I believe that this is some corruption in the HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices part of the registry, where perhaps two of your drives have wound up with the same hexademical label. what you have just done should sort that. if not, post back.
  4. Justin

    Justin TS Rookie Posts: 942

    Or alternatively you could disable autoplay for C: with TweakXP, or right click C, select "Explorer", then look for and delete a file called AUTORUN.INF if it exists.

    Yes, if autorun.inf exists on a disk it will try to autplay it if you attempt to open, even a local hard disk.
  5. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    That is quite strange, I never would have thought of that. Seems kind of silly if you ask me...
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    yeah, that's true. you can also write your own autorun.inf file and assign an icon to a hdd partition in the same way a cd can have a custom icon.
  7. Justin

    Justin TS Rookie Posts: 942

    I just felt a little shocked when all the suggestions were fairly drastic; reminds me of the time when I was dealing with people who 9 times out of 10, if they couldn't solve the problem within 5 minutes they thought it was best to do a format and reinstall.

    Look for the simple explanations first, before resorting to more drastic ones that could potentially cause more damage then harm, especially in the hands of the inexperienced.
  8. TonyH

    TonyH TS Rookie Topic Starter

    Thanks guys for solving my problem. Deleting the autorun.inf file on my drive D fixed everything.
  9. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    well done soul harvester!

    but how the hell you winded up with an autorun.inf on your hdd confuses me... anywayz, its fixed which is the main thing.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...