Strange hard drive problem

By Hodsocks ยท 4 replies
Nov 7, 2003
  1. The story so far: I have a 2 month old pc built by a friend of a friend and so far it has had 2 hard drives and windows Xp pro loaded on it 3 times. It has been passed to me to try and sort it out.
    I have loaded XP pro again and after a few hours it starts having problems booting with a message about the config.sys file being missing or corrupt......the same problem as before.
    I have done some diagnostic checks on it....memory....motherboard etc and can only find a strange problem with the hard drive. Whenever I try to check it out it throw up an error message.....Data boundary error.....which refers to another device wanting to use the same DMA channel. I disabled all the other IDE devices and still got the same message. I changed the HD for an old 4GB one and it ran all the tests without a I assumed there was a problem with the HD.
    I dutifully bought a new one today and loaded window XP and it all went OK. I ran my tests but still got the same error about the DMA channel.
    So now I am completely the tests I carried out on the motherboard passed OK.

    Sorry about the long message but the full story seemed necessary.....should any of you guys have any suggestions.
    Thanks in advance....before I pull whats left of my hair out.
  2. Nic

    Nic TechSpot Paladin Posts: 1,549

    It definitely sounds like a mainboard problem. Try checking for an updated bios and drivers. If that doesn't help, then disassemble everything, and rebuild the PC from scratch. If you need more help then please supply more details, such as mainboard model etc.
  3. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 382

    The mainboard is a Jetway V266B with Via chipset; memory is 256Mb PC133 SDRAM(generic); hard drive was Maxtor Diamondmax 16 (80Gb), now Hitachi Deskstar 80Gb. Graphics is a 3D power Geforce MX 32 Tv, sound is onboard.
  4. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 382

    The BIOS is the latest and I have updated to the latest 4 in 1 drivers but still the same error message appearing occasionally, although when I reboot it seems to go into windows.
    Looking at the Microsoft site for the error message I receive it seems as though the registry is becoming corrupted somehow. even though windows has only been loaded yesterday.
    Its driving me crazy.
  5. Nic

    Nic TechSpot Paladin Posts: 1,549

    The corruption is happening during read/write to the hard drive. That could be due to faulty mainboard (I/O Controller), memory, cables, or hard drive. As you've already replaced some of these, and given the error messages, I'd be inclined to suspect the mainboard is faulty.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...