Strange Realtek AC'97 Issue

By Cawfee ยท 4 replies
Nov 11, 2005
  1. Hello everyone,

    I'm having a bit of a weird problem that involves my on-board VIA sound chipset of the AC'97 type. I have recently re-formatted my OS partition and upgraded from Windows 2000 to XP. All's working fine, except the audio, even though the proper driver from the Realtek site is installed. And this is where it gets wonky.

    When Windows starts after turning the PC on, there is no sound and no speaker icon in my task bar. Instead, the Realtek entry in the Device Manager reports a "Driver Error" by displaying the little yellow (!) warning next to it and detailing with "Windows cannot load the device driver for this hardware".

    Now, if I uninstall this driver, install the one I already applied *again* and reboot, the sound will (mostly) work; on some occasions, the Multimedia Audio controller will shove itself in between the sound detection and forces me to run the driver install file again, but after that, the sound works. I can reboot all I want now and the sound will work...

    Until I turn the computer completely off. In which case, there will once again be no sound and the same issue by the next time I turn it on. In clear text, this means I have to reinstall the drivers several times everytime I start up the computer, which is getting sort of annoying.

    Now, I tried installing the drivers in Safe Mode with no success and the same results I get in "Normal" mode. If I uninstall the drivers from the Device Manager and let it detect new hardware on it's own, it will find the "Multimedia Audio Controller" *AND* the "Realtek AC'97" audio. It will then proceed to automatically install the drivers for the Realtek Audio, then prompts me with the Windows Logo verficiation warning I also get when installing the drivers from file, and upon hitting "Continue Anyway", it tells me "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing". I'm back to where I was. Yay.

    Let's sum it up:
    The sound works just fine *if* I uninstall the initial drivers marked with (!) , keep installing the drivers and rebooting until it works and I get a speaker icon in my taskbar. Sometimes this can involve rebooting and installing up to 3 times. The drivers are the latest official and correct release from Realtek. If I turn my PC off, my drivers go whacky again.

    I am not having any other issues with the system, be they of memory or other nature. Here's the system, if it helps:

    AMD Athlon 2800+
    Albatron KT600 Mainboard
    A gig o' RAM
    Realtek AC'97 Audio device
    Radeon 9600Pro 256MB DDR

    Thanks in advance for any help and hints you folks can give me!
  2. mailpup

    mailpup TS Special Forces Posts: 7,187   +470

    Uninstall the sound driver from the Add/Remove Programs in the Control Panel not the Device manager. Restart and install the fresh driver.
  3. Rik

    Rik Banned Posts: 3,814

    Ive used an ac97 for years and found that the driver from my mobo manufacturer worked the best.

    Hope that helps. Rik
  4. Cawfee

    Cawfee TS Rookie Topic Starter

    Sadly, even the complete De- and Reinstall of the sound driver didn't do the trick.

    I'd be willing to try that, but my mobo manufacturer site (Albatron) is hellishly slow, and their FTP downloads time out after about 2 minutes in (it's an 18 MB download).

    If anyone manages to grab the following file:

    ... and up it on one of the many file uploading thingies like Savefile, I'd be eternally grateful. Funnily enough, their webmaster tech support emails bounce back on me. Yay for good support :p
  5. fletchy88

    fletchy88 TS Rookie

    Hi i was reading these threads as to do with the problems people have been having with the realtek AC97' audio baloney...i have a very wierd problem, and would be appreciated to find ANYONE who may have the same problem or may even know what the hell is going on here...right here goes

    1.i have a shuttle XPC barebones SS56G v2

    ive read it has onboard sound at the actual shuttle site in the discontinued products section although im not really sure about that anymore as the realtex thing is not even listed in my device manager, the pc i got off my uncle and it had cds that came with it that have the realtek drivers on there.....SO there MUST be onboard sound with this pc otherwise why would they sell the cds with it????

    i have tried and tried, i have tried downloading drivers from, etc bla bla....bottomline IT IS NOT WORKING, i should mention that it had XP SP2 PRO on it when i got and that day installed XP MCE 2005 because basically it was knackered and i had a new 320GB HD so i thought what the hell "quick and easy fix" and so it worked the pc now runs lightning fast (i like to think lol ;) ) im am completely bafflleedddd
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...