1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Strange Video Bug (games)

By kadim ยท 4 replies
Jan 7, 2006
  1. Hello everybody, I entered computer hell a few months ago when my completely ancient geforce2 gts 32 meg graphics card stopped rendering polygons.

    Now, I figured this would be just the end of the card's life. It was something like three or four years old and the fan had stopped working on it. I had since replaced most every other part of my machine save the graphics card, so I lived with my machine not rendering 3d anything until I could afford a new card.

    Well I got a geforce4 128 meg card, and when I installed it my computer still would not render polygons. I reformatted my machine and tried again, and it worked... for about 48 hours.

    It may not be important, but I played Knights of the Old Republic on the fresh format solidly until my wife wanted a game of Diablo, so I installed Diablo, played a game, and when I went back to KotOR the game didn't load (see below). I went on to install the rest of my games and try them with similar results, some of which are listed below.

    My current machine I've built myself, it's got:

    duron 1.8 ghz processor
    foxconn 748k7aa 400 mhz fsb mainboard
    768 mb of ddr 400 ram
    onboard sound (at the moment, I've got an audigy one I yanked out to see if that was maybe causing issues)
    geforce4 mx 4000 agp with 128 meg o ram

    None of these parts were installed in my machine when the problem first came up, so I have to assume it's either a software conflict of some kind or:

    My power supply (400 watt, standard cooling)
    Lack of cooling (new cpu fan, gpu doesn't have its own fan, have a tower fan but it's old)
    My dodgy as hell cd rom drive that's due to be replaced (sometimes doesn't recognize cds, even in the command prompt. Machine still detects the drive, but the drive won't spin up)

    My software:
    Windows XP Pro sp1 (dodgy cd key prevents me from upgrading to sp2)

    Standard nvidia forceware drivers (tried omega drivers as well, no dice)


    diablo 2 (sprites with some low tech lighting, works)

    deus ex (polygons, loads but crashes the moment I hit a key)

    Star Wars: KotOR (doesn't load a new game, the old game I had after the fresh format will load but crash the moment I hit a key after loading)

    Civ 3 Conquests (works; again, sprites)

    JK2 (won't load)

    Warcraft 3 (works on first install, once I quit the game and try to reload it won't load)

    AOM: The Titans (loads menu but not game)

    None of these games offer any error messages when they quit out, they simply disappear and I find myself staring at the desktop. Does anyone have any idea what it could possibly be? I've updated every driver I can find, flashed my bios, tried alternate drivers and none seem to change anything.

    Thanks for your time

  2. mossimoboy

    mossimoboy TS Rookie Posts: 120

    ... GPU doesn't have its own fan? Its probably the GPU overheating..

    buy a zalman gpu fan (best out there that I know of) and if that doesn't fix it,
    update to the latest nVidia forceware drivers from thier website.

    And what do you mean it won't render polygons? Polygons are a shape..
    Does it not render shapes well?

    The PSU looks fine, (but how old?)

    Could be the optical drive, since these games have to load files from a CD,
    that could be causing the problems.

    Solutions: but a GPU fan, buy a new optical CD-Drive.
  3. kadim

    kadim TS Rookie Topic Starter

    The gpu came with a large heat sink on it, but no visible fan just to look at it. I didn't think much of this because it's brand new.

    By polygons I mean 3d rendering (which is achieved by grouping various triangles and texturing the surfaces of them, as we all know). Anything using 3d rendering crashes out either as its loading or once I try to enter a command after it's loaded, no error messages are given.

    The psu is going on three years old, maybe a bit older. It's nothing special, but I did buy it in America and when I moved to England last year I just flipped it over into 240v mode. I was thinking maybe that would cause trouble, though it is designed to do that.

    I'll try your suggestions, but the thing that sits wrong about the whole thing with me is that it worked fine for a day or two after a complete reformat before it started all this up again. I think I'm going to try reformatting again and see what that does as well. Honestly, I'm running out of hardware to replace, so I have to wonder if this isn't a software problem.

    Any feedback is welcome, thanks :)

  4. kadim

    kadim TS Rookie Topic Starter

    by the way, I've pulled the side panels off of my computer. No changes.
  5. robikewl

    robikewl TS Rookie

    It seems a strange issue. Try checking your RAM, HDD and ur CPU temp. If that seems Ok, take a look at the software part. Look for viruses.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...