STUPID! I accidentally disabled vgasave, need help!

By Brickdom ยท 11 replies
Nov 5, 2006
  1. I have an annoying problem! (omg a problem thats annoying)

    I was installing new vid card (nvidia fx5200), unable to install drivers, so for some reason I disabled the VGASAVE driver!.
    Now even in safe mode, enable vga mode or use last working settings... etc,display Doesn't get past xp logo screen (computer still loads normally with startup sound).
    I'm running XP pro, and have done everything with recovery console like enabling vgasave, recopying drivers.....still nothing
    I've even used different video cards and still get same result.
    I dont have XP installation cd and the recovery console i have been using is for XP Home, not Professional, wondering if works the same.
    Is there anyway to fix this without XP installation CD? Is there a way of forcing video drivers to work even though display cant get past xp logo ? (everything else seems to work fine)
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Instead of opening new threads for this problem, you should`ve bumped this one.

    I have now deleted your other threads/posts for this problem. Since I have just replied to this thread, it is now bumped back to the top of the forums.

    Regards Howard :wave: :wave:
  3. Dreyfus24

    Dreyfus24 TS Rookie

    Me TOO - I just did that this morning in an attempt to get my computer to detect my graphics card! Surely there is a way to get the vgasave to reboot or to get the computer to do something!?
  4. carlgran

    carlgran TS Rookie

    Me three! Been working on it for 2 days now. No luck. I've heard that even a repair install using the original WinXP installation cd won't work because when the repair install gets to a certain point, poof!, black screen again. What started everything going down hill was when I followed Microsoft's instructions to do a clean boot. Be warned that if you do a clean boot using msconfig panel following MS's instructions, you could lose all of your restore system points. Thats what happened to me. The clean boot process also caused the dreaded BSOD (Blue Screen of Death) to appear on my computer. I was troubleshooting that when I inadvertently clicked on "disable" in display properties while doing the troubleshooting in safe mode (safe? Yeah, right.) Anyhow I'm still working on getting VgaSave back. There's got to be a way without a complete square 1 install of the OS.
  5. smore9648

    smore9648 TS Rookie Posts: 697

    Your all screwed. :wave:

    VGASAVE is designed in Microsoft Windows to load automatically when the default designated video card driver does not work, or if a newly installed video card driver refuses to work.

    VGASAVE is enabled by default and should not be disabled. If you disable it and reboot, there is a strong chance the system may not boot, since during boot-time it is used as a fail-safe.

    Thats what you get when you click on stuff to fast and without thinking first:blush: :blackeye: :wave:
    \/ Read my signature (You have qualified)
  6. K@in

    K@in TS Rookie Posts: 36

    D'oh! D'oh! reinstall windows you numnuts
  7. smore9648

    smore9648 TS Rookie Posts: 697

    How is the re-install going?
  8. carlgran

    carlgran TS Rookie

    It was nice of you to ask, smore, but the fact of the matter is that I did not have to re-install. I did not give up that easy. I found a couple of websites that were of great help in getting vgasave enabled. They are: and
    Just by using keyboard commands with a black screen I was able to navigate to the window where enable for vgasave resides. The first couple of tries it didn't work but I kept at it and it finally worked. It helps greatly to have a second working computer to follow along with and see what your keyboard inputs are actually doing. Good luck to all that are trying to get vgasave re-enabled. It can be done. This method worked for me.
  9. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I think it can be done from recovery console as well, with command enable VgaSave. (or was it VgaSafe?)
  10. carlgran

    carlgran TS Rookie

    Thanks for the input Mictlantecuhtli. I tried the recovery console route many times with that command and with all combos of switches, etc. to no avail. I'm not saying that it can't be done in recovery console. Just that I couldn't find a way using it. I know one thing for sure though. Before I disable another service or device, I will thoroughly investigate the consequences first. Lesson learned.
  11. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    That`s great news and I for one am really pleased for you.

    Thanks for taking the time to let us know the outcome and thanks for sharing the solution. I`m sure it`ll help other members with the same problem.

    Regards Howard :)
  12. Dreyfus24

    Dreyfus24 TS Rookie

    Thats awesome that someone finally found how to do it, I myself was already purchasing a new HDD so I have just ran the new one as the master and my existing HDD as a slave to it, kept all my data and doubled my space! YAY. Might favourite the links for future referance though.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...